From: Stefan Richter <stefanr@s5r6.in-berlin.de>
To: Takashi Sakamoto <o-takashi@sakamocchi.jp>
Cc: Takashi Iwai <tiwai@suse.de>,
alsa-devel@alsa-project.org, Clemens Ladisch <clemens@ladisch.de>,
ffado-devel@lists.sf.net
Subject: Re: [RFC][PATCH v2 00/13] speakers: Add support for capture/playback of PCM/MIDI
Date: Sun, 12 Jan 2014 13:35:08 +0100 [thread overview]
Message-ID: <20140112133508.6894fe70@stein> (raw)
In-Reply-To: <52D01D47.4030004@sakamocchi.jp>
On Jan 11 Takashi Sakamoto wrote:
> (Jan 11 2014 00:57), Takashi Iwai wrote:
> > Yeah, module names aren't that important. And you can put
> > MODULE_ALIAS("snd-firewire-speakers"), if any.
>
> OK. I decide to rename the driver to 'snd-oxfw, and add the alias.
I agree that it should be renamed, and 'snd-oxfw' looks good to me. The
module alias wouldn't even be strictly necessary for a driver like this
(probably not present in initrd images etc.), but it doesn't hurt to
include it.
The constants which patch 13/13 adds to include/uapi/sound/{asound,firewire}.h
should of course be named accordingly then.
--
Stefan Richter
-=====-====- ---= -==--
http://arcgraph.de/sr/
next prev parent reply other threads:[~2014-01-12 12:35 UTC|newest]
Thread overview: 38+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-01-05 11:13 [RFC][PATCH 0/8] A new driver for OXFW970/971 based devices Takashi Sakamoto
2014-01-05 11:13 ` [PATCH 1/8] oxfw: Add skelton " Takashi Sakamoto
2014-01-05 11:13 ` [PATCH 2/8] oxfw: Read firmware version to name card Takashi Sakamoto
2014-01-05 11:13 ` [PATCH 3/8] oxfw: Add some AV/C commands for channel formation of AMDTP stream Takashi Sakamoto
2014-01-05 11:13 ` [PATCH 4/8] oxfw: Add connections and streams management Takashi Sakamoto
2014-01-05 11:13 ` [PATCH 5/8] oxfw: Add proc interface for debugging purpose Takashi Sakamoto
2014-01-05 11:13 ` [PATCH 6/8] oxfw: Add MIDI interface Takashi Sakamoto
2014-01-05 11:13 ` [PATCH 7/8] oxfw: Add PCM interface Takashi Sakamoto
2014-01-05 11:13 ` [PATCH 8/8] oxfw: Add hwdep interface Takashi Sakamoto
2014-01-05 19:46 ` [RFC][PATCH 0/8] A new driver for OXFW970/971 based devices Takashi Iwai
2014-01-06 8:33 ` Takashi Sakamoto
2014-01-07 10:07 ` Takashi Iwai
2014-01-10 15:29 ` [RFC][PATCH v2 00/13] speakers: Add support for capture/playback of PCM/MIDI Takashi Sakamoto
2014-01-10 15:29 ` [PATCH 01/13] speakers: move to its own directory Takashi Sakamoto
2014-01-10 15:29 ` [PATCH 02/13] speakers: Split stream functionality to a new file and add a header file Takashi Sakamoto
2014-01-10 15:29 ` [PATCH 03/13] speakers: Split PCM functionality to a new file Takashi Sakamoto
2014-01-10 15:29 ` [PATCH 04/13] speakers: Split control " Takashi Sakamoto
2014-01-10 15:29 ` [PATCH 05/13] speakers: Change the way to name card Takashi Sakamoto
2014-01-10 15:29 ` [PATCH 06/13] speakers: Change the way to make PCM rules/constraints Takashi Sakamoto
2014-01-12 12:18 ` Stefan Richter
2014-01-12 14:44 ` Takashi Sakamoto
2014-01-30 14:21 ` Stefan Richter
2014-02-01 6:31 ` Takashi Sakamoto
2014-02-02 15:45 ` Stefan Richter
2014-02-03 3:07 ` Takashi Sakamoto
2014-01-10 15:29 ` [PATCH 07/13] speakers: Add proc interface for debugging purpose Takashi Sakamoto
2014-01-10 15:29 ` [PATCH 08/13] speakers: Change the way to start stream Takashi Sakamoto
2014-01-10 15:29 ` [PATCH 09/13] speakers: Add some AV/C commands to get stream formation and supported sampling rates Takashi Sakamoto
2014-01-10 15:29 ` [PATCH 10/13] speakers: Add support for Behringer/Mackie devices Takashi Sakamoto
2014-01-10 15:29 ` [PATCH 11/13] speakers: Add support AMDTP in-stream and PCM capture Takashi Sakamoto
2014-01-10 15:29 ` [PATCH 12/13] speakers: Add support for capture/playback MIDI messages Takashi Sakamoto
2014-01-10 15:29 ` [PATCH 13/13] speakers: Add hwdep interface Takashi Sakamoto
2014-01-10 15:45 ` [RFC][PATCH v2 00/13] speakers: Add support for capture/playback of PCM/MIDI Clemens Ladisch
2014-01-10 15:57 ` Takashi Iwai
2014-01-10 16:18 ` Takashi Sakamoto
2014-01-12 12:35 ` Stefan Richter [this message]
2014-01-12 14:53 ` Takashi Sakamoto
2014-01-10 15:59 ` Takashi Sakamoto
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20140112133508.6894fe70@stein \
--to=stefanr@s5r6.in-berlin.de \
--cc=alsa-devel@alsa-project.org \
--cc=clemens@ladisch.de \
--cc=ffado-devel@lists.sf.net \
--cc=o-takashi@sakamocchi.jp \
--cc=tiwai@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox