From: Vinod Koul <vinod.koul@intel.com>
To: Takashi Iwai <tiwai@suse.de>
Cc: alsa-devel@alsa-project.org, patches.audio@intel.com,
lgirdwood@gmail.com, broonie@kernel.org,
Jeeja KP <jeeja.kp@intel.com>,
"Subhransu S. Prusty" <subhransu.s.prusty@intel.com>
Subject: Re: [RFC 07/11] ALSA: hda - add generic functions to set hdac stream params
Date: Tue, 14 Apr 2015 10:08:49 +0530 [thread overview]
Message-ID: <20150414043849.GH2963@intel.com> (raw)
In-Reply-To: <s5h6190p745.wl-tiwai@suse.de>
On Mon, Apr 13, 2015 at 02:04:10PM +0200, Takashi Iwai wrote:
> At Sun, 12 Apr 2015 18:06:14 +0530,
> Subhransu S. Prusty wrote:
> >
> > From: Jeeja KP <jeeja.kp@intel.com>
> >
> > This will be used by hda controller driver to
> > setup stream params in prepare. This function will
> > setup the bdl and periods.
> >
> > Signed-off-by: Jeeja KP <jeeja.kp@intel.com>
> > Signed-off-by: Subhransu S. Prusty <subhransu.s.prusty@intel.com>
> > Signed-off-by: Vinod Koul <vinod.koul@intel.com>
> > ---
> > include/sound/hdaudio.h | 2 ++
> > sound/hda/hdac_stream.c | 29 +++++++++++++++++++++++++++++
> > 2 files changed, 31 insertions(+)
> >
> > diff --git a/include/sound/hdaudio.h b/include/sound/hdaudio.h
> > index 5fc6d81..1f9f4ec 100644
> > --- a/include/sound/hdaudio.h
> > +++ b/include/sound/hdaudio.h
> > @@ -364,6 +364,8 @@ void snd_hdac_stream_sync(struct hdac_stream *azx_dev, bool start,
> > unsigned int streams);
> > void snd_hdac_stream_timecounter_init(struct hdac_stream *azx_dev,
> > unsigned int streams);
> > +int snd_set_hdac_stream_params(struct hdac_stream *azx_dev,
> > + unsigned int format_val);
> >
> > /*DSP loader functions */
> > int snd_hdac_load_dsp_prepare(struct hdac_stream *azx_dev, unsigned int format,
> > diff --git a/sound/hda/hdac_stream.c b/sound/hda/hdac_stream.c
> > index 394fd15..ce25f8f 100644
> > --- a/sound/hda/hdac_stream.c
> > +++ b/sound/hda/hdac_stream.c
> > @@ -472,6 +472,35 @@ void snd_hdac_stream_sync(struct hdac_stream *azx_dev, bool start,
> > }
> > EXPORT_SYMBOL_GPL(snd_hdac_stream_sync);
> >
> > +int snd_set_hdac_stream_params(struct hdac_stream *azx_dev,
> > + unsigned int format_val)
>
> I'd name it a bit more consistently, e.g. snd_hdac_stream_set_format()
> or snd_hdac_stream_set_params() or so.
Ah thats a bad miss on our side, will fix in next rev
>
> > +{
> > +
> > + unsigned int bufsize, period_bytes;
> > + struct snd_pcm_substream *substream = azx_dev->substream;
> > + struct snd_pcm_runtime *runtime = substream->runtime;
>
> I would do a NULL check for substream to be sure.
sure...
--
~Vinod
next prev parent reply other threads:[~2015-04-14 4:43 UTC|newest]
Thread overview: 31+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-04-12 12:36 [RFC 00/11] ASoC: hda - Add ASoC Skylake HD audio driver Subhransu S. Prusty
2015-04-12 12:36 ` [RFC 01/11] ALSA: hda - add id table support for hdac device/driver Subhransu S. Prusty
2015-04-13 11:46 ` Takashi Iwai
2015-04-14 4:34 ` Vinod Koul
2015-04-12 12:36 ` [RFC 02/11] ALSA: hda - Add generic helper function to register/unregister driver Subhransu S. Prusty
2015-04-13 11:50 ` Takashi Iwai
2015-04-12 12:36 ` [RFC 03/11] ALSA: hda - add generic function to unregister all devices on bus Subhransu S. Prusty
2015-04-13 11:54 ` Takashi Iwai
2015-04-14 4:36 ` Vinod Koul
2015-04-12 12:36 ` [RFC 04/11] ALSA: hda: corrected snd_hdac_stream_init() declaration Subhransu S. Prusty
2015-04-13 11:52 ` Takashi Iwai
2015-04-14 4:36 ` Vinod Koul
2015-04-12 12:36 ` [RFC 05/11] ALSA: hda - exported link_reset enter/exit Subhransu S. Prusty
2015-04-13 12:04 ` Takashi Iwai
2015-04-14 4:37 ` Vinod Koul
2015-04-12 12:36 ` [RFC 06/11] ALSA: hda - moved alloc/free stream pages function to controller library Subhransu S. Prusty
2015-04-12 12:36 ` [RFC 07/11] ALSA: hda - add generic functions to set hdac stream params Subhransu S. Prusty
2015-04-13 12:04 ` Takashi Iwai
2015-04-14 4:38 ` Vinod Koul [this message]
2015-04-12 12:36 ` [RFC 08/11] ASoC: hda - add Skylake platform driver Subhransu S. Prusty
2015-04-12 12:36 ` [RFC 09/11] ALSA: hda - moved interrupt handler to controller library Subhransu S. Prusty
2015-04-13 12:01 ` Takashi Iwai
2015-04-14 4:43 ` Vinod Koul
2015-04-14 5:22 ` Takashi Iwai
2015-04-12 12:36 ` [RFC 10/11] ASoC: hda - add Skylake HD audio driver Subhransu S. Prusty
2015-04-13 12:00 ` Takashi Iwai
2015-04-14 4:44 ` Vinod Koul
2015-04-12 12:36 ` [RFC 11/11] ASoC: hda - enable ASoC " Subhransu S. Prusty
2015-04-13 12:01 ` Takashi Iwai
2015-04-14 4:46 ` Vinod Koul
2015-04-14 5:23 ` Takashi Iwai
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20150414043849.GH2963@intel.com \
--to=vinod.koul@intel.com \
--cc=alsa-devel@alsa-project.org \
--cc=broonie@kernel.org \
--cc=jeeja.kp@intel.com \
--cc=lgirdwood@gmail.com \
--cc=patches.audio@intel.com \
--cc=subhransu.s.prusty@intel.com \
--cc=tiwai@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox