From: Vinod Koul <vinod.koul@intel.com>
To: Takashi Iwai <tiwai@suse.de>
Cc: alsa-devel@alsa-project.org, intel-gfx@lists.freedesktop.org,
daniel.vetter@intel.com,
David Henningsson <david.henningsson@canonical.com>
Subject: Re: [PATCH 1/4] drm/i915: Add audio hotplug info struct
Date: Wed, 22 Jul 2015 19:43:23 +0530 [thread overview]
Message-ID: <20150722141323.GX23525@localhost> (raw)
In-Reply-To: <s5hy4i8h8pw.wl-tiwai@suse.de>
On Wed, Jul 22, 2015 at 10:55:55AM +0200, Takashi Iwai wrote:
> On Wed, 22 Jul 2015 10:50:03 +0200,
> David Henningsson wrote:
> >
> > >> struct i915_audio_component {
> > >> struct device *dev;
> > >> + struct hdac_bus *hdac_bus;
> > >
> > > If we want to be more generic, using a struct device would be better,
> > > e.g.
> > > struct device *audio_dev;
> >
> > Does this work? If we want to have the hdac_bus.dev ptr instead of a
> > hdac_bus ptr, there does not seem to be an obvious way to go from the
> > audio_dev back to the hdac_bus struct (as snd_hdac_bus_init takes an
> > arbitrary dev pointer).
>
> Hrm, right, currently it's not straightforward. Scratch the idea,
> then.
That depends on the device we register this with. Actually this makes more
sense to me :)
If we register with struct device *audio_dev, which in this case would be
the codec device we create while probing the bus. This way you are linking i915
ops to the codec device. Ofcourse hdac_device has bus pointer but you can
invoke device callback without even searching for the device :)
--
~Vinod
>
>
> > >> + void (*hotplug_notify)(struct hdac_bus *, const struct i915_audio_hotplug_info *);
> > >> + } *cb_ops;
> > >
> > > cb_ops doesn't sound intuitive. Any better name?
> >
> > I was thinking of it as "callback ops", i e, calls that go in the
> > reverse direction compared to the already existing "ops".
> >
> > But if we call the device "audio_dev" as you suggested above, then maybe
> > "audio_ops" would be nice and symmetric?
>
> Yes, it sounds better.
>
>
> Takashi
--
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/intel-gfx
next prev parent reply other threads:[~2015-07-22 14:13 UTC|newest]
Thread overview: 24+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-07-21 7:57 [PATCH 0/4] i915 to call hda driver on HDMI plug/unplug David Henningsson
2015-07-21 7:57 ` [PATCH 1/4] drm/i915: Add audio hotplug info struct David Henningsson
2015-07-22 8:22 ` Takashi Iwai
2015-07-22 8:50 ` David Henningsson
2015-07-22 8:55 ` Takashi Iwai
2015-07-22 14:13 ` Vinod Koul [this message]
2015-07-22 17:52 ` David Henningsson
2015-07-22 20:31 ` Takashi Iwai
2015-07-23 3:43 ` Vinod Koul
2015-07-23 6:17 ` David Henningsson
2015-07-23 6:25 ` David Henningsson
2015-07-23 10:02 ` Takashi Iwai
2015-07-21 7:57 ` [PATCH 2/4] drm/i915: Call audio hotplug notify function David Henningsson
2015-07-21 9:14 ` Daniel Vetter
2015-07-21 14:26 ` David Henningsson
2015-07-21 7:57 ` [PATCH 3/4] ALSA: hda - Dispatch incoming HDMI hotplug i915 callback David Henningsson
2015-07-22 8:30 ` Takashi Iwai
2015-07-22 13:56 ` Vinod Koul
2015-07-22 14:01 ` Takashi Iwai
2015-07-21 7:57 ` [PATCH 4/4] ALSA: hda - Wake the codec up on hotplug notify events David Henningsson
2015-07-21 17:37 ` [PATCH 0/4] i915 to call hda driver on HDMI plug/unplug R, Durgadoss
2015-07-22 8:50 ` Takashi Iwai
2015-07-22 15:53 ` David Henningsson
-- strict thread matches above, loose matches on Subject: below --
2015-07-22 15:28 [PATCH v2 " David Henningsson
2015-07-22 15:28 ` [PATCH 1/4] drm/i915: Add audio hotplug info struct David Henningsson
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20150722141323.GX23525@localhost \
--to=vinod.koul@intel.com \
--cc=alsa-devel@alsa-project.org \
--cc=daniel.vetter@intel.com \
--cc=david.henningsson@canonical.com \
--cc=intel-gfx@lists.freedesktop.org \
--cc=tiwai@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox