Alsa-Devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Vinod Koul <vinod.koul@intel.com>
To: Lars-Peter Clausen <lars@metafoo.de>
Cc: Linux-ALSA <alsa-devel@alsa-project.org>,
	Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>,
	Takashi Iwai <tiwai@suse.de>,
	Mengdong Lin <mengdong.lin@intel.com>,
	Mark Brown <broonie@kernel.org>,
	Pierre-Louis Bossart <pierre-louis.bossart@linux.intel.com>,
	Jin Yao <yao.jin@linux.intel.co>, Simon <horms@verge.net.au>
Subject: Re: [PATCH 1/4] ASoC: rt286: rt286_mic_detect() uses component
Date: Wed, 26 Oct 2016 09:20:45 +0530	[thread overview]
Message-ID: <20161026035045.GB3000@localhost> (raw)
In-Reply-To: <5a1187a2-521a-0cd7-856a-ffdc69a045ed@metafoo.de>

On Mon, Oct 24, 2016 at 11:19:17AM +0200, Lars-Peter Clausen wrote:
> On 10/24/2016 09:43 AM, Kuninori Morimoto wrote:
> > Hi
> > 
> >>>> From: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
> >>>>
> >>>> Intel broadwell is using card->codec_dev_list, but it will be
> >>>> replaced to component list soon. Then, it will not be able to use
> >>>> "codec".
> >>>
> >>> Can't it be deduced by a simple container_of()?
> >>
> >> There is the snd_soc_component_to_codec() helper for this.
> > 
> > The points are
> >  1) We would like to remove "codec" related functions
> 
> The focus at the moment is to remove all special handling of CODECs from the
> ASoC core. And trying to do this without being too invasive and causing too
> many changes all over the place.
> 
> >  2) We can get "codec" pointer by above function/macro,
> >     but "codec" function/macro is using codec->component inside.
> > 
> 
> That's not a problem though.
> 
> This is slightly unrelated to this series, but these drivers should not be
> poking the internal data structures of snd_soc_card in the first place. The
> best way to get the pointer to the CODEC is by using the DAI link init
> callback. This also means that there is no need to run a lookup each time
> the CODEC is needed. An alternative is to add a helper function in the core
> that allows to lookup a component by name.
> 
> Maybe somebody from the Intel side can look into fixing this. The affected
> boards are cht_bsw_rt5672 and broadwell, which both access the cards
> codec_dev_list field.

This also exists in some customer SKL machines.

I agree that this may not be best implementation so I can send a patch for
this.

As Lars suggested we can use DAI link init callback, but then I dont feel it
is right to use rtd->codec to get codec pointer, again we will be looking
into rtd internals. So would make sense to combine two suggestion and add an
API:

struct snd_soc_codec *snd_soc_get_codec(struct snd_soc_pcm_runtime *rtd)
{
	return rtd->codec;
}

then we can use this is drivers.

Let me know if all are in agreement, I can test this and send out..

Thanks
-- 
~Vinod

  reply	other threads:[~2016-10-26  3:41 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-10-21  4:28 [PATCH 0/5] ASoC: Component has suspend/resume support Kuninori Morimoto
2016-10-21  4:29 ` [PATCH 1/4] ASoC: rt286: rt286_mic_detect() uses component Kuninori Morimoto
2016-10-24  6:57   ` Takashi Iwai
2016-10-24  7:06     ` Lars-Peter Clausen
2016-10-24  7:43       ` Kuninori Morimoto
2016-10-24  9:19         ` Lars-Peter Clausen
2016-10-26  3:50           ` Vinod Koul [this message]
2016-10-26  4:48             ` Kuninori Morimoto
2016-10-26 16:06               ` Vinod Koul
2016-10-26  6:56             ` Lars-Peter Clausen
2016-10-26 16:08               ` Vinod Koul
2016-10-26 12:12             ` Mark Brown
2016-10-21  4:29 ` [PATCH 2/4] ASoC: rt5670: rt5670_jack_suspend/resume() " Kuninori Morimoto
2016-10-21  4:31 ` [PATCH 3/4] ASoC: core: add component_dev_list on Card Kuninori Morimoto
2016-10-21  4:32 ` [PATCH 4/4] ASoC: add Component level suspend/resume Kuninori Morimoto

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20161026035045.GB3000@localhost \
    --to=vinod.koul@intel.com \
    --cc=alsa-devel@alsa-project.org \
    --cc=broonie@kernel.org \
    --cc=horms@verge.net.au \
    --cc=kuninori.morimoto.gx@renesas.com \
    --cc=lars@metafoo.de \
    --cc=mengdong.lin@intel.com \
    --cc=pierre-louis.bossart@linux.intel.com \
    --cc=tiwai@suse.de \
    --cc=yao.jin@linux.intel.co \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox