From: Peter Ujfalusi <peter.ujfalusi@linux.intel.com>
To: lgirdwood@gmail.com, broonie@kernel.org
Cc: alsa-devel@alsa-project.org,
pierre-louis.bossart@linux.intel.com,
ranjani.sridharan@linux.intel.com, kai.vehmanen@linux.intel.com,
daniel.baluta@nxp.com, rander.wang@intel.com
Subject: [PATCH 0/9] ASoC: SOF: Use generic IPC type identifiers
Date: Tue, 19 Sep 2023 13:42:17 +0300 [thread overview]
Message-ID: <20230919104226.32239-1-peter.ujfalusi@linux.intel.com> (raw)
Hi,
rename the IPC type defines to be more generic and intuitive:
SOF_IPC -> SOF_IPC_TYPE_3
SOF_INTEL_IPC4 -> SOF_IPC_TYPE_4
No functional change, just renaming all around.
Regards,
Peter
---
Peter Ujfalusi (9):
ASoC: SOF: Introduce generic names for IPC types
ASoC: SOF: sof-pci-dev: Update the ipc_type module parameter
description
ASoC: SOF: Kconfig: Rename SND_SOC_SOF_INTEL_IPC4 to SND_SOC_SOF_IPC4
ASoC: SOF: Use generic names for IPC types
ASoC: SOF: amd: Use generic names for IPC types
ASoC: SOF: imx: Use generic names for IPC types
ASoC: SOF: Intel: Use generic names for IPC types
ASoC: SOF: mediatek: Use generic names for IPC types
ASoC: SOF: Drop unused IPC type defines
include/sound/sof.h | 4 +-
sound/soc/sof/Kconfig | 2 +-
sound/soc/sof/Makefile | 4 +-
sound/soc/sof/amd/pci-rmb.c | 10 +-
sound/soc/sof/amd/pci-rn.c | 10 +-
sound/soc/sof/amd/pci-vangogh.c | 10 +-
sound/soc/sof/imx/imx8.c | 20 +--
sound/soc/sof/imx/imx8m.c | 10 +-
sound/soc/sof/imx/imx8ulp.c | 10 +-
sound/soc/sof/intel/Kconfig | 14 +-
sound/soc/sof/intel/apl.c | 4 +-
sound/soc/sof/intel/bdw.c | 10 +-
sound/soc/sof/intel/byt.c | 30 ++--
sound/soc/sof/intel/cnl.c | 4 +-
sound/soc/sof/intel/hda-dai-ops.c | 4 +-
sound/soc/sof/intel/hda-dai.c | 4 +-
sound/soc/sof/intel/hda-loader.c | 2 +-
sound/soc/sof/intel/hda.c | 2 +-
sound/soc/sof/intel/icl.c | 4 +-
sound/soc/sof/intel/pci-apl.c | 36 ++---
sound/soc/sof/intel/pci-cnl.c | 54 ++++----
sound/soc/sof/intel/pci-icl.c | 36 ++---
sound/soc/sof/intel/pci-lnl.c | 10 +-
sound/soc/sof/intel/pci-mtl.c | 12 +-
sound/soc/sof/intel/pci-skl.c | 20 +--
sound/soc/sof/intel/pci-tgl.c | 144 ++++++++++----------
sound/soc/sof/intel/pci-tng.c | 10 +-
sound/soc/sof/intel/tgl.c | 4 +-
sound/soc/sof/ipc.c | 6 +-
sound/soc/sof/ipc3-dtrace.c | 2 +-
sound/soc/sof/mediatek/mt8186/mt8186.c | 20 +--
sound/soc/sof/mediatek/mt8195/mt8195.c | 10 +-
sound/soc/sof/sof-acpi-dev.c | 8 +-
sound/soc/sof/sof-client-ipc-msg-injector.c | 4 +-
sound/soc/sof/sof-client-probes.c | 6 +-
sound/soc/sof/sof-client.c | 26 ++--
sound/soc/sof/sof-of-dev.c | 6 +-
sound/soc/sof/sof-pci-dev.c | 2 +-
38 files changed, 286 insertions(+), 288 deletions(-)
--
2.42.0
next reply other threads:[~2023-09-19 10:43 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-09-19 10:42 Peter Ujfalusi [this message]
2023-09-19 10:42 ` [PATCH 1/9] ASoC: SOF: Introduce generic names for IPC types Peter Ujfalusi
2023-09-19 10:42 ` [PATCH 2/9] ASoC: SOF: sof-pci-dev: Update the ipc_type module parameter description Peter Ujfalusi
2023-09-19 10:42 ` [PATCH 3/9] ASoC: SOF: Kconfig: Rename SND_SOC_SOF_INTEL_IPC4 to SND_SOC_SOF_IPC4 Peter Ujfalusi
2023-09-19 10:42 ` [PATCH 4/9] ASoC: SOF: Use generic names for IPC types Peter Ujfalusi
2023-09-19 10:42 ` [PATCH 5/9] ASoC: SOF: amd: " Peter Ujfalusi
2023-09-19 10:42 ` [PATCH 6/9] ASoC: SOF: imx: " Peter Ujfalusi
2023-09-19 10:42 ` [PATCH 7/9] ASoC: SOF: Intel: " Peter Ujfalusi
2023-09-19 10:42 ` [PATCH 8/9] ASoC: SOF: mediatek: " Peter Ujfalusi
2023-09-19 10:42 ` [PATCH 9/9] ASoC: SOF: Drop unused IPC type defines Peter Ujfalusi
2023-09-21 16:30 ` [PATCH 0/9] ASoC: SOF: Use generic IPC type identifiers Mark Brown
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20230919104226.32239-1-peter.ujfalusi@linux.intel.com \
--to=peter.ujfalusi@linux.intel.com \
--cc=alsa-devel@alsa-project.org \
--cc=broonie@kernel.org \
--cc=daniel.baluta@nxp.com \
--cc=kai.vehmanen@linux.intel.com \
--cc=lgirdwood@gmail.com \
--cc=pierre-louis.bossart@linux.intel.com \
--cc=rander.wang@intel.com \
--cc=ranjani.sridharan@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox