From: AngeloGioacchino Del Regno <angelogioacchino.delregno@collabora.com>
To: "Trevor Wu (吳文良)" <Trevor.Wu@mediatek.com>,
"lgirdwood@gmail.com" <lgirdwood@gmail.com>,
"matthias.bgg@gmail.com" <matthias.bgg@gmail.com>,
"broonie@kernel.org" <broonie@kernel.org>,
"tiwai@suse.com" <tiwai@suse.com>,
"perex@perex.cz" <perex@perex.cz>
Cc: "linux-arm-kernel@lists.infradead.org"
<linux-arm-kernel@lists.infradead.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"linux-mediatek@lists.infradead.org"
<linux-mediatek@lists.infradead.org>,
"alsa-devel@alsa-project.org" <alsa-devel@alsa-project.org>
Subject: Re: [PATCH 1/3] ASoC: mediatek: mt8188-mt6359: support dynamic pinctrl
Date: Wed, 26 Jul 2023 08:43:54 +0200 [thread overview]
Message-ID: <320ab7cc-32dd-79dd-b2ae-96d3608aeb9c@collabora.com> (raw)
In-Reply-To: <69690b530fb46d6adad1732d570c8cfad9c0f23c.camel@mediatek.com>
Il 26/07/23 04:19, Trevor Wu (吳文良) ha scritto:
> On Tue, 2023-07-25 at 09:06 +0200, AngeloGioacchino Del Regno wrote:
>> Il 25/07/23 05:53, Trevor Wu ha scritto:
>>> To avoid power leakage, it is recommended to replace the default
>>> pinctrl
>>> state with dynamic pinctrl since certain audio pinmux functions can
>>> remain in a HIGH state even when audio is disabled. Linking pinctrl
>>> with
>>> DAPM using SND_SOC_DAPM_PINCTRL will ensure that audio pins remain
>>> in
>>> GPIO mode by default and only switch to an audio function when
>>> necessary.
>>>
>>> Signed-off-by: Trevor Wu <trevor.wu@mediatek.com>
>>> ---
>>> sound/soc/mediatek/mt8188/mt8188-mt6359.c | 21
>>> +++++++++++++++++++++
>>> 1 file changed, 21 insertions(+)
>>>
>>> diff --git a/sound/soc/mediatek/mt8188/mt8188-mt6359.c
>>> b/sound/soc/mediatek/mt8188/mt8188-mt6359.c
>>> index 7c9e08e6a4f5..667d79f33bf2 100644
>>> --- a/sound/soc/mediatek/mt8188/mt8188-mt6359.c
>>> +++ b/sound/soc/mediatek/mt8188/mt8188-mt6359.c
>>> @@ -246,6 +246,11 @@ static const struct snd_soc_dapm_widget
>>> mt8188_mt6359_widgets[] = {
>>> SND_SOC_DAPM_MIC("Headset Mic", NULL),
>>> SND_SOC_DAPM_SINK("HDMI"),
>>> SND_SOC_DAPM_SINK("DP"),
>>> +
>>> + /* dynamic pinctrl */
>>> + SND_SOC_DAPM_PINCTRL("ETDM_SPK_PIN", "aud_etdm_spk_on",
>>> "aud_etdm_spk_off"),
>>> + SND_SOC_DAPM_PINCTRL("ETDM_HP_PIN", "aud_etdm_hp_on",
>>> "aud_etdm_hp_off"),
>>> + SND_SOC_DAPM_PINCTRL("MTKAIF_PIN", "aud_mtkaif_on",
>>> "aud_mtkaif_off"),
>>> };
>>>
>>> static const struct snd_kcontrol_new mt8188_mt6359_controls[] = {
>>> @@ -267,6 +272,7 @@ static int
>>> mt8188_mt6359_mtkaif_calibration(struct snd_soc_pcm_runtime *rtd)
>>> snd_soc_rtdcom_lookup(rtd, AFE_PCM_NAME);
>>> struct snd_soc_component *cmpnt_codec =
>>> asoc_rtd_to_codec(rtd, 0)->component;
>>> + struct snd_soc_dapm_widget *pin_w = NULL, *w;
>>> struct mtk_base_afe *afe;
>>> struct mt8188_afe_private *afe_priv;
>>> struct mtkaif_param *param;
>>> @@ -306,6 +312,18 @@ static int
>>> mt8188_mt6359_mtkaif_calibration(struct snd_soc_pcm_runtime *rtd)
>>> return 0;
>>> }
>>>
>>> + for_each_card_widgets(rtd->card, w) {
>>> + if (!strcmp(w->name, "MTKAIF_PIN")) {
>>
>> if (strncmp(w->name, "MTKAIF_PIN", strlen(w->name) == 0) {
>> pin_w = w;
>> break;
>> }
>>
>> That's safer.
>>
>
> If w->name is MTKAIF, the strncmp expression will return 0. However,
> the result is not expected. I prefer to keep strcmp here.
>
You could also do, instead
if (strncmp(w->name, "MTKAIF_PIN", strlen("MTKAIF_PIN") == 0))
...solving your concern.
Regards,
Angelo
>>> + pin_w = w;
>>> + break;
>>> + }
>>> + }
>>> +
>>> + if (!pin_w)
>>
>> Just a nitpick: you're checking for `if (pin_w)` later in this
>> function, so
>> to increase readability please do the same here.
>>
>> if (pin_w)
>> dapm_pinctrl_event(...)
>> else
>> dev_dbg(...)
>>
>
> OK. I will update it in v2.
>
> Thanks,
> Trevor
next prev parent reply other threads:[~2023-07-26 6:45 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-07-25 3:53 [PATCH 0/3] ASoC: mt8188-mt6359: add SOF support Trevor Wu
2023-07-25 3:53 ` [PATCH 1/3] ASoC: mediatek: mt8188-mt6359: support dynamic pinctrl Trevor Wu
2023-07-25 7:06 ` AngeloGioacchino Del Regno
2023-07-26 2:19 ` Trevor Wu (吳文良)
2023-07-26 6:43 ` AngeloGioacchino Del Regno [this message]
2023-07-26 11:36 ` Trevor Wu (吳文良)
2023-07-26 11:54 ` AngeloGioacchino Del Regno
2023-07-27 2:03 ` Trevor Wu (吳文良)
2023-07-31 13:35 ` AngeloGioacchino Del Regno
2023-07-25 3:53 ` [PATCH 2/3] ASoC: mediatek: common: revise SOF common code Trevor Wu
2023-07-25 3:53 ` [PATCH 3/3] ASoC: mediatek: mt8188-mt6359: add SOF support Trevor Wu
2023-07-25 7:11 ` AngeloGioacchino Del Regno
2023-07-26 2:25 ` Trevor Wu (吳文良)
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=320ab7cc-32dd-79dd-b2ae-96d3608aeb9c@collabora.com \
--to=angelogioacchino.delregno@collabora.com \
--cc=Trevor.Wu@mediatek.com \
--cc=alsa-devel@alsa-project.org \
--cc=broonie@kernel.org \
--cc=lgirdwood@gmail.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mediatek@lists.infradead.org \
--cc=matthias.bgg@gmail.com \
--cc=perex@perex.cz \
--cc=tiwai@suse.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox