From mboxrd@z Thu Jan 1 00:00:00 1970 From: Takashi Sakamoto Subject: Re: [PATCH 5/6] control: add a function to add an element of bytes type Date: Tue, 23 Feb 2016 18:22:50 +0900 Message-ID: <56CC24EA.8060505@sakamocchi.jp> References: <1456188510-7189-1-git-send-email-o-takashi@sakamocchi.jp> <1456188510-7189-6-git-send-email-o-takashi@sakamocchi.jp> <56CC18EE.1070800@ladisch.de> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii"; Format="flowed" Content-Transfer-Encoding: 7bit Return-path: Received: from smtp310.phy.lolipop.jp (smtp310.phy.lolipop.jp [210.157.22.78]) by alsa0.perex.cz (Postfix) with ESMTP id 42A3B260535 for ; Tue, 23 Feb 2016 10:22:53 +0100 (CET) In-Reply-To: <56CC18EE.1070800@ladisch.de> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: alsa-devel-bounces@alsa-project.org Sender: alsa-devel-bounces@alsa-project.org To: Clemens Ladisch , tiwai@suse.de, perex@perex.cz Cc: alsa-devel@alsa-project.org List-Id: alsa-devel@alsa-project.org Hi, On Feb 23 2016 17:31, Clemens Ladisch wrote: > Takashi Sakamoto wrote: >> ALSA Ctl core allows userspace applications to add elements of bytes type, >> while there's no APIs for this purpose in alsa-lib. >> >> This commit adds the missing function. > >> /** >> + * \brief Create and add an user-defined control element of bytes type. >> + * \param[in] ctl CTL handle. >> + * \param[in,out] id ID of the new control element. >> + * \param[in] channels The number of channels which a control element includes. > > For this control type, "count" might be a better name. > Or at least say in the description that this is the number of bytes. For the name of this variable, I don't mind using 'count'. But then, in next commit, snd_ctl_elem_add_bytes_set() has two arguments named 'count'. And the consistency of API design is lost a bit. I think that naming the variables depends on interpretation of 'struct snd_ctl_elem_value', therefore it mostly depends on taste of each developers. For example, to 'bytes' type element set, we can interpret 'struct snd_ctl_elem_value.bytes' as either 'byte array in an element' or 'data for each channels with int8_t (=char) value for an element'. So I propose the design of ALSA control core. If possible, I'd like to follow the design when adding new APIs for a consistent representation. If the proposed design is not propper, we can change the design for better shape. (but it will sometimes be a dull work depending on taste of each developers.) And, I note that the name of 'channel' is picked up from Mixer APIs in alsa-lib. It doesn't come from my brain ;) Thanks Takashi Sakamoto