From: Thomas Gleixner <tglx@linutronix.de>
To: Andy Shevchenko <andy.shevchenko@gmail.com>
Cc: Ulf Hansson <ulf.hansson@linaro.org>,
"maintainer:X86 ARCHITECTURE \(32-BIT AND 64-BIT\)"
<x86@kernel.org>, Viresh Kumar <viresh.kumar@linaro.org>,
ALSA Development Mailing List <alsa-devel@alsa-project.org>,
Platform Driver <platform-driver-x86@vger.kernel.org>,
Jacob Pan <jacob.jun.pan@linux.intel.com>,
Srinivas Pandruvada <srinivas.pandruvada@linux.intel.com>,
Amit Kucheria <amit.kucheria@verdurent.com>,
Mark Gross <mgross@linux.intel.com>,
Herbert Xu <herbert@gondor.apana.org.au>,
Chanwoo Choi <cw00.choi@samsung.com>,
Daniel Lezcano <daniel.lezcano@linaro.org>,
ACPI Devel Maling List <linux-acpi@vger.kernel.org>,
linux-pci@vger.kernel.org, Darren Hart <dvhart@infradead.org>,
Zhang Rui <rui.zhang@intel.com>,
Guenter Roeck <linux@roeck-us.net>, Len Brown <lenb@kernel.org>,
Jean Delvare <jdelvare@suse.com>,
Linux PM <linux-pm@vger.kernel.org>,
linux-mmc <linux-mmc@vger.kernel.org>,
Bjorn Helgaas <bhelgaas@google.com>,
Takashi Iwai <tiwai@suse.com>,
Adrian Hunter <adrian.hunter@intel.com>,
linux-edac@vger.kernel.org, linux-hwmon@vger.kernel.org,
Tony Luck <tony.luck@intel.com>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
"Rafael J. Wysocki" <rjw@rjwysocki.net>,
LKML <linux-kernel@vger.kernel.org>,
linux-crypto <linux-crypto@vger.kernel.org>,
Paolo Bonzini <pbonzini@redhat.com>,
"David S. Miller" <davem@davemloft.net>,
Andy Shevchenko <andy@infradead.org>
Subject: Re: [patch 08/22] ACPI: Convert to new X86 CPU match macros
Date: Fri, 20 Mar 2020 21:32:26 +0100 [thread overview]
Message-ID: <87bloqpy1x.fsf@nanos.tec.linutronix.de> (raw)
In-Reply-To: <CAHp75VcK3tL0YayjF=CSkSkHiOpg2zOV3rdkXQWJmLZ9fmevpg@mail.gmail.com>
Andy Shevchenko <andy.shevchenko@gmail.com> writes:
> On Fri, Mar 20, 2020 at 3:19 PM Thomas Gleixner <tglx@linutronix.de> wrote:
>>
>> The new macro set has a consistent namespace and uses C99 initializers
>> instead of the grufty C89 ones.
>>
>> Rename the local macro wrapper to X86_MATCH for consistency. It stays for
>> readability sake.
>
>> + X86_MATCH_INTEL_FAM6_MODEL(ATOM_SILVERMONT, NULL),
>> + X86_MATCH_INTEL_FAM6_MODEL(ATOM_AIRMONT, NULL),
>
>> -#define ICPU(model) { X86_VENDOR_INTEL, 6, model, X86_FEATURE_ANY, }
>> +#define X86_MATCH(model) X86_MATCH_INTEL_FAM6_MODEL(model, NULL)
>
> Maybe we can do a generic macro to avoid all these ', NULL' repetitions?
I opted for having the data argument everywhere to keep the macro maze
small. And we have enough places where data is actually used.
Thanks,
tglx
next prev parent reply other threads:[~2020-03-23 13:56 UTC|newest]
Thread overview: 27+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <20200320131345.635023594@linutronix.de>
2020-03-20 14:31 ` [patch 00/22] x86/treewide: Consolidate CPU match macro maze and get rid of C89 (sic!) initializers Andy Shevchenko
[not found] ` <20200320131508.736205164@linutronix.de>
2020-03-20 14:33 ` [patch 01/22] x86/devicetable: Move x86 specific macro out of generic code Andy Shevchenko
2020-03-20 20:24 ` Thomas Gleixner
[not found] ` <20200320131508.826011988@linutronix.de>
2020-03-20 14:29 ` [patch 02/22] x86/cpu: Add conistent CPU match macros Bjorn Helgaas
2020-03-20 14:39 ` Andy Shevchenko
2020-03-20 20:27 ` Thomas Gleixner
[not found] ` <20200320131509.467730627@linutronix.de>
2020-03-20 14:47 ` [patch 08/22] ACPI: Convert to new X86 " Andy Shevchenko
2020-03-20 20:32 ` Thomas Gleixner [this message]
2020-03-23 16:38 ` mark gross
[not found] ` <20200320131509.564059710@linutronix.de>
2020-03-20 14:50 ` [patch 09/22] cpufreq: " Andy Shevchenko
2020-03-20 20:30 ` Thomas Gleixner
2020-03-20 21:52 ` Andy Shevchenko
2020-03-20 22:18 ` Thomas Gleixner
2020-03-24 6:01 ` [cpufreq] 06c4d00466: will-it-scale.per_process_ops -53.4% regression kernel test robot
2020-03-24 10:24 ` Andy Shevchenko
2020-03-24 15:38 ` Srinivas Pandruvada
2020-03-25 7:51 ` Rong Chen
2020-03-25 7:50 ` Rong Chen
2020-03-25 10:32 ` Thomas Gleixner
2020-03-26 8:33 ` kernel test robot
2020-03-24 13:51 ` [patch V2 09/22] cpufreq: Convert to new X86 CPU match macros Thomas Gleixner
2020-03-24 15:37 ` Rafael J. Wysocki
[not found] ` <20200320131509.766573641@linutronix.de>
2020-03-20 14:52 ` [patch 11/22] platform/x86: Convert to new " Andy Shevchenko
[not found] ` <20200320131510.594671507@linutronix.de>
2020-03-20 14:58 ` [patch 19/22] ASoC: Intel: Convert to new X86 " Andy Shevchenko
2020-03-20 14:59 ` [patch 00/22] x86/treewide: Consolidate CPU match macro maze and get rid of C89 (sic!) initializers Greg Kroah-Hartman
2020-03-24 18:58 ` [PATCH 23/22] x86/smpboot: Remove the last ICPU() macro Borislav Petkov
[not found] ` <20200320131509.673579000@linutronix.de>
2020-03-24 19:31 ` [patch 10/22] EDAC: Convert to new X86 CPU match macros Luck, Tony
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87bloqpy1x.fsf@nanos.tec.linutronix.de \
--to=tglx@linutronix.de \
--cc=adrian.hunter@intel.com \
--cc=alsa-devel@alsa-project.org \
--cc=amit.kucheria@verdurent.com \
--cc=andy.shevchenko@gmail.com \
--cc=andy@infradead.org \
--cc=bhelgaas@google.com \
--cc=cw00.choi@samsung.com \
--cc=daniel.lezcano@linaro.org \
--cc=davem@davemloft.net \
--cc=dvhart@infradead.org \
--cc=gregkh@linuxfoundation.org \
--cc=herbert@gondor.apana.org.au \
--cc=jacob.jun.pan@linux.intel.com \
--cc=jdelvare@suse.com \
--cc=lenb@kernel.org \
--cc=linux-acpi@vger.kernel.org \
--cc=linux-crypto@vger.kernel.org \
--cc=linux-edac@vger.kernel.org \
--cc=linux-hwmon@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mmc@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=linux@roeck-us.net \
--cc=mgross@linux.intel.com \
--cc=pbonzini@redhat.com \
--cc=platform-driver-x86@vger.kernel.org \
--cc=rjw@rjwysocki.net \
--cc=rui.zhang@intel.com \
--cc=srinivas.pandruvada@linux.intel.com \
--cc=tiwai@suse.com \
--cc=tony.luck@intel.com \
--cc=ulf.hansson@linaro.org \
--cc=viresh.kumar@linaro.org \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox