Alsa-Devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Jani Nikula <jani.nikula@linux.intel.com>
To: "Yang, Libin" <libin.yang@intel.com>,
	David Henningsson <david.henningsson@canonical.com>,
	"alsa-devel@alsa-project.org" <alsa-devel@alsa-project.org>,
	Daniel Vetter <daniel@ffwll.ch>,
	"ville.syrjala@linux.intel.com" <ville.syrjala@linux.intel.com>
Subject: Re: [PATCH v2] drm/i915: set proper N/CTS in modeset
Date: Tue, 13 Oct 2015 17:35:31 +0300	[thread overview]
Message-ID: <87twpu3kgc.fsf@intel.com> (raw)
In-Reply-To: <96A12704CE18D347B625EE2D4A099D1974C695@SHSMSX103.ccr.corp.intel.com>

On Tue, 13 Oct 2015, "Yang, Libin" <libin.yang@intel.com> wrote:
> + gfx driver team.
>
> Hi David,
>
>> -----Original Message-----
>> From: David Henningsson [mailto:david.henningsson@canonical.com]
>> Sent: Tuesday, October 13, 2015 9:43 PM
>> To: alsa-devel@alsa-project.org; Yang, Libin
>> Subject: Re: [alsa-devel] [PATCH v2] drm/i915: set proper N/CTS in
>> modeset
>> 
>> 
>> 
>> On 2015-09-25 03:36, libin.yang@intel.com wrote:
>> > @@ -24,8 +24,18 @@
>> >   #ifndef _I915_COMPONENT_H_
>> >   #define _I915_COMPONENT_H_
>> >
>> > +/* MAX_PORT is the number of port
>> > + * It must be sync with I915_MAX_PORTS defined i915_drv.h
>> > + * 5 should be enough as only HSW, BDW, SKL need such fix.
>> > + */
>> > +#define MAX_PORTS 5
>> > +
>> >   struct i915_audio_component {
>> >   	struct device *dev;
>> > +	/**
>> > +	 * @aud_sample_rate: the array of audio sample rate per port
>> > +	 */
>> > +	int aud_sample_rate[MAX_PORTS];
>> 
>> Just a quick question as I was trying to understand the code:
>> 
>> aud_sample_rate seems only set and get on the i915 side, never on the
>> hda side.
>> 
>> In short, why is this variable here, and not in e g, as a single integer
>> in the intel_digital_port struct?
>> 
>> That way we also avoid the possibility of MAX_PORTS becoming out of
>> sync
>> with the i915 side.
>
> Put it in struct i915_audio_component just because it is audio related and
> easy for management.
>
> It seems to put it in intel_digital_port will be easier.
>
> Let's hear the gfx team's comments. 

Ack on moving it into struct intel_digital_port.

We had a bit of a hurry to get the original patches in, didn't want to
start bikeshedding at each step of the way...

BR,
Jani.


>
> Regards,
> Libin
>
>> 
>> --
>> David Henningsson, Canonical Ltd.
>> https://launchpad.net/~diwic

-- 
Jani Nikula, Intel Open Source Technology Center

      parent reply	other threads:[~2015-10-13 14:32 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-09-25  1:36 [PATCH v2] drm/i915: set proper N/CTS in modeset libin.yang
2015-09-25  8:01 ` Jani Nikula
2015-09-25  8:11   ` Takashi Iwai
2015-10-07 13:33     ` Daniel Vetter
2015-10-13 13:42 ` David Henningsson
2015-10-13 14:21   ` Yang, Libin
2015-10-13 14:30     ` Ville Syrjälä
2015-10-13 14:35     ` Jani Nikula [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87twpu3kgc.fsf@intel.com \
    --to=jani.nikula@linux.intel.com \
    --cc=alsa-devel@alsa-project.org \
    --cc=daniel@ffwll.ch \
    --cc=david.henningsson@canonical.com \
    --cc=libin.yang@intel.com \
    --cc=ville.syrjala@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox