Alsa-Devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Takashi Iwai <tiwai@suse.de>
To: Arnd Bergmann <arnd@arndb.de>
Cc: Sam Ravnborg <sam@ravnborg.org>,
	alsa-devel@alsa-project.org,
	Jaswinder Singh Rajput <jaswinder@kernel.org>,
	Ingo Molnar <mingo@elte.hu>, LKML <linux-kernel@vger.kernel.org>
Subject: Re: usr/include/linux/soundcard.h warnings for 'make headers_check'
Date: Tue, 10 Feb 2009 00:06:29 +0100	[thread overview]
Message-ID: <s5h7i3znrbe.wl%tiwai@suse.de> (raw)
In-Reply-To: <200902041502.08055.arnd@arndb.de>

At Wed, 4 Feb 2009 15:02:07 +0100,
Arnd Bergmann wrote:
> 
> On Wednesday 04 February 2009, Jaswinder Singh Rajput wrote:
> > > +#define _SEQ_EXTERN extern
> > > +#define SEQ_USE_EXTBUF() \
> > > +             _SEQ_EXTERN unsigned char _seqbuf[]; \
> > > +             _SEQ_EXTERN int _seqbuflen;_SEQ_EXTERN int _seqbufptr
> > 
> > hmm, you rename snake as rope, but actually snake is still there ;-)
> 
> Yes, that's true.
> 
> The alternative would be to remove all those macros entirely, breaking
> also the applications from number 2 in my list.
> 
> I see this header as another example of the byteorder.h type where
> a kernel header provides functionality that is used by existing
> applications. While it should have been part of a library to start
> with, we cannot change it any more now without breaking stuff.
> 
> Maybe a comment should be added to clarify this.

Yes, that should help understanding, at least.

I applied your previous patch with this change now no sound git tree,
and will include it in the next pull request.


Thanks!

Takashi

> 
> 	Arnd <><
> 
> --- a/include/linux/soundcard.h
> +++ b/include/linux/soundcard.h
> @@ -1050,7 +1050,17 @@ typedef struct mixer_vol_table {
>   *	Some convenience macros to simplify programming of the
>   *	/dev/sequencer interface
>   *
> - *	These macros define the API which should be used when possible.
> + *	This is a legacy interface for applications written against
> + *	the OSSlib-3.8 style interface. It is no longer possible
> + *	to actually link against OSSlib with this header, but we
> + *	still provide these macros for programs using them.
> + *
> + *	If you want to use OSSlib, it is recommended that you get
> + *	the GPL version of OSS-4.x and build against that version
> + *	of the header.
> + *
> + *	We redefine the extern keyword so that make headers_check
> + *	does not complain about SEQ_USE_EXTBUF.
>   */
>  #define SEQ_DECLAREBUF()		SEQ_USE_EXTBUF()
>  
> 

  reply	other threads:[~2009-02-09 23:06 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-01-20 15:38 usr/include/linux/soundcard.h warnings for 'make headers_check' Jaswinder Singh Rajput
2009-01-21  0:08 ` Takashi Iwai
2009-01-21  0:25   ` Jaswinder Singh Rajput
2009-01-21  5:41   ` Sam Ravnborg
2009-02-03 20:27     ` Arnd Bergmann
2009-02-04  4:04       ` Jaswinder Singh Rajput
2009-02-04  6:39         ` Takashi Iwai
2009-02-04  8:34           ` Jaswinder Singh Rajput
2009-02-04  9:03             ` Takashi Iwai
2009-02-04 10:37               ` Jaswinder Singh Rajput
2009-02-04 10:52                 ` Takashi Iwai
2009-02-04 11:31                   ` Jaswinder Singh Rajput
2009-02-04 11:43                     ` Takashi Iwai
2009-02-04 12:51                       ` Arnd Bergmann
2009-02-04 12:58                         ` Takashi Iwai
2009-02-04 13:44                         ` Jaswinder Singh Rajput
2009-02-04 13:49                           ` Takashi Iwai
2009-02-04 14:02                           ` Arnd Bergmann
2009-02-09 23:06                             ` Takashi Iwai [this message]
2009-01-24  6:50   ` Jaswinder Singh Rajput

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=s5h7i3znrbe.wl%tiwai@suse.de \
    --to=tiwai@suse.de \
    --cc=alsa-devel@alsa-project.org \
    --cc=arnd@arndb.de \
    --cc=jaswinder@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=sam@ravnborg.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox