Alsa-Devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Takashi Iwai <tiwai@suse.de>
To: Ranjani Sridharan <ranjani.sridharan@linux.intel.com>
Cc: liam.r.girdwood@linux.intel.com, alsa-devel@alsa-project.org,
	broonie@kernel.org
Subject: Re: [PATCH] ASoC: Add accessor macros for TLV items
Date: Tue, 27 Mar 2018 21:43:59 +0200	[thread overview]
Message-ID: <s5hh8p18fsw.wl-tiwai@suse.de> (raw)
In-Reply-To: <20180327183945.6551-1-ranjani.sridharan@linux.intel.com>

On Tue, 27 Mar 2018 20:39:45 +0200,
Ranjani Sridharan wrote:
> 
> This patch adds macros for accessing the type, length, min, mute
> and step items in TLV data. These will be used by drivers to extract
> the TLV data while loading topology.
> 
> Signed-off-by: Ranjani Sridharan <ranjani.sridharan@linux.intel.com>

The subject is wrongly prefixed.  This is ALSA core API stuff, not
about ASoC.

And about the change...

> --- a/include/sound/tlv.h
> +++ b/include/sound/tlv.h
> @@ -49,6 +49,11 @@
>  
>  #define TLV_DB_GAIN_MUTE		SNDRV_CTL_TLVD_DB_GAIN_MUTE
>  
> +#define TLV_ITEM_TYPE			SNDRV_CTL_TLVD_ITEM_TYPE
> +#define TLV_ITEM_LEN			SNDRV_CTL_TLVD_ITEM_LEN
> +#define TLV_DB_MIN			SNDRV_CTL_TLVD_DB_SCALE_MIN
> +#define TLV_DB_MUTE_AND_STEP		SNDRV_CTL_TLVD_DB_SCALE_MUTE_AND_STEP

What's the reason of these redundant redefinitions?


> --- a/include/uapi/sound/tlv.h
> +++ b/include/uapi/sound/tlv.h
> @@ -60,6 +60,13 @@
>  	unsigned int name[] = { \
>  		SNDRV_CTL_TLVD_DB_SCALE_ITEM(min, step, mute) \
>  	}
> +/* Accessor macros for TLV type and len */
> +#define SNDRV_CTL_TLVD_ITEM_TYPE		0
> +#define SNDRV_CTL_TLVD_ITEM_LEN			1
> +
> +/* Accessor macros for min, mute and step values from dB scale type TLV */
> +#define SNDRV_CTL_TLVD_DB_SCALE_MIN		2
> +#define SNDRV_CTL_TLVD_DB_SCALE_MUTE_AND_STEP	3

These are no "macros" but constants.  And, they use the same prefix
SNDRV_CTL_TLVD_* as other existing macros.  SNDTV_CTL_TLVD_*() is a
macro to define/expand a TLV descriptor.  It's not for defining the
offset value as added in the patch.

That is, better to choose another unique prefix to distinguish the
definitions clearly.


thanks,

Takashi

  reply	other threads:[~2018-03-27 19:44 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-03-27 18:39 [PATCH] ASoC: Add accessor macros for TLV items Ranjani Sridharan
2018-03-27 19:43 ` Takashi Iwai [this message]
2018-03-27 21:08   ` Ranjani Sridharan
2018-03-28  1:55     ` Takashi Sakamoto

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=s5hh8p18fsw.wl-tiwai@suse.de \
    --to=tiwai@suse.de \
    --cc=alsa-devel@alsa-project.org \
    --cc=broonie@kernel.org \
    --cc=liam.r.girdwood@linux.intel.com \
    --cc=ranjani.sridharan@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox