From: Takashi Iwai <tiwai@suse.de>
To: Takashi Sakamoto <o-takashi@sakamocchi.jp>
Cc: alsa-devel@alsa-project.org, kuninori.morimoto.gx@renesas.com
Subject: Re: [PATCH 6/8] ALSA: pcm: adaption of code formatting
Date: Thu, 08 Jun 2017 09:14:47 +0200 [thread overview]
Message-ID: <s5hlgp32bo8.wl-tiwai@suse.de> (raw)
In-Reply-To: <20170607231026.23383-7-o-takashi@sakamocchi.jp>
On Thu, 08 Jun 2017 01:10:24 +0200,
Takashi Sakamoto wrote:
>
> This commit modifies current code according to fashion in kernel land:
> - within 80 characters per line as possible
> - removal of trailing linear white spaces
> - use int type variable for loop counter
> - use prefix operator for numerical increment
This isn't always preferred, and I see no reason to change.
thanks,
Takashi
> For readability:
> - use bool type variable instead of int type variable assigned to 0/1
> - move variable definition from loop to top of the function definition
>
> Signed-off-by: Takashi Sakamoto <o-takashi@sakamocchi.jp>
> ---
> sound/core/pcm_native.c | 39 +++++++++++++++++++++------------------
> 1 file changed, 21 insertions(+), 18 deletions(-)
>
> diff --git a/sound/core/pcm_native.c b/sound/core/pcm_native.c
> index 6fa5947d7db8..7c74c293cab7 100644
> --- a/sound/core/pcm_native.c
> +++ b/sound/core/pcm_native.c
> @@ -259,12 +259,13 @@ static int constrain_mask_params(struct snd_pcm_substream *substream,
> struct snd_pcm_hw_constraints *constrs =
> &substream->runtime->hw_constraints;
> struct snd_mask *m;
> - unsigned int k;
> + int k;
> int changed;
>
> struct snd_mask __maybe_unused old_mask;
>
> - for (k = SNDRV_PCM_HW_PARAM_FIRST_MASK; k <= SNDRV_PCM_HW_PARAM_LAST_MASK; k++) {
> + for (k = SNDRV_PCM_HW_PARAM_FIRST_MASK;
> + k <= SNDRV_PCM_HW_PARAM_LAST_MASK; ++k) {
> m = hw_param_mask(params, k);
> if (snd_mask_empty(m))
> return -EINVAL;
> @@ -293,12 +294,13 @@ static int constrain_interval_params(struct snd_pcm_substream *substream,
> struct snd_pcm_hw_constraints *constrs =
> &substream->runtime->hw_constraints;
> struct snd_interval *i;
> - unsigned int k;
> + int k;
> int changed;
>
> struct snd_interval __maybe_unused old_interval;
>
> - for (k = SNDRV_PCM_HW_PARAM_FIRST_INTERVAL; k <= SNDRV_PCM_HW_PARAM_LAST_INTERVAL; k++) {
> + for (k = SNDRV_PCM_HW_PARAM_FIRST_INTERVAL;
> + k <= SNDRV_PCM_HW_PARAM_LAST_INTERVAL; ++k) {
> i = hw_param_interval(params, k);
> if (snd_interval_empty(i))
> return -EINVAL;
> @@ -326,25 +328,28 @@ static int constrain_params_by_rules(struct snd_pcm_substream *substream,
> {
> struct snd_pcm_hw_constraints *constrs =
> &substream->runtime->hw_constraints;
> - unsigned int k;
> + int k;
> unsigned int rstamps[constrs->rules_num];
> unsigned int vstamps[SNDRV_PCM_HW_PARAM_LAST_INTERVAL + 1];
> - unsigned int stamp = 2;
> - int again;
> + unsigned int stamp;
> + struct snd_pcm_hw_rule *r;
> + int d;
> + bool again;
> int changed;
>
> struct snd_mask __maybe_unused old_mask;
> struct snd_interval __maybe_unused old_interval;
>
> - for (k = 0; k < constrs->rules_num; k++)
> + for (k = 0; k < constrs->rules_num; ++k)
> rstamps[k] = 0;
> - for (k = 0; k <= SNDRV_PCM_HW_PARAM_LAST_INTERVAL; k++)
> + for (k = 0; k <= SNDRV_PCM_HW_PARAM_LAST_INTERVAL; ++k)
> vstamps[k] = (params->rmask & (1 << k)) ? 1 : 0;
> +
> + stamp = 2;
> retry:
> - again = 0;
> + again = false;
> for (k = 0; k < constrs->rules_num; k++) {
> - struct snd_pcm_hw_rule *r = &constrs->rules[k];
> - unsigned int d;
> + r = &constrs->rules[k];
> if (r->cond && !(r->cond & params->flags))
> continue;
> for (d = 0; r->deps[d] >= 0; d++) {
> @@ -378,7 +383,7 @@ static int constrain_params_by_rules(struct snd_pcm_substream *substream,
> if (changed && r->var >= 0) {
> params->cmask |= (1 << r->var);
> vstamps[r->var] = stamp;
> - again = 1;
> + again = true;
> }
> if (changed < 0)
> return changed;
> @@ -397,7 +402,6 @@ int snd_pcm_hw_refine(struct snd_pcm_substream *substream,
> struct snd_pcm_hardware *hw;
> struct snd_interval *i = NULL;
> struct snd_mask *m = NULL;
> - int changed;
> int err;
>
> struct snd_mask __maybe_unused old_mask;
> @@ -451,16 +455,15 @@ int snd_pcm_hw_refine(struct snd_pcm_substream *substream,
> i = hw_param_interval(params, SNDRV_PCM_HW_PARAM_CHANNELS);
> if (snd_mask_min(m) == snd_mask_max(m) &&
> snd_interval_min(i) == snd_interval_max(i)) {
> - changed = substream->ops->ioctl(substream,
> + err = substream->ops->ioctl(substream,
> SNDRV_PCM_IOCTL1_FIFO_SIZE, params);
> - if (changed < 0)
> - return changed;
> + if (err < 0)
> + return err;
> }
> }
> params->rmask = 0;
> return 0;
> }
> -
> EXPORT_SYMBOL(snd_pcm_hw_refine);
>
> static int snd_pcm_hw_refine_user(struct snd_pcm_substream *substream,
> --
> 2.11.0
>
next prev parent reply other threads:[~2017-06-08 7:14 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-06-07 23:10 [PATCH 0/8] ALSA: pcm: code refactoring for snd_pcm_hw_refine() Takashi Sakamoto
2017-06-07 23:10 ` [PATCH 1/8] ALSA: pcm: add a helper function to constrain mask-type parameters Takashi Sakamoto
2017-06-08 7:10 ` Takashi Iwai
2017-06-08 7:28 ` Takashi Sakamoto
2017-06-08 7:30 ` Takashi Sakamoto
2017-06-08 7:35 ` Takashi Iwai
2017-06-08 8:35 ` Takashi Sakamoto
2017-06-07 23:10 ` [PATCH 2/8] ALSA: pcm: add a helper function to constrain interval-type parameters Takashi Sakamoto
2017-06-07 23:10 ` [PATCH 3/8] ALSA: pcm: add a helper function to apply parameter rules Takashi Sakamoto
2017-06-07 23:10 ` [PATCH 4/8] ALSA: pcm: use goto statement instead of while statement to reduce indentation Takashi Sakamoto
2017-06-07 23:10 ` [PATCH 5/8] ALSA: pcm: remove function local variable with alternative evaluation Takashi Sakamoto
2017-06-07 23:10 ` [PATCH 6/8] ALSA: pcm: adaption of code formatting Takashi Sakamoto
2017-06-08 7:14 ` Takashi Iwai [this message]
2017-06-07 23:10 ` [PATCH 7/8] ALSA: pcm: use helper functions to check whether parameters are determined Takashi Sakamoto
2017-06-07 23:10 ` [PATCH 8/8] ALSA: pcm: add comment about application of rule to PCM parameters Takashi Sakamoto
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=s5hlgp32bo8.wl-tiwai@suse.de \
--to=tiwai@suse.de \
--cc=alsa-devel@alsa-project.org \
--cc=kuninori.morimoto.gx@renesas.com \
--cc=o-takashi@sakamocchi.jp \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox