From mboxrd@z Thu Jan 1 00:00:00 1970 From: Takashi Iwai Subject: Re: PATCH - ESI Juli driver - works OK Date: Thu, 20 Mar 2008 12:37:16 +0100 Message-ID: References: <47DD1934.3000003@insite.cz> <47DE328D.1080009@insite.cz> <47DE3BD2.5090007@insite.cz> <47DE7B70.2040407@insite.cz> <47DE934F.3060308@insite.cz> <47DF678B.3000605@insite.cz> <47E016F8.6030504@insite.cz> Mime-Version: 1.0 (generated by SEMI 1.14.6 - "Maruoka") Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mx2.suse.de (mx2.suse.de [195.135.220.15]) by alsa0.perex.cz (Postfix) with ESMTP id 499A824748 for ; Thu, 20 Mar 2008 12:37:16 +0100 (CET) In-Reply-To: <47E016F8.6030504@insite.cz> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: alsa-devel-bounces@alsa-project.org Errors-To: alsa-devel-bounces@alsa-project.org To: Pavel Hofman Cc: ALSA development List-Id: alsa-devel@alsa-project.org At Tue, 18 Mar 2008 20:24:40 +0100, Pavel Hofman wrote: > > Takashi Iwai wrote: > > At Tue, 18 Mar 2008 07:56:11 +0100, > > Pavel Hofman wrote: > >> Takashi Iwai wrote: > >>> At Mon, 17 Mar 2008 16:50:39 +0100, > >>> Pavel Hofman wrote: > >>> > >>> Well, then we'll need to find some point to compromise. Could you > >>> repost the patch after reducing the callbacks again? > >>> > >>> I'll have also no time from the next week at all -- will be on > >>> vacation for three weeks. So, let's kick it out soonish :) > >>> > >> Hi, > >> > >> I am sorry, the previous patch had some debugs enabled. Here is a fixed > >> patch. > >> > >> Thanks a lot. > >> > >> Pavel. > >> > >> > >> Signed-off-by: Pavel Hofman > >> > >> * moving most of clock-specific code to card-specific routines > >> * support for ESI Juli > >> * to-be-researched - monitoring of analog/digital inputs > > > > Thanks. Now I checked the patch and found it much better now. > > However, I still think the get_rate_index can be omitted by checking > > the index from the rate list dynamically. This looks inefficent but > > improves the readability and reduces the code size better. Moreover, > > the snd_pcm_hw's aren't needed to be prepared for each type. > > > > Below is my revised patch. With this patch, ice->hw_rates must be > > non-NULL and this is referred in many places. It cleans up > > *_internal_clock*() nicely. > > > > Well Takashi, you are the real master here, your patch tells. I > especially like the smart way you replaced the ugly switch/case > structures in juli.c > > The patch works fine, both standard clock as well as Juli. Thanks for confirming. I applied the patch to HG tree now. Takashi