From mboxrd@z Thu Jan 1 00:00:00 1970 From: Takashi Iwai Subject: Re: [PATCH 2/3] ALSA: hda - Move in_pm accessors to HDA core Date: Thu, 28 Jun 2018 00:05:49 +0200 Message-ID: References: <20180627091034.22724-1-tiwai@suse.de> <20180627091034.22724-3-tiwai@suse.de> <153009232054.8693.169642523536241126@mail.alporthouse.com> Mime-Version: 1.0 (generated by SEMI 1.14.6 - "Maruoka") Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mx2.suse.de (mx2.suse.de [195.135.220.15]) by alsa0.perex.cz (Postfix) with ESMTP id EBB592679A6 for ; Thu, 28 Jun 2018 00:05:49 +0200 (CEST) In-Reply-To: <153009232054.8693.169642523536241126@mail.alporthouse.com> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: alsa-devel-bounces@alsa-project.org Sender: alsa-devel-bounces@alsa-project.org To: Chris Wilson Cc: alsa-devel@alsa-project.org, Ville =?UTF-8?B?U3lyasOkbMOk?= List-Id: alsa-devel@alsa-project.org On Wed, 27 Jun 2018 11:38:40 +0200, Chris Wilson wrote: > > Quoting Takashi Iwai (2018-06-27 10:10:33) > > The in_pm atomic in hdac_device is an important field used as a flag > > as well as a refcount for PM. The existing snd_hdac_power_up/down > > helpers already refer to it in the HD-audio core code, while the code > > to actually setting the value (atomic_inc() / _dec()) is open-coded in > > HDA legacy side, which is hard to find. > > > > This patch adds the helper functions to set/reset the in_pm counter to > > HDA core and use them in HDA legacy side, for making it clearer who / > > where the PM is managed. > > > > There is no functional changes, just code refactoring. > > > > Signed-off-by: Takashi Iwai > > Mechanical code change that helps explain what it is doing, > Reviewed-by: Chris Wilson This patch still seems OK, so merged to for-next branch alone. Takashi