From mboxrd@z Thu Jan 1 00:00:00 1970 From: Takashi Iwai Subject: Re: [ALSA - patch_sigmatel.c for HP dv4-1222nr laptop 9/9Patch to patch_sigmatel.c for HP dv4-1222nr laptop Date: Fri, 17 Apr 2009 08:59:39 +0200 Message-ID: References: <730476.70849.qm@web54507.mail.re2.yahoo.com> Mime-Version: 1.0 (generated by SEMI 1.14.6 - "Maruoka") Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mx1.suse.de (cantor.suse.de [195.135.220.2]) by alsa0.perex.cz (Postfix) with ESMTP id 656FA24399 for ; Fri, 17 Apr 2009 08:59:40 +0200 (CEST) In-Reply-To: <730476.70849.qm@web54507.mail.re2.yahoo.com> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: alsa-devel-bounces@alsa-project.org Errors-To: alsa-devel-bounces@alsa-project.org To: renidragsemaj@yahoo.com Cc: alsa-devel@alsa-project.org List-Id: alsa-devel@alsa-project.org At Thu, 16 Apr 2009 22:39:35 -0700 (PDT), James Gardiner wrote: > > > > > > --- On Tue, 4/14/09, Takashi Iwai wrote: > > > > > Thanks for the patch. The change looks almost good to me. > > See some comments below > > > > > > > > > + spec->num_dmics = 1; > > > + spec->num_dmuxes = 2; > > > + stac92xx_auto_set_pinctl(codec, 0x1c, 2); > > > > The number "2" doesn't look cute... > > > > Could you fix and repost the patch? > > > > > > thanks, > > > > Takashi > > Are you worried it looks like a magic number? Or am I supposed to be > looking for something else? Or would a '#define' be more what > you're talking about? Use constants defined in hda_codec.h. For pin-setup, AC_PINCTL_* can be used. > Can you (simple) explain to me what the PCI_QUIRK stuff does? The driver identifies the specific model via PCI SSID (not codec SSID). Check "lspci -nv" output and pass the value there. thanks, Takashi