From mboxrd@z Thu Jan 1 00:00:00 1970 From: Nathan Chancellor Subject: Re: [PATCH] drm/amd/display: return 'NULL' instead of 'false' from dcn20_acquire_idle_pipe_for_layer Date: Fri, 12 Jul 2019 10:57:15 -0700 Message-ID: <20190712175715.GA21080@archlinux-threadripper> References: <20190712094009.1535662-1-arnd@arndb.de> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Return-path: Content-Disposition: inline In-Reply-To: <20190712094009.1535662-1-arnd@arndb.de> Sender: linux-kernel-owner@vger.kernel.org To: Arnd Bergmann Cc: Harry Wentland , Leo Li , Alex Deucher , Christian =?iso-8859-1?Q?K=F6nig?= , "David (ChunMing) Zhou" , David Airlie , Daniel Vetter , Bhawanpreet Lakha , Dmytro Laktyushkin , Nikola Cornij , Charlene Liu , Jun Lei , amd-gfx@lists.freedesktop.org, dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org, clang-built-linux@googlegroups.com List-Id: amd-gfx.lists.freedesktop.org On Fri, Jul 12, 2019 at 11:39:52AM +0200, Arnd Bergmann wrote: > clang complains that 'false' is a not a pointer: > > drivers/gpu/drm/amd/amdgpu/../display/dc/dcn20/dcn20_resource.c:2428:10: error: expression which evaluates to zero treated as a null pointer constant of type 'struct pipe_ctx *' [-Werror,-Wnon-literal-null-conversion] > return false; > > Changing it to 'NULL' looks like the right thing that will shut up > the warning and make it easier to read, while not changing behavior. > > Fixes: 7ed4e6352c16 ("drm/amd/display: Add DCN2 HW Sequencer and Resource") > Signed-off-by: Arnd Bergmann Reviewed-by: Nathan Chancellor