AMD-GFX Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Sam Ravnborg <sam@ravnborg.org>
To: Lee Jones <lee.jones@linaro.org>
Cc: "David Airlie" <airlied@linux.ie>,
	LKML <linux-kernel@vger.kernel.org>,
	"amd-gfx list" <amd-gfx@lists.freedesktop.org>,
	"Alex Deucher" <alexander.deucher@amd.com>,
	"Maling list - DRI developers" <dri-devel@lists.freedesktop.org>,
	"Alex Deucher" <alexdeucher@gmail.com>,
	"Christian König" <christian.koenig@amd.com>
Subject: Re: [PATCH 15/20] drm/radeon/r600d: Move 'rc600_*' prototypes into shared header
Date: Tue, 10 Nov 2020 10:02:47 +0100	[thread overview]
Message-ID: <20201110090247.GB2027451@ravnborg.org> (raw)
In-Reply-To: <20201110072242.GF2063125@dell>

Hi Lee,

> > the *d.h headers are supposed to just be hardware definitions.  I'd
> > prefer to keep driver stuff out of them.
> 
> That's fine (I did wonder if that were the case).
> 
> I need an answer from you and Sam whether I can create new headers.
> 
> For me, it is the right thing to do.

Please follow the advice of Alex for the radeon driver.

	Sam
_______________________________________________
amd-gfx mailing list
amd-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/amd-gfx

  reply	other threads:[~2020-11-10  9:02 UTC|newest]

Thread overview: 41+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-09 21:18 [PATCH 00/20] [Set 3] Rid W=1 warnings from GPU Lee Jones
2020-11-09 21:18 ` [PATCH 01/20] drm/radeon/radeon_ttm: Place declaration of 'rdev' in same clause as its use Lee Jones
2020-11-10 22:05   ` Alex Deucher
2020-11-09 21:18 ` [PATCH 02/20] drm/radeon: Move radeon_ttm{init, fini} to shared location Lee Jones
2020-11-09 21:18 ` [PATCH 03/20] drm/radeon/radeon_fence: Demote some non-conformant kernel-doc headers and fix another Lee Jones
2020-11-10 22:06   ` Alex Deucher
2020-11-09 21:18 ` [PATCH 04/20] drm/radeon: Move 'radeon_add_legacy_encoder' prototype to shared header Lee Jones
2020-11-09 21:18 ` [PATCH 05/20] drm/radeon: Move 'radeon_add_legacy_encoder's prototype to shared location Lee Jones
2020-11-09 21:18 ` [PATCH 06/20] drm/radeon/radeon_connectors: Strip out set but unused variable 'ret' Lee Jones
2020-11-10 22:08   ` Alex Deucher
2020-11-09 21:18 ` [PATCH 07/20] drm/radeon/radeon_display: Remove unused variable 'mod' Lee Jones
2020-11-10 22:09   ` Alex Deucher
2020-11-09 21:18 ` [PATCH 08/20] drm/radeon/radeon_i2c: Remove pointless function header Lee Jones
2020-11-10 22:10   ` Alex Deucher
2020-11-09 21:18 ` [PATCH 09/20] drm/radeon/radeon_irq_kms: Demote non-conformant kernel-doc fix another Lee Jones
2020-11-10 22:13   ` Alex Deucher
2020-11-09 21:18 ` [PATCH 10/20] drm/radeon/radeon_ring: Add missing function parameters 'rdev' and 'data' Lee Jones
2020-11-10 22:15   ` Alex Deucher
2020-11-09 21:18 ` [PATCH 11/20] drm/radeon/r600: Strip out set but unused 'tmp' variables Lee Jones
2020-11-10 22:17   ` Alex Deucher
2020-11-09 21:18 ` [PATCH 12/20] drm/radeon/radeon_cs: Fix a bunch of doc-rot issues Lee Jones
2020-11-10 22:41   ` Alex Deucher
2020-11-09 21:18 ` [PATCH 13/20] drm/radeon/evergreen: Move 'rv770_set_clk_bypass_mode' prototype to shared location Lee Jones
2020-11-09 21:18 ` [PATCH 14/20] drm/radeon: Move 'radeon_pm_acpi_event_handler' prototype into shared header Lee Jones
2020-11-09 21:18 ` [PATCH 15/20] drm/radeon/r600d: Move 'rc600_*' prototypes " Lee Jones
2020-11-09 22:20   ` Alex Deucher
2020-11-10  7:22     ` Lee Jones
2020-11-10  9:02       ` Sam Ravnborg [this message]
2020-11-10  9:41         ` Lee Jones
2020-11-10 20:08           ` Alex Deucher
2020-11-10 21:02             ` Lee Jones
2020-11-09 21:18 ` [PATCH 16/20] drm/radeon/radeon_audio: Move 'dce3_2_*' prototypes to shared location Lee Jones
2020-11-09 21:18 ` [PATCH 17/20] drm/radeon/evergreend: Move 'evergreen_*' and 'sumo_*' prototypes out " Lee Jones
2020-11-09 21:18 ` [PATCH 18/20] drm/radeon/radeon_display: Fix function doc formatting and missing param issues Lee Jones
2020-11-10 22:44   ` Alex Deucher
2020-11-09 21:18 ` [PATCH 19/20] drm/radeon/r600: Fix a misnamed parameter description and a formatting issue Lee Jones
2020-11-10 22:45   ` Alex Deucher
2020-11-09 21:18 ` [PATCH 20/20] drm/radeon/cik: Fix a bunch of function parameter descriptions Lee Jones
2020-11-10 22:48   ` Alex Deucher
2020-11-09 22:22 ` [PATCH 00/20] [Set 3] Rid W=1 warnings from GPU Alex Deucher
2020-11-10  7:20   ` Lee Jones

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20201110090247.GB2027451@ravnborg.org \
    --to=sam@ravnborg.org \
    --cc=airlied@linux.ie \
    --cc=alexander.deucher@amd.com \
    --cc=alexdeucher@gmail.com \
    --cc=amd-gfx@lists.freedesktop.org \
    --cc=christian.koenig@amd.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=lee.jones@linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox