From: Jochen Rollwagen <joro-2013-zqRNUXuvxA0b1SvskN2V4Q@public.gmane.org>
To: amd-gfx-PD4FTy7X32lNgt0PjOBp9y5qC8QIuHrW@public.gmane.org
Subject: [PATCH] Remove RADEON_HOST_DATA_SWAP_HDW case from RadeonCopySwap
Date: Fri, 4 Nov 2016 09:23:09 +0100 [thread overview]
Message-ID: <581C456D.7010707@t-online.de> (raw)
[-- Attachment #1: Type: text/plain, Size: 1200 bytes --]
From ba45efaafc3cf790c44b905d2f6272ef7830b403 Mon Sep 17 00:00:00 2001
From: Jochen Rollwagen <joro-2013-zqRNUXuvxA0b1SvskN2V4Q@public.gmane.org>
Date: Fri, 4 Nov 2016 08:39:30 +0100
Subject: [PATCH] Remove RADEON_HOST_DATA_SWAP_HDW case from RadeonCopySwap
RadeonCopySwap is never called with swap=RADEON_HOST_DATA_SWAP_HDW.
Remove the case from the switch for clarity.
---
src/radeon_accel.c | 10 ----------
1 file changed, 10 deletions(-)
diff --git a/src/radeon_accel.c b/src/radeon_accel.c
index 1def2a3..af2fc99 100644
--- a/src/radeon_accel.c
+++ b/src/radeon_accel.c
@@ -131,16 +131,6 @@ int radeon_cs_space_remaining(ScrnInfoPtr pScrn)
void RADEONCopySwap(uint8_t *dst, uint8_t *src, unsigned int size, int
swap)
{
switch(swap) {
- case RADEON_HOST_DATA_SWAP_HDW:
- {
- unsigned int *d = (unsigned int *)dst;
- unsigned int *s = (unsigned int *)src;
- unsigned int nwords = size >> 2;
-
- for (; nwords > 0; --nwords, ++d, ++s)
- *d = ((*s & 0xffff) << 16) | ((*s >> 16) & 0xffff);
- return;
- }
case RADEON_HOST_DATA_SWAP_32BIT:
{
unsigned int *d = (unsigned int *)dst;
--
1.7.9.5
[-- Attachment #2: 0001-Remove-RADEON_HOST_DATA_SWAP_HDW-case-from-RadeonCop.patch --]
[-- Type: text/x-patch, Size: 1165 bytes --]
>From ba45efaafc3cf790c44b905d2f6272ef7830b403 Mon Sep 17 00:00:00 2001
From: Jochen Rollwagen <joro-2013-zqRNUXuvxA0b1SvskN2V4Q@public.gmane.org>
Date: Fri, 4 Nov 2016 08:39:30 +0100
Subject: [PATCH] Remove RADEON_HOST_DATA_SWAP_HDW case from RadeonCopySwap
RadeonCopySwap is never called with swap=RADEON_HOST_DATA_SWAP_HDW. Remove the case from the switch for clarity.
---
src/radeon_accel.c | 10 ----------
1 file changed, 10 deletions(-)
diff --git a/src/radeon_accel.c b/src/radeon_accel.c
index 1def2a3..af2fc99 100644
--- a/src/radeon_accel.c
+++ b/src/radeon_accel.c
@@ -131,16 +131,6 @@ int radeon_cs_space_remaining(ScrnInfoPtr pScrn)
void RADEONCopySwap(uint8_t *dst, uint8_t *src, unsigned int size, int swap)
{
switch(swap) {
- case RADEON_HOST_DATA_SWAP_HDW:
- {
- unsigned int *d = (unsigned int *)dst;
- unsigned int *s = (unsigned int *)src;
- unsigned int nwords = size >> 2;
-
- for (; nwords > 0; --nwords, ++d, ++s)
- *d = ((*s & 0xffff) << 16) | ((*s >> 16) & 0xffff);
- return;
- }
case RADEON_HOST_DATA_SWAP_32BIT:
{
unsigned int *d = (unsigned int *)dst;
--
1.7.9.5
[-- Attachment #3: Type: text/plain, Size: 154 bytes --]
_______________________________________________
amd-gfx mailing list
amd-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/amd-gfx
next reply other threads:[~2016-11-04 8:23 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-11-04 8:23 Jochen Rollwagen [this message]
[not found] ` <581C456D.7010707-zqRNUXuvxA0b1SvskN2V4Q@public.gmane.org>
2016-11-07 1:58 ` [PATCH] Remove RADEON_HOST_DATA_SWAP_HDW case from RadeonCopySwap Michel Dänzer
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=581C456D.7010707@t-online.de \
--to=joro-2013-zqrnuxuvxa0b1svskn2v4q@public.gmane.org \
--cc=amd-gfx-PD4FTy7X32lNgt0PjOBp9y5qC8QIuHrW@public.gmane.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox