From: Nirmoy <nirmodas@amd.com>
To: christian.koenig@amd.com, Nirmoy Das <nirmoy.das@amd.com>,
amd-gfx@lists.freedesktop.org
Cc: alexander.deucher@amd.com
Subject: Re: [RFC PATCH 1/1] drm/amdgpu: fix usable gart size calculation
Date: Fri, 13 Nov 2020 17:51:47 +0100 [thread overview]
Message-ID: <5b429baf-39a3-da9b-b5ed-06e5d6d51f2f@amd.com> (raw)
In-Reply-To: <46bfa315-227c-47c2-d950-47a9a866b070@gmail.com>
On 11/13/20 5:21 PM, Christian König wrote:
> Am 13.11.20 um 17:17 schrieb Nirmoy Das:
>> amdgpu_do_test_moves() is failing because of wrong
>> usable gart size calculation and throwing:
>>
>> [drm:amdgpu_do_test_moves [amdgpu]] *ERROR* 0000000020bdc9f3 bind failed
>>
>> Signed-off-by: Nirmoy Das <nirmoy.das@amd.com>
>> ---
>>
>> This still doesn't work. As per my calculation 1st 4MB of GART is not
>> accounted for in adev->gmc.gart_size -
>> atomic64_read(&adev->gart_pin_size).
>
> The member gart_pin_size should probably be renamed to gtt_pin_size,
> but since a gtt pin is also automatically visible in the GART that
> should probably be ok for now.
>
>> What am I missing ?
>
> The two 2MB windows in the GART which are used for buffer moves.
>
> See AMDGPU_GTT_MAX_TRANSFER_SIZE and AMDGPU_GTT_NUM_TRANSFER_WINDOWS.
Thanks, I should've asked much earlier :)
Nirmoy
>
> Regards,
> Christian.
>
>>
>> drivers/gpu/drm/amd/amdgpu/amdgpu_test.c | 11 ++---------
>> 1 file changed, 2 insertions(+), 9 deletions(-)
>>
>> diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_test.c
>> b/drivers/gpu/drm/amd/amdgpu/amdgpu_test.c
>> index 6042b3b81a4c..d983c729997f 100644
>> --- a/drivers/gpu/drm/amd/amdgpu/amdgpu_test.c
>> +++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_test.c
>> @@ -42,16 +42,9 @@ static void amdgpu_do_test_moves(struct
>> amdgpu_device *adev)
>> size = 1024 * 1024;
>>
>> /* Number of tests =
>> - * (Total GTT - IB pool - writeback page - ring buffers) / test
>> size
>> + * (Total GTT - gart_pin_size) / test size
>> */
>> - n = adev->gmc.gart_size - AMDGPU_IB_POOL_SIZE;
>> - for (i = 0; i < AMDGPU_MAX_RINGS; ++i)
>> - if (adev->rings[i])
>> - n -= adev->rings[i]->ring_size;
>> - if (adev->wb.wb_obj)
>> - n -= AMDGPU_GPU_PAGE_SIZE;
>> - if (adev->irq.ih.ring_obj)
>> - n -= adev->irq.ih.ring_size;
>> + n = adev->gmc.gart_size - atomic64_read(&adev->gart_pin_size);
>> n /= size;
>>
>> gtt_obj = kcalloc(n, sizeof(*gtt_obj), GFP_KERNEL);
>> --
>> 2.29.0
>>
>> _______________________________________________
>> amd-gfx mailing list
>> amd-gfx@lists.freedesktop.org
>> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Flists.freedesktop.org%2Fmailman%2Flistinfo%2Famd-gfx&data=04%7C01%7Cnirmoy.das%40amd.com%7Cc9c61fcfe5b744b494c208d887f0430e%7C3dd8961fe4884e608e11a82d994e183d%7C0%7C0%7C637408813271687888%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=o9w4aKiHNAZvkcWPHTiZQZC5nrOYdjs7TqMpZ3d8AJ0%3D&reserved=0
>>
>
_______________________________________________
amd-gfx mailing list
amd-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/amd-gfx
prev parent reply other threads:[~2020-11-13 16:51 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-11-13 16:17 [RFC PATCH 1/1] drm/amdgpu: fix usable gart size calculation Nirmoy Das
2020-11-13 16:21 ` Christian König
2020-11-13 16:51 ` Nirmoy [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=5b429baf-39a3-da9b-b5ed-06e5d6d51f2f@amd.com \
--to=nirmodas@amd.com \
--cc=alexander.deucher@amd.com \
--cc=amd-gfx@lists.freedesktop.org \
--cc=christian.koenig@amd.com \
--cc=nirmoy.das@amd.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox