AMD-GFX Archive on lore.kernel.org
 help / color / mirror / Atom feed
 messages from 2016-09-07 15:47:25 to 2016-09-13 20:43:31 UTC [more...]

need guidance re amdgpu i2c
 2016-09-13 20:43 UTC  (3+ messages)

[PATCH xf86-video-ati 1/4] glamor: Fix radeon_glamor_share_pixmap_backing for priv->bo == NULL
 2016-09-13 14:22 UTC  (5+ messages)
  ` [PATCH xf86-video-ati 2/4] Consolidate get_drawable_pixmap helper
  ` [PATCH xf86-video-ati 3/4] Move DRI2's local fixup_glamor helper to radeon_glamor_set_pixmap_bo
  ` [PATCH xf86-video-ati 4/4] glamor: Reallocate linear pixmap BO if necessary for DRI2 PRIME

[PATCH 1/2] drm/amdgpu/si/dpm: make a bunch of things static
 2016-09-13 14:13 UTC  (6+ messages)
  ` [PATCH 2/2] drm/amdgpu/si/dpm: fix symbol conflicts with radeon

[PATCH] drm/i915: Before pageflip, also wait for shared dmabuf fences
 2016-09-13 12:52 UTC  (4+ messages)

[PATCH v2 00/16] powerplay code refactoring
 2016-09-13 12:12 UTC  (19+ messages)
  ` [PATCH v2 01/16] drm/amd/powerplay: add common interface in smumgr to help to visit fw image
  ` [PATCH v2 02/16] drm/amd/powerplay: implement smu7 hwmgr to manager asics with smu ip version 7
  ` [PATCH v2 03/16] drm/amd/powerplay: implement fw image related smum interface for Polaris
  ` [PATCH v2 04/16] drm/amd/powerplay: use smu7 hwmgr to manager polaris10/11
  ` [PATCH v2 05/16] drm/amd/powerplay: implement fw image related smu interface for Fiji
  ` [PATCH v2 06/16] drm/amd/powerplay: use smu7 hwmgr to manager fiji
  ` [PATCH v2 07/16] drm/amd/powerplay: implement fw image related smum interface for tonga
  ` [PATCH v2 08/16] drm/amd/powerplay: use smu7_hwmgr to manager tonga
  ` [PATCH v2 09/16] drm/amd/powerplay: implement smu7_smumgr for asics with smu ip version 7
  ` [PATCH v2 10/16] drm/amd/powerplay: use smu7 common functions and data on Tonga
  ` [PATCH v2 11/16] drm/amd/powerplay: use smu7 common functions and data on Polars10
  ` [PATCH v2 12/16] drm/amd/powerplay: use smu7 common functions and data on Fiji
  ` [PATCH v2 13/16] drm/amd/powerplay: use smu7 common functions and data on icelannd
  ` [PATCH v2 14/16] drm/amd/powerplay: implement fw related smu interface for iceland
  ` [PATCH v2 15/16] drm/amd/powerplay: use smu7 hwmgr to manager iceland
  ` [PATCH v2 16/16] drm/amd/powerplay: delete useless files

[PATCH] drm/amdgpu: add VCE VM mode support
 2016-09-13  4:31 UTC 

[PATCH] drm/amdgpu: improve GTT BO alloc speed in OGL
 2016-09-13  2:53 UTC  (5+ messages)

[PATCH 1/6] drm/amdgpu: validate size and offset of user fence BO
 2016-09-13  1:32 UTC  (10+ messages)
  ` [PATCH 2/6] drm/amdgpu: add AMDGPU_BO_INVALID_OFFSET
  ` [PATCH 3/6] drm/amdgpu: unbind GTT only when it is bound
  ` [PATCH 4/6] drm/amdgpu: use explicit GTT limit for evictions
  ` [PATCH 5/6] drm/amdgpu: use expolicit limit fro VRAM<->GTT moves
  ` [PATCH 6/6] drm/amdgpu: add a custom GTT memory manager v2

[PATCH 1/3] drm/amdgpu: refine function name for consistency
 2016-09-12 23:43 UTC  (3+ messages)
` [PATCH 3/3] drm/amdgpu: add vce bypass mode for tonga

amdkfd - misc fixes + get_local_mem_info() port [V.2]
 2016-09-12 21:03 UTC  (17+ messages)
  ` [PATCH 1/7] amdkfd: Tidy up kfd_generate_gpu_id() uint64_t bitshift unpack
  ` [PATCH 2/7] radeonkfd/amdkfd: Implement get_local_mem_info()
  ` [PATCH 3/7] amdkfd: Add some missing memset zero'ing in queue init func
  ` [PATCH 4/7] drm/amdkfd: Make kfd_lookup_process_by_pasid() well defined
  ` [PATCH 5/7] drm/amdkfd: Remove duplicate pqm_uninit()
  ` [PATCH 6/7] drm/amdkfd: Reuse function to find a process through pasid
  ` [PATCH 7/7] drm/amdkfd: Fix possible infinite loop

[PATCH 1/2] drm/amdgpu/vi: expose CB chicken bit registers via read reg interface
 2016-09-12 19:36 UTC  (2+ messages)
  ` [PATCH 2/2] drm/amdgpu/cik: "

[PATCH 1/2] dma-buf: return index of the first signaled fence
 2016-09-12 18:59 UTC  (2+ messages)
  ` [PATCH 2/2] drm/amdgpu: return first signaled fence index in status parameter

[PATCH] drm/amdgpu: add the interface of waiting multiple fences (v3)
 2016-09-12 18:48 UTC  (4+ messages)

[PATCH] drm/amdgpu: Avoid use-after-free
 2016-09-12 18:21 UTC  (2+ messages)

[PATCH] drm/amdgpu: add the interface of waiting multiple fences (v2)
 2016-09-12 16:24 UTC 

use-after-free in libdrm
 2016-09-12 16:00 UTC 

[PATCH 1/4] amdgpu: add the function to get the marketing name (v2)
 2016-09-12 15:14 UTC  (4+ messages)
  ` [PATCH 2/4] amdgpu: add the interface of waiting multiple fences
  ` [PATCH 3/4] amdgpu/tests: add multi-fence test in base test
  ` [PATCH 4/4] amdgpu: cs_wait_fences now can return the first signaled fence index

[PATCH 1/3] drm/amdgpu: add AMDGPU_BO_INVALID_OFFSET
 2016-09-12 14:45 UTC  (5+ messages)
  ` [PATCH 2/3] drm/amdgpu: unbind GTT only when it is bound
  ` [PATCH 3/3] drm/amdgpu: add a custom GTT memory manager

[PATCH 0/3] rename file name
 2016-09-12 10:43 UTC  (6+ messages)
  ` [PATCH 1/3] drm/amd/powerplay: rename tonga_processpptable* to processpptable_v1_0*
  ` [PATCH 2/3] drm/amd/powerplay: add pp_table_version in hwmgr
  ` [PATCH 3/3] drm/amd/powerplay: add pptable point check before use it

[PATCH] drm/amdgpu: move some release handles into fail labels
 2016-09-12  9:07 UTC  (3+ messages)

[PATCH 0/9] misc patches related to powerplay
 2016-09-09 22:45 UTC  (14+ messages)
  ` [PATCH 1/9] drm/amd/powerplay: mark symbols static where possible on tonga/iceland
  ` [PATCH 2/9] drm/amd/powerplay: add feature flags in hwmgr to enable/disable special features
  ` [PATCH 3/9] drm/amd/powerplay: add module parameter for mask pp feature
  ` [PATCH 4/9] drm/amd/powerplay: initialize platform caps in hwmgr_init
  ` [PATCH 5/9] drm/amd/powerplay: add common functiones for visiting pp table
  ` [PATCH 6/9] drm/amd/powerplay: wrap get evv voltage of fiji and polaris
  ` [PATCH 7/9] drm/amd/powerplay: move smu related variable definitions to smumgr
  ` [PATCH 8/9] drm/amd/powerplay: delete const flag of hwmgr_funcs for overload
  ` [PATCH 9/9] drm/amd/powerplay: delete dupicated function and definition

[PATCH 1/2] drm/ttm: remove unused placement flags
 2016-09-09 15:11 UTC  (11+ messages)

[PATCH 00/20] powerplay code refactoring
 2016-09-09 13:39 UTC  (21+ messages)
  ` [PATCH 01/20] drm/amd/powerplay: add common interface in smumgr to help to visit fw image
  ` [PATCH 02/20] drm/amd/powerplay: implement smu7 hwmgr to manager asics with smu ip version 7
  ` [PATCH 03/20] drm/amd/powerplay: implement fw image related smum interface for Polaris
  ` [PATCH 04/20] drm/amd/powerplay: use smu7 hwmgr to manager polaris10/11
  ` [PATCH 05/20] drm/amd/powerplay: implement fw image related smu interface for Fiji
  ` [PATCH 06/20] drm/amd/powerplay: use smu7 hwmgr to manager fiji
  ` [PATCH 07/20] drm/amd/powerplay: implement fw image related smum interface for tonga
  ` [PATCH 08/20] drm/amd/powerplay: use smu7_hwmgr to manager tonga
  ` [PATCH 09/20] drm/amd/powerplay: implement smu7_smumgr for asics with smu ip version 7
  ` [PATCH 10/20] drm/amd/powerplay: use smu7 common functions and data on Tonga
  ` [PATCH 11/20] drm/amd/powerplay: use smu7 common functions and data on Polars10
  ` [PATCH 12/20] drm/amd/powerplay: use smu7 common functions and data on Fiji
  ` [PATCH 13/20] drm/amd/powerplay: use smu7 common functions and data on icelannd
  ` [PATCH 14/20] drm/amd/powerplay: rename tonga_processpptable* to processpptable_v1_0*
  ` [PATCH 15/20] drm/amd/powerplay: add pp_table_version in hwmgr
  ` [PATCH 16/20] drm/amd/powerplay: add pp table v0 support in smu7_hwmgr
  ` [PATCH 17/20] drm/amd/powerplay: add pptable point check before use it
  ` [PATCH 18/20] drm/amd/powerplay: implement fw related smu interface for iceland
  ` [PATCH 19/20] drm/amd/powerplay: use smu7 hwmgr to manager iceland
  ` [PATCH 20/20] drm/amd/powerplay: delete useless files

[PATCH] drm/amdgpu: validate size and offset of user fence BO
 2016-09-09 11:30 UTC 

[PATCH] drm/amdgpu: use error label to handle exceptional case
 2016-09-09 10:30 UTC  (3+ messages)

[PATCH 1/2] drm/amdgpu: update gart_pin_size if bo is in GTT
 2016-09-09  8:52 UTC  (7+ messages)
  ` [PATCH 2/2] drm/amdgpu: calc addr with domain's gpu_offset
      ` 答复: "

[PATCH xserver] config: fix GPUDevice fail when AutoAddGPU off + BusID
 2016-09-08 13:24 UTC 

[PATCH xf86-video-amdgpu 01/12] Add explicit AMDGPU_DRM_QUEUE_ERROR define
 2016-09-08 12:53 UTC  (13+ messages)
  ` [PATCH xf86-video-amdgpu 02/12] Use EventCallback to avoid flushing every time in the FlushCallback
  ` [PATCH xf86-video-amdgpu 03/12] Keep track of damage event related flushes per-client
  ` [PATCH xf86-video-amdgpu 04/12] Wait for pending flips to complete before turning off an output or CRTC
  ` [PATCH xf86-video-amdgpu 05/12] Use drmmode_crtc_scanout_* helpers for RandR 1.4 scanout pixmaps
  ` [PATCH xf86-video-amdgpu 06/12] Handle RandR 1.4 slave dirty updates via amdgpu_drm_queue
  ` [PATCH xf86-video-amdgpu 07/12] Track damage accurately for RandR 1.4 slave scanout
  ` [PATCH xf86-video-amdgpu 08/12] Only copy from screen pixmap to shared pixmap on demand for "
  ` [PATCH xf86-video-amdgpu 09/12] Factor out transform_region helper
  ` [PATCH xf86-video-amdgpu 10/12] Move up amdgpu_scanout_extents_intersect
      ` [PATCH xf86-video-amdgpu 11/12] Synchronize scanout pixmaps for TearFree
      ` [PATCH xf86-video-amdgpu 12/12] Make TearFree effective with PRIME slave scanout

[PATCH v2] drm/amd/amdgpu: S4 issue for amdgpu
 2016-09-08 12:47 UTC  (4+ messages)
    ` 答复: "

[PATCH 1/3] drm/amd/powerplay: calculate flexible array member's address
 2016-09-08 12:36 UTC  (7+ messages)
  ` [PATCH 2/3] drm/amdgpu: fix compiler warning
  ` [PATCH 3/3] drm/amd/powerplay: declare functions instand of include header file

[PATCH 6/6] drm: Add DRM_MODE_PAGE_FLIP_TARGET_ABSOLUTE/RELATIVE flags
 2016-09-08  9:36 UTC  (5+ messages)
` [PATCH 6/6] drm: Add DRM_MODE_PAGE_FLIP_TARGET_ABSOLUTE/RELATIVE flags v2

[PATCH v3] drm: modify drm_global_item_ref to avoid two times of writing ref->object
 2016-09-08  8:08 UTC  (7+ messages)

[PATCH] drm/amdgpu:implement CONTEXT_CONTROL (v5)
 2016-09-08  7:22 UTC  (2+ messages)

[PATCH] drm/amdgpu:implement CONTEXT_CONTROL (v5)
 2016-09-08  6:33 UTC  (3+ messages)

Various tidy'ups with SI DMA/DPM/SMC/IH code
 2016-09-08  1:51 UTC  (5+ messages)
` [PATCH 7/7] drm/amd/amdgpu: Comment out currently unused SI DPM struct

[PATCH 1/2] drm/amdgpu: add a new helper to free a BO in kernel allocations
 2016-09-08  1:50 UTC  (3+ messages)

[PATCH 1/2] drm/amdgpu: fix GTT offset handling
 2016-09-07 16:26 UTC  (8+ messages)
` [PATCH 2/2] drm/amdgpu: bind GTT on demand

[PATCH] drm/amd/amdgpu: Fix return values in SI DPM code
 2016-09-07 15:47 UTC  (2+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox