AMD-GFX Archive on lore.kernel.org
 help / color / mirror / Atom feed
 messages from 2025-10-08 18:53:14 to 2025-10-10 15:10:55 UTC [more...]

[PATCH v3 2/5] drm/ttm: Replace multiple booleans with flags in pool init
 2025-10-10 15:10 UTC  (2+ messages)

[PATCH 1/6] drm/amdgpu: Updated naming of SRIOV critical region offsets/sizes with _V1 suffix
 2025-10-10 15:04 UTC  (12+ messages)
` [PATCH 2/6] drm/amdgpu: Add SRIOV crit_region_version support
` [PATCH 3/6] drm/amdgpu: Introduce SRIOV critical regions v2 during VF init
` [PATCH 4/6] drm/amdgpu: Reuse fw_vram_usage_* for dynamic critical region in SRIOV
` [PATCH 5/6] drm/amdgpu: Add logic for VF ipd and VF bios to init from dynamic crit_region offsets
` [PATCH 6/6] drm/amdgpu: Add logic for VF data exchange region "

[PATCH v2 1/2] drm/amdgpu: Add amdgpu_discovery_info
 2025-10-10 14:57 UTC  (2+ messages)
` [PATCH v2 2/2] drm/amdgpu: Reserve discovery TMR only if needed

[PATCH 00/28] Fair DRM scheduler
 2025-10-10 14:29 UTC  (28+ messages)
` [PATCH 01/28] drm/sched: Reverse drm_sched_rq_init arguments
` [PATCH 02/28] drm/sched: Add some scheduling quality unit tests
` [PATCH 03/28] drm/sched: Add some more "
` [PATCH 04/28] drm/sched: Implement RR via FIFO
` [PATCH 05/28] drm/sched: Consolidate entity run queue management
` [PATCH 06/28] drm/sched: Move run queue related code into a separate file
` [PATCH 07/28] drm/sched: Free all finished jobs at once
` [PATCH 08/28] drm/sched: Account entity GPU time
` [PATCH 19/28] drm/imagination: Remove drm_sched_init_args->num_rqs usage
` [PATCH 24/28] drm/panthor: "
` [PATCH 25/28] drm/sched: "
` [PATCH 26/28] drm/v3d: "

[Patch v4 1/2] drm/amdgpu: update the functions to use amdgpu version of hmm
 2025-10-10 14:07 UTC  (2+ messages)
` [Patch v4 2/2] drm/amdgpu/userqueue: validate userptrs for userqueues

[PATCH 1/2] drm/amdgpu: Add amdgpu_discovery_info
 2025-10-10 14:07 UTC  (3+ messages)
` [PATCH 2/2] drm/amdgpu: Reserve discovery TMR only if needed

[Patch v3 1/2] drm/amdgpu: update the functions to use amdgpu version of hmm
 2025-10-10 13:54 UTC  (2+ messages)
` [Patch v3 2/2] drm/amdgpu/userqueue: validate userptrs for userqueues

[PATCH] drm/sched: Avoid killing entity last used by parent on child SIGKILL
 2025-10-10 12:48 UTC  (5+ messages)

Unplayable framerates in game but specific kernel versions work, maybe amdgpu problem
 2025-10-10  9:06 UTC  (6+ messages)

[PATCH] drm/radeon: Solve the problem of the audio options not disappearing promptly after unplugging the HDMI audio
 2025-10-10 11:03 UTC 

[PATCH] drm/amdgpu: re-enable power1_cap* hwmon nodes for gfx 11.0.3 vf mode
 2025-10-10 11:49 UTC 

[PATCH 1/3] drm/amdgpu: handle wrap around in reemit handling
 2025-10-10 11:37 UTC  (3+ messages)

[Patch v2] drm/amdgpu/userqueue: validate userptrs for userqueues
 2025-10-10  8:49 UTC  (3+ messages)

[PATCH v5 00/30] Fix DYNAMIC_DEBUG classmaps for DRM
 2025-10-09 17:58 UTC  (31+ messages)
` [PATCH v5 01/30] docs/dyndbg: update examples \012 to \n
` [PATCH v5 02/30] docs/dyndbg: explain flags parse 1st
` [PATCH v5 03/30] test-dyndbg: fixup CLASSMAP usage error
` [PATCH v5 04/30] dyndbg: reword "class unknown, " to "class:_UNKNOWN_"
` [PATCH v5 05/30] dyndbg: make ddebug_class_param union members same size
` [PATCH v5 06/30] dyndbg: drop NUM_TYPE_ARRAY
` [PATCH v5 07/30] dyndbg: tweak pr_fmt to avoid expansion conflicts
` [PATCH v5 08/30] dyndbg: reduce verbose/debug clutter
` [PATCH v5 09/30] dyndbg: refactor param_set_dyndbg_classes and below
` [PATCH v5 10/30] dyndbg: tighten fn-sig of ddebug_apply_class_bitmap
` [PATCH v5 11/30] dyndbg: replace classmap list with a vector
` [PATCH v5 12/30] dyndbg: macrofy a 2-index for-loop pattern
` [PATCH v5 13/30] dyndbg: DECLARE_DYNDBG_CLASSMAP needs stub defn
` [PATCH v5 14/30] dyndbg, module: make proper substructs in _ddebug_info
` [PATCH v5 15/30] dyndbg: hoist classmap-filter-by-modname up to ddebug_add_module
` [PATCH v5 16/30] dyndbg: move mod_name from ddebug_table down to _ddebug_info
` [PATCH v5 17/30] dyndbg-API: remove DD_CLASS_TYPE_(DISJOINT|LEVEL)_NAMES and code
` [PATCH v5 18/30] selftests-dyndbg: add a dynamic_debug run_tests target
` [PATCH v5 19/30] dyndbg: change __dynamic_func_call_cls* macros into expressions
` [PATCH v5 20/30] dyndbg-API: replace DECLARE_DYNDBG_CLASSMAP
` [PATCH v5 21/30] dyndbg: detect class_id reservation conflicts
` [PATCH v5 22/30] dyndbg: check DYNAMIC_DEBUG_CLASSMAP_DEFINE args at compile-time
` [PATCH v5 23/30] dyndbg-test: change do_prints testpoint to accept a loopct
` [PATCH v5 24/30] dyndbg-API: promote DYNAMIC_DEBUG_CLASSMAP_PARAM to API
` [PATCH v5 25/30] dyndbg: treat comma as a token separator
` [PATCH v5 26/30] dyndbg: split multi-query strings with %
` [PATCH v5 27/30] selftests-dyndbg: add test_mod_submod
` [PATCH v5 28/30] dyndbg: resolve "protection" of class'd pr_debugs
` [PATCH v5 29/30] dyndbg: add DYNAMIC_DEBUG_CLASSMAP_USE_(clname, _base)
` [PATCH v5 30/30] docs/dyndbg: add classmap info to howto

[PATCH] drm/amd: Permit DC_FP_START/END only in non-FP compilation units
 2025-10-09 21:27 UTC  (4+ messages)

[PATCH v2 1/2] drm/amdgpu: Add kiq hdp flush callbacks
 2025-10-10  7:32 UTC  (2+ messages)
` [PATCH v2 2/2] drm/amdgpu: use GPU_HDP_FLUSH for sriov

[PATCH v5 0/4] Adjustment to power limit setting
 2025-10-10  7:12 UTC  (6+ messages)
` [PATCH v5 1/4] drm/amd: Stop overloading power limit with limit type
` [PATCH v5 2/4] drm/amd: Remove second call to set_power_limit()
` [PATCH v5 3/4] drm/amd: Save and restore all limit types
` [PATCH v5 4/4] drm/amd: Drop calls to restore power limit and clock from smu_resume()

[PATCH 1/2] drm/amd: Add a helper to tell whether an IP block HW is enabled
 2025-10-09 20:55 UTC  (2+ messages)
` [PATCH 2/2] drm/amd/display: Check if display HW is enabled in amdgpu_dm_atomic_check()

[PATCH 0/6] pre-req fixes for mes user compute queue reset
 2025-10-09 20:36 UTC  (17+ messages)
` [PATCH 1/6] drm/amdgpu: fix gfx12 mes packet status return check
` [PATCH 2/6] drm/amdgpu: fix initialization of doorbell array for detect and hang
` [PATCH 3/6] drm/amdgpu: fix hung reset queue array return for hws user compute
` [PATCH 4/6] drm/amdgpu: enable suspend/resume all for gfx 12
` [PATCH 5/6] drm/amdkfd: fix suspend/resume all calls in mes based eviction path
` [PATCH 6/6] drm/amdgpu: update remove after reset flag for MES remove queue

[PATCH 0/3] More SI power management and PLL fixes
 2025-10-09 19:38 UTC  (9+ messages)
` [PATCH 1/3] drm/amd/pm: Disable MCLK switching on SI at high pixel clocks
` [PATCH 2/3] drm/amd: Disable ASPM on SI
` [PATCH 3/3] drm/amd/display: Set stricter clock dividers on DCE 6-10

[PATCH 00/23] Analog connector support in DC (v2)
 2025-10-09 18:27 UTC  (7+ messages)
` [PATCH 13/23] drm/amd/display: Support DAC in dce110_hwseq

6.18/regression/bisected – BUG: sleeping function called from invalid context at ./include/linux/sched/mm.h:321 after 6d31602a9f57
 2025-10-09 16:55 UTC  (4+ messages)

[pull] amdgpu, amdkfd drm-next-6.18
 2025-10-09 16:29 UTC 

[PATCH] drm/amdgpu: fix gfx12 mes packet submission status check
 2025-10-09 16:09 UTC  (10+ messages)

[PATCH 5/6] drm/amdgpu: Add logic for VF ipd and VF bios to init from dynamic crit_region offsets
 2025-10-09 15:24 UTC  (3+ messages)

[PATCH v2] Revert "drm/amd/display: Only restore backlight after amdgpu_dm_init or dm_resume"
 2025-10-09 14:57 UTC  (2+ messages)

[PATCH v4 0/6] Adjustment to power limit setting
 2025-10-09 14:11 UTC  (9+ messages)
` [PATCH v4 1/6] drm/amd: Remove some unncessary header includes
` [PATCH v4 2/6] drm/amd: Stop overloading power limit with limit type
` [PATCH v4 3/6] drm/amd: Remove second call to set_power_limit()
` [PATCH v4 4/6] drm/amd: Save and restore all limit types
` [PATCH v4 5/6] drm/amd: Drop calls to restore power limit and clock from smu_resume()
` [PATCH v4 6/6] drm/amd: Adjust whitespace for vangogh_ppt

[PATCH 4/6] drm/amdgpu: Reuse fw_vram_usage_* for dynamic critical region in SRIOV
 2025-10-09 13:59 UTC  (4+ messages)

[PATCH 3/6] drm/amdgpu: Introduce SRIOV critical regions v2 during VF init
 2025-10-09 13:50 UTC  (3+ messages)

[PATCH 0/4] drm/client: Implement free callback for fbdev and log
 2025-10-09 13:32 UTC  (6+ messages)
` [PATCH 1/4] drm/client: Add client free callback to unprepare fb_helper
` [PATCH 2/4] drm/log: Do not hold lock across drm_client_release()
` [PATCH 3/4] drm/log: Add free callback
` [PATCH 4/4] drm/client: Do not free client memory by default

[PATCH 1/2] drm/amdgpu: Add kiq hdp flush callbacks
 2025-10-09 12:46 UTC  (4+ messages)
` [PATCH 2/2] drm/amdgpu: use GPU_HDP_FLUSH for sriov

[PATCH] Revert "drm/amd/display: Only restore backlight after amdgpu_dm_init or dm_resume"
 2025-10-09 10:49 UTC  (4+ messages)

[PATCH 1/6] drm/amdgpu: Updated naming of SRIOV critical region offsets/sizes with _V1 suffix
 2025-10-09 12:15 UTC  (2+ messages)

[PATCH v3 0/5] Improving the worst case TTM large allocation latency
 2025-10-09  8:58 UTC  (11+ messages)
` [PATCH v3 5/5] drm/amdgpu: Configure max beneficial TTM pool allocation order

[PATCH v3 00/19 5.15.y] Backport minmax.h updates from v6.17-rc7
 2025-10-08 15:29 UTC  (20+ messages)
` [PATCH v3 01/19 5.15.y] minmax: add in_range() macro
` [PATCH v3 02/19 5.15.y] minmax: Introduce {min,max}_array()
` [PATCH v3 03/19 5.15.y] minmax: deduplicate __unconst_integer_typeof()
` [PATCH v3 04/19 5.15.y] minmax: fix indentation of __cmp_once() and __clamp_once()
` [PATCH v3 05/19 5.15.y] minmax: avoid overly complicated constant expressions in VM code
` [PATCH v3 06/19 5.15.y] minmax: add a few more MIN_T/MAX_T users
` [PATCH v3 07/19 5.15.y] minmax: simplify and clarify min_t()/max_t() implementation
` [PATCH v3 08/19 5.15.y] minmax: make generic MIN() and MAX() macros available everywhere
` [PATCH v3 09/19 5.15.y] minmax: don't use max() in situations that want a C constant expression
` [PATCH v3 10/19 5.15.y] minmax: simplify min()/max()/clamp() implementation
` [PATCH v3 11/19 5.15.y] minmax: improve macro expansion and type checking
` [PATCH v3 12/19 5.15.y] minmax: fix up min3() and max3() too
` [PATCH v3 13/19 5.15.y] minmax.h: add whitespace around operators and after commas
` [PATCH v3 14/19 5.15.y] minmax.h: update some comments
` [PATCH v3 15/19 5.15.y] minmax.h: reduce the #define expansion of min(), max() and clamp()
` [PATCH v3 16/19 5.15.y] minmax.h: use BUILD_BUG_ON_MSG() for the lo < hi test in clamp()
` [PATCH v3 17/19 5.15.y] minmax.h: move all the clamp() definitions after the min/max() ones
` [PATCH v3 18/19 5.15.y] minmax.h: simplify the variants of clamp()
` [PATCH v3 19/19 5.15.y] minmax.h: remove some #defines that are only expanded once

[PATCH RESEND] drm/amd/display: Initialize return value in dm_cache_state()
 2025-10-08 22:00 UTC  (3+ messages)

[PATCH 5.10.y 0/2] drm/amd/display: Fix potential null dereference
 2025-10-09  2:17 UTC  (3+ messages)
` [PATCH 5.10.y 1/2] drm/amd/display: Remove redundant safeguards for dmub-srv destroy()
` [PATCH 5.10.y 2/2] drm/amd/display: Fix potential null dereference

[PATCH 00/16] drm/atomic: Switch drm_private_obj to reset
 2025-10-08 13:30 UTC  (3+ messages)
` [PATCH 15/16] drm/atomic: Remove state argument to drm_atomic_private_obj_init

[PATCH] drm/amdgpu/userq: drop VCN and VPE doorbell handling
 2025-10-09  6:20 UTC  (2+ messages)

[PATCH] drm/amdgpu: hide VRAM sysfs attributes on GPUs without VRAM
 2025-10-09  6:00 UTC  (3+ messages)

[PATCH 6/6] drm/amdgpu: Add logic for VF data exchange region to init from dynamic crit_region offsets
 2025-10-09  3:31 UTC 

[PATCH 2/6] drm/amdgpu: Add SRIOV crit_region_version support
 2025-10-09  3:30 UTC 

[v7 1/2] drm/amdgpu: Convert amdgpu userqueue management from IDR to XArray
 2025-10-09  2:12 UTC  (2+ messages)

[PATCH v2 0/5] Adjustment to power limit setting
 2025-10-08 18:53 UTC  (5+ messages)
`  "


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox