From: "Timur Kristóf" <timur.kristof@gmail.com>
To: amd-gfx@lists.freedesktop.org,
Tvrtko Ursulin <tvrtko.ursulin@igalia.com>
Cc: kernel-dev@igalia.com, Alex Deucher <alexander.deucher@amd.com>
Subject: Re: [RFC 1/2] drm/amdgpu: Store SDMA instance and index in the ring
Date: Tue, 08 Sep 2026 11:32:38 +0200 [thread overview]
Message-ID: <F3N0UX71T9uRTCKIeAarRQ@gmail.com> (raw)
In-Reply-To: <76000248-b0ac-478d-bb13-45d4eebb1676@igalia.com>
On 2026. szeptember 8., kedd 10:54:04 közép-európai nyári idő Tvrtko Ursulin
wrote:
> On 08/09/2026 09:42, Timur Kristóf wrote:
> > On 2026. június 22., hétfő 16:36:48 közép-európai nyári idő Tvrtko Ursulin
> >
> > wrote:
> >> Instead of searching for the matching SDMA instance inside many of the
> >> SDMA ring vfuncs, lets just cache the instance and index in the new SDMA
> >> specific section of struct amdgpu_ring. This converts a function call
> >> plus
> >> array walks to a direct lookup.
> >
> > AFAIK, the rings already have the IP block instance ID in the "me" field.
> > So this could be simplified by using that. For example like this:
> > https://pastebin.com/raw/jp4Uk2sE
>
> Ah thank you, it never occurred to me ring->me is not a management
> engine of some sort but ring's personal pronoun. :)
I think the field should be better documented. AFAIU, it refers to the firmware
instance that handles the ring. For SDMA it's the same as the instance ID.
(For graphics/compute this is the "micro engine" CP (command processor)
instance. There is only one graphics/compute IP block and there are several CP
instance within that same IP block.)
In your words, "on a rainy day" we can write that documentation or just rename
the field to something more meaningful. :)
> >> While at it, we also consolidate the initialization side with a new
> >> amdgpu_sdma_ring_init() helper.
> >
> > Can you move that part to a separate commit?
>
> Yes that makes much more sense indeed, will do.
Thanks!
next prev parent reply other threads:[~2026-09-08 9:32 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-06-22 14:36 [RFC 0/2] Store SDMA ring instance and index in the ring Tvrtko Ursulin
2026-06-22 14:36 ` [RFC 1/2] drm/amdgpu: Store SDMA " Tvrtko Ursulin
2026-09-08 8:42 ` Timur Kristóf
2026-09-08 8:54 ` Tvrtko Ursulin
2026-09-08 9:32 ` Timur Kristóf [this message]
2026-06-22 14:36 ` [RFC 2/2] drm/amdgpu: Drop null SDMA instance checks from SDMA vfuncs Tvrtko Ursulin
2026-09-08 8:42 ` Timur Kristóf
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=F3N0UX71T9uRTCKIeAarRQ@gmail.com \
--to=timur.kristof@gmail.com \
--cc=alexander.deucher@amd.com \
--cc=amd-gfx@lists.freedesktop.org \
--cc=kernel-dev@igalia.com \
--cc=tvrtko.ursulin@igalia.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).