From: "Timur Kristóf" <timur.kristof@gmail.com>
To: amd-gfx@lists.freedesktop.org,
Alex Deucher <alexander.deucher@amd.com>,
Natalie Vock <natalie.vock@gmx.de>, Melissa Wen <mwen@igalia.com>,
mario.limonciello@amd.com, alex.hung@amd.com,
harry.wentland@amd.com, Tvrtko Ursulin <tursulin@ursulin.net>
Subject: Re: [PATCH 1/2] drm/amd/display: Shorten name of FRL polling workqueue
Date: Tue, 14 Jul 2026 10:51:03 +0200 [thread overview]
Message-ID: <aXo6J2_kQ_SXM08igon8Aw@gmail.com> (raw)
In-Reply-To: <c1d30a27-0fa2-442c-b2be-aac23137a08e@ursulin.net>
On Monday, July 13, 2026 12:15:13 PM Central European Summer Time Tvrtko
Ursulin wrote:
> On 11/07/2026 12:30, Timur Kristóf wrote:
> > The current name is too long and triggers a warning.
> >
> > Signed-off-by: Timur Kristóf <timur.kristof@gmail.com>
> > ---
> >
> > drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 4 ++--
> > 1 file changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
> > b/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c index
> > b97ceabe6173..6299f0e384f1 100644
> > --- a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
> > +++ b/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
> > @@ -829,9 +829,9 @@ static int amdgpu_dm_init(struct amdgpu_device *adev)
> >
> > }
> > if (adev->dm.dc->caps.max_links > 0) {
> >
> > adev->dm.hdmi_frl_status_polling_wq =
> >
> > -
create_singlethread_workqueue("hdmi_frl_status_polling_workqueue");
> > +
create_singlethread_workqueue("hdmi_frl_status_polling_wq");
> >
> > if (!adev->dm.hdmi_frl_status_polling_wq)
> >
> > - drm_err(adev_to_drm(adev), "failed to
initialize
> > hdmi_frl_status_polling_workqueue\n"); +
drm_err(adev_to_drm(adev),
> > "failed to initialize hdmi_frl_status_polling_wq\n");>
> > }
> > if (dc_is_dmub_outbox_supported(adev->dm.dc)) {
> >
> > init_completion(&adev->dm.dmub_aux_transfer_done);
>
> This one does not require display knowledge so I feel okay to review it:
>
> Reviewed-by: Tvrtko Ursulin <tvrtko.ursulin@igalia.com>
>
> Two nitpicks would be that the _wq suffix is even redundant since for
> the task name it will have the kworker/ prefix anyway.
Ok, what name do you suggest to use then?
> Second one is
> that while touching this it may make sense to replace the variable name
> from the error message with a human readable name like "failed to
> initialize HDMI FLR status polling".
Ok, can do.
> In fact, is this even an error or
> should be a warning given I do not see an immediate exit?
No idea, I just wanted to fix the warning that I saw.
Timur
next prev parent reply other threads:[~2026-07-14 8:51 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-11 11:30 [PATCH 1/2] drm/amd/display: Shorten name of FRL polling workqueue Timur Kristóf
2026-07-11 11:30 ` [PATCH 2/2] drm/amd/display: Check HDMI FRL support before creating " Timur Kristóf
2026-07-15 15:46 ` Zuo, Jerry
2026-07-15 18:10 ` Harry Wentland
2026-07-15 19:04 ` Timur Kristóf
2026-07-13 10:15 ` [PATCH 1/2] drm/amd/display: Shorten name of FRL " Tvrtko Ursulin
2026-07-13 13:33 ` Mario Limonciello
2026-07-14 8:51 ` Timur Kristóf [this message]
2026-07-14 9:56 ` Tvrtko Ursulin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=aXo6J2_kQ_SXM08igon8Aw@gmail.com \
--to=timur.kristof@gmail.com \
--cc=alex.hung@amd.com \
--cc=alexander.deucher@amd.com \
--cc=amd-gfx@lists.freedesktop.org \
--cc=harry.wentland@amd.com \
--cc=mario.limonciello@amd.com \
--cc=mwen@igalia.com \
--cc=natalie.vock@gmx.de \
--cc=tursulin@ursulin.net \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox