ATH10K Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Sebastian Gottschall <s.gottschall@dd-wrt.com>
To: Steve deRosier <derosier@gmail.com>
Cc: Sebastian Gottschall <s.gottschall@newmedia-net.de>,
	linux-wireless <linux-wireless@vger.kernel.org>,
	ath10k@lists.infradead.org, Kalle Valo <kvalo@codeaurora.org>
Subject: Re: [PATCH v7] ath10k: add LED and GPIO controlling support for various chipsets
Date: Tue, 20 Feb 2018 20:49:53 +0100	[thread overview]
Message-ID: <248047fb-3805-5b49-bb98-6ace37bc31ca@dd-wrt.com> (raw)
In-Reply-To: <CALLGbR+GQHBcuoO=6BVJYLUhwQk=tv2juWBRDpkyrDtFedfn5Q@mail.gmail.com>


> Agreed, I am also not a fan of bloat code. I wasn't suggesting you
> move it to the .h, just saying that if it were not static, that's how
> I'd suggest doing it.
>
> In this case, keep it static, keep it in the .c.  And use the blocking
> I suggested. You will get the optimizer friendly result you're looking
> for, but make it more readable and more-inline with the dominant style
> for these things.
thats what i did already in my sourcetree
>
>> true, but consider that required structures like gpio_chip (ar->gpio) and
>> led_classdev arent defined in the kernel if these CONFIG options arent
>> configured. so i may move it into a separate function ,but the guards will
>> remain.
>> thats not my fault. thats a fault of the kernel api.
>>
> Hm. I assumed the names were still valid, even if the functionality
> that uses it wasn't.  Understood.
>
> In that case, I suggest moving the code to a separate static function
> that can be guarded. It keeps the mess out of the main startup
> function, makes it easier to read as it collapses to a single
> self-documented function name, and gets rid of the label and jump.
yes but we have 2 guards. GPIOLIB and LED_CLASS
so the mess remaines in the same way with no change. the same unreadable 
code just moved (personally i think its not that unreadable since its small)

>
>>> The rest of this looks OK to me.
>> okay. i already changed some code, based on your requests but will wait for
>> reply of you and for other comments until i send out a new version
> I appreciate the extra work you've put in. I hadn't expected my
> comments would've generated so much extra work; sorry about that. It's
> looking good.
i just want it upstream. i have alot of usefull patches in my backhand 
and its now getting hard to maintain the code with new ath10k patches.
and at the end its not that much work as it seems. just a question of 
some seconds todo that changes. i can live with it.

Sebastian


-- 
Mit freundlichen Grüssen / Regards

Sebastian Gottschall / CTO

NewMedia-NET GmbH - DD-WRT
Firmensitz:  Stubenwaldallee 21a, 64625 Bensheim
Registergericht: Amtsgericht Darmstadt, HRB 25473
Geschäftsführer: Peter Steinhäuser, Christian Scheele
http://www.dd-wrt.com
email: s.gottschall@dd-wrt.com
Tel.: +496251-582650 / Fax: +496251-5826565


_______________________________________________
ath10k mailing list
ath10k@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/ath10k

      reply	other threads:[~2018-02-20 19:50 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-02-20  7:32 [PATCH v7] ath10k: add LED and GPIO controlling support for various chipsets s.gottschall
2018-02-20 13:07 ` Bo YU
2018-02-20 14:41   ` Sebastian Gottschall
2018-02-20 16:52 ` Steve deRosier
2018-02-20 18:06   ` Sebastian Gottschall
2018-02-20 18:39     ` Steve deRosier
2018-02-20 19:49       ` Sebastian Gottschall [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=248047fb-3805-5b49-bb98-6ace37bc31ca@dd-wrt.com \
    --to=s.gottschall@dd-wrt.com \
    --cc=ath10k@lists.infradead.org \
    --cc=derosier@gmail.com \
    --cc=kvalo@codeaurora.org \
    --cc=linux-wireless@vger.kernel.org \
    --cc=s.gottschall@newmedia-net.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox