From: Arend van Spriel <arend.vanspriel@broadcom.com>
To: "Luis R. Rodriguez" <mcgrof@kernel.org>,
"Valo, Kalle" <kvalo@qca.qualcomm.com>
Cc: Prarit Bhargava <prarit@redhat.com>,
Stanislaw Gruszka <sgruszka@redhat.com>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Ming Lei <ming.lei@canonical.com>,
linux-wireless <linux-wireless@vger.kernel.org>,
ath10k <ath10k@lists.infradead.org>,
"mmarek@suse.com" <mmarek@suse.com>,
"michal.kazior@tieto.com" <michal.kazior@tieto.com>,
Arend van Spriel <arend@broadcom.com>,
Emmanuel Grumbach <egrumbach@gmail.com>
Subject: Re: [RFC] ath10k: silence firmware file probing warnings
Date: Wed, 3 Aug 2016 21:19:14 +0200 [thread overview]
Message-ID: <6fb6f394-83fe-87e6-ef49-9fa854899721@broadcom.com> (raw)
In-Reply-To: <20160803171044.GP3296@wotan.suse.de>
On 03-08-16 19:10, Luis R. Rodriguez wrote:
> On Wed, Aug 03, 2016 at 03:04:39PM +0000, Valo, Kalle wrote:
>> "Luis R. Rodriguez" <mcgrof@kernel.org> writes:
>>
>>> On Wed, Aug 03, 2016 at 01:33:31PM +0200, Arend van Spriel wrote:
>>>> On 02-08-16 16:16, Luis R. Rodriguez wrote:
>>>>> On Tue, Aug 02, 2016 at 11:10:22AM +0000, Valo, Kalle wrote:
>>>>>> "Luis R. Rodriguez" <mcgrof@kernel.org> writes:
>>>>>>
>>>>>>> I was considering this as a future extension to the firmware API
>>>>>>> through the new extensible firmware API, the sysdata API.
>>>>>>
>>>>>> I think Linus mentioned this already, but I want to reiterate anyway.
>>>>>> The name "sysdata" is horrible, I didn't have any idea what it means
>>>>>> until I read your description. Please continue to use the term
>>>>>> "firmware", anyone already know what it means.
>>>>>
>>>>> We've gone well past using the firmware API for firmware though, if
>>>>> we use it for 802.11 to replace CRDA for instance its really odd to
>>>>> be calling it firmware. But sure... I will rebrand again to firmware...
>>>>
>>>> I tend to agree. Although some people even call an OpenWrt image
>>>> firmware. Guess it is just in the eye of the beholder.
>>>
>>> Sure...
>>>
>>> Come to think of it I'll still go with "sysdata", this is a very minor
>>> detail, do let me know if there is anything technical rather than
>>> the color of the bikeshed [0] over the patches.
>>
>> Well, you don't seem to care but I prefer that the terminology is clear
>> and I don't want to waste people's time browsing the source to find out
>> what something means.
>
> Its not that I don't care, its this is a super trivial matter, like the
> color of a bikeshed, and I'd much prefer to put energy and review on
> technical matters.
>
>> Even "driverdata" would be more descriptive for me
>> than "sysdata".
>>
>> Actually, what does the "sys" refer here, system? And what system is
>> that exactly?
>
> Yes system, so as in system data file. "driver_data" is just as good.
> Although who knows, others may want to paint the bikeshed a different
> color.
>
> The core reason why the name change is to make emphasis of the fact that
> we've gone way past the point where the APIs are used for non-firmware
> and I expect this use will only grow.
Here some colors to add to the palet with "color code" in brackets:
- device specific data (dsd): although if CRDA stuff is loaded it is no
longer tied to a device.
- eXtensible firmware API (xfw): the ever popular x factor :-p
- binary blob loader (bbl): just popped up in me head.
Need more beer to go on.
Regards,
Arend
_______________________________________________
ath10k mailing list
ath10k@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/ath10k
next prev parent reply other threads:[~2016-08-03 19:19 UTC|newest]
Thread overview: 30+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-07-19 13:00 [RFC] ath10k: silence firmware file probing warnings Michal Kazior
2016-07-21 7:09 ` Stanislaw Gruszka
2016-07-21 7:36 ` Emmanuel Grumbach
2016-07-21 8:05 ` Stanislaw Gruszka
2016-07-21 10:23 ` Prarit Bhargava
2016-07-21 11:51 ` Stanislaw Gruszka
2016-07-21 12:01 ` Prarit Bhargava
2016-07-22 8:38 ` Arend Van Spriel
2016-07-22 10:26 ` Stanislaw Gruszka
2016-07-22 12:21 ` Arend Van Spriel
2016-07-22 12:51 ` Prarit Bhargava
2016-07-22 22:19 ` Luis R. Rodriguez
2016-07-25 7:51 ` Emmanuel Grumbach
2016-07-22 22:15 ` Luis R. Rodriguez
2016-07-28 19:23 ` Arend van Spriel
2016-08-02 11:10 ` Valo, Kalle
2016-08-02 14:16 ` Luis R. Rodriguez
2016-08-03 11:33 ` Arend van Spriel
2016-08-03 14:21 ` Luis R. Rodriguez
2016-08-03 15:04 ` Valo, Kalle
2016-08-03 17:10 ` Luis R. Rodriguez
2016-08-03 19:19 ` Arend van Spriel [this message]
2016-07-22 22:05 ` Luis R. Rodriguez
2016-07-28 19:23 ` Arend van Spriel
2016-07-28 23:28 ` Luis R. Rodriguez
2016-08-02 11:18 ` Valo, Kalle
2016-08-02 11:24 ` Felix Fietkau
2017-01-20 12:51 ` Kalle Valo
2017-01-20 12:56 ` Michal Kazior
2017-01-31 15:02 ` Kalle Valo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=6fb6f394-83fe-87e6-ef49-9fa854899721@broadcom.com \
--to=arend.vanspriel@broadcom.com \
--cc=arend@broadcom.com \
--cc=ath10k@lists.infradead.org \
--cc=egrumbach@gmail.com \
--cc=gregkh@linuxfoundation.org \
--cc=kvalo@qca.qualcomm.com \
--cc=linux-wireless@vger.kernel.org \
--cc=mcgrof@kernel.org \
--cc=michal.kazior@tieto.com \
--cc=ming.lei@canonical.com \
--cc=mmarek@suse.com \
--cc=prarit@redhat.com \
--cc=sgruszka@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox