From mboxrd@z Thu Jan 1 00:00:00 1970 Return-path: Received: from wolverine02.qualcomm.com ([199.106.114.251]) by bombadil.infradead.org with esmtps (Exim 4.87 #1 (Red Hat Linux)) id 1cr59v-00074F-I5 for ath10k@lists.infradead.org; Thu, 23 Mar 2017 16:00:25 +0000 From: Kalle Valo Subject: Re: [PATCH v6 06/10] ath10k: add sdio extra initializations Date: Thu, 23 Mar 2017 15:59:53 +0000 Message-ID: <87h92kyoef.fsf@kamboji.qca.qualcomm.com> References: <148959263520.31432.8488419244476213373.stgit@potku.adurom.net> <148959276143.31432.4108050733445067980.stgit@potku.adurom.net> <9eb52257-2753-d9d0-2590-dd05c7aedea6@qca.qualcomm.com> In-Reply-To: <9eb52257-2753-d9d0-2590-dd05c7aedea6@qca.qualcomm.com> (Ryan Hsu's message of "Thu, 16 Mar 2017 01:18:58 +0000") Content-Language: en-US MIME-Version: 1.0 List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Sender: "ath10k" Errors-To: ath10k-bounces+kvalo=adurom.com@lists.infradead.org To: Ryan Hsu Cc: "ath10k@lists.infradead.org" Ryan Hsu writes: > On 03/15/2017 08:46 AM, Kalle Valo wrote: > >> From: Erik Stromdahl >> >> Extra initializations needed by all sdio boards. >> Derived from qcacld. >> >> Signed-off-by: Erik Stromdahl >> Signed-off-by: Kalle Valo >> --- >> drivers/net/wireless/ath/ath10k/core.c | 22 ++++++++++++++++++++-- >> 1 file changed, 20 insertions(+), 2 deletions(-) >> >> diff --git a/drivers/net/wireless/ath/ath10k/core.c b/drivers/net/wireless/ath/ath10k/core.c >> index f450ebbb28d5..6b6ea8a571fa 100644 >> --- a/drivers/net/wireless/ath/ath10k/core.c >> +++ b/drivers/net/wireless/ath/ath10k/core.c >> @@ -377,7 +377,22 @@ static void ath10k_send_suspend_complete(struct ath10k *ar) >> complete(&ar->target_suspend); >> } >> >> -static int ath10k_init_configure_target(struct ath10k *ar) >> +static void ath10k_sdio_extra_initialization(struct ath10k *ar) >> +{ >> + u32 param = 0; >> + >> + ath10k_bmi_write32(ar, hi_mbox_io_block_sz, 256); >> + ath10k_bmi_write32(ar, hi_mbox_isr_yield_limit, 99); >> + ath10k_bmi_read32(ar, hi_acs_flags, ¶m); >> + >> + param |= (HI_ACS_FLAGS_SDIO_SWAP_MAILBOX_SET | >> + HI_ACS_FLAGS_SDIO_REDUCE_TX_COMPL_SET | >> + HI_ACS_FLAGS_ALT_DATA_CREDIT_SIZE); >> + >> + ath10k_bmi_write32(ar, hi_acs_flags, param); >> +} >> + >> +static int ath10k_init_sdio(struct ath10k *ar) > > Shouldn't we just keep the ath10k_init_configure_target() and move the > sdio specific to ath10k_sdio_extra_initialization()? > instead of renaming this to ath10k_init_sdio()? not sure if this is > just a local hack that didn't revert? Ouch, I was supposed to rename ath10k_sdio_extra_initialization() to ath10k_init_sdio() but accidentally renamed the wrong function. Will fix in v7. Thanks for catching this! -- Kalle Valo _______________________________________________ ath10k mailing list ath10k@lists.infradead.org http://lists.infradead.org/mailman/listinfo/ath10k