From: Kalle Valo <kvalo@codeaurora.org>
To: Anilkumar Kolli <akolli@codeaurora.org>
Cc: linux-wireless@vger.kernel.org, ath10k@lists.infradead.org
Subject: Re: [PATCH 3/4] ath10k: add extended per sta tx statistics support
Date: Fri, 31 Aug 2018 14:59:48 +0300 [thread overview]
Message-ID: <87r2ied9vv.fsf@kamboji.qca.qualcomm.com> (raw)
In-Reply-To: <1533561223-342-4-git-send-email-akolli@codeaurora.org> (Anilkumar Kolli's message of "Mon, 6 Aug 2018 18:43:42 +0530")
Anilkumar Kolli <akolli@codeaurora.org> writes:
> This patch adds per station tx statistics support.
>
> Per station tx stats include
> - pkts/bytes transmitted at all possible rates(mcs/nss/bw/gi).
> - ACK fails count
> - ampdu bytes/pkts transmitted at all possible rates(mcs/nss/bw/gi).
> - BA fails count
>
> Tested on QCA9984/QCA4019/QCA988x
> Firmware: 10.4-3.5.3-00057
> 10.2.4-1.0-00037
>
> Signed-off-by: Anilkumar Kolli <akolli@codeaurora.org>
[...]
> --- a/drivers/net/wireless/ath/ath10k/wmi.h
> +++ b/drivers/net/wireless/ath/ath10k/wmi.h
> @@ -4958,10 +4958,15 @@ enum wmi_rate_preamble {
> #define ATH10K_HW_GI(flags) (((flags) >> 5) & 0x1)
> #define ATH10K_HW_RATECODE(rate, nss, preamble) \
> (((preamble) << 6) | ((nss) << 4) | (rate))
> -
> -#define VHT_MCS_NUM 10
> -#define VHT_BW_NUM 4
> -#define VHT_NSS_NUM 4
> +#define ATH10K_HW_AMPDU(flags) (flags & 0x1)
> +#define ATH10K_HW_BA_FAIL(flags) (((flags) >> 1) & 0x3)
> +
> +#define NUM_VHT_MCS 10
> +#define NUM_BW 4
> +#define NUM_NSS 4
> +#define NUM_LEGACY 12
> +#define NUM_GI 2
> +#define NUM_HT_MCS 32
Why are you renaming these to use NUM_ prefix? That looks odd to me,
usually the "NUM" is the last.
If changing something, you should add ATH10K_ prefix to missing defines.
--
Kalle Valo
_______________________________________________
ath10k mailing list
ath10k@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/ath10k
next prev parent reply other threads:[~2018-08-31 12:00 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-08-06 13:13 [PATCH 0/4] Add support to dump tx stats histogram Anilkumar Kolli
2018-08-06 13:13 ` [PATCH 1/4] ath10k: get the legacy rate index to update the txrate table Anilkumar Kolli
2018-08-06 13:13 ` [PATCH 2/4] ath10k: add debugfs entry to enable extended tx stats Anilkumar Kolli
2018-08-06 13:13 ` [PATCH 3/4] ath10k: add extended per sta tx statistics support Anilkumar Kolli
2018-08-28 13:35 ` Kalle Valo
2018-08-31 11:59 ` Kalle Valo [this message]
2018-08-06 13:13 ` [PATCH 4/4] ath10k: add debugfs support to dump per sta tx stats Anilkumar Kolli
2018-08-28 13:36 ` Kalle Valo
[not found] ` <20180828133640.7D55E6044E@smtp.codeaurora.org>
2018-09-04 8:54 ` Anilkumar Kolli
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87r2ied9vv.fsf@kamboji.qca.qualcomm.com \
--to=kvalo@codeaurora.org \
--cc=akolli@codeaurora.org \
--cc=ath10k@lists.infradead.org \
--cc=linux-wireless@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox