From: Kalle Valo <kvalo@qca.qualcomm.com>
To: Michal Kazior <michal.kazior@tieto.com>
Cc: arnd@arndb.de, linux-wireless@vger.kernel.org,
twilightrook@gmail.com, ath10k@lists.infradead.org,
oscarrydberg@gmail.com, vvanpo@gmail.com,
joseph.salisbury@canonical.com
Subject: Re: [PATCH/RFT 2/2] ath10k: rename qca6174 to qca61x4
Date: Fri, 14 Aug 2015 11:27:23 +0300 [thread overview]
Message-ID: <87zj1ujmvo.fsf@kamboji.qca.qualcomm.com> (raw)
In-Reply-To: <1439469147-9408-3-git-send-email-michal.kazior@tieto.com> (Michal Kazior's message of "Thu, 13 Aug 2015 14:32:27 +0200")
Michal Kazior <michal.kazior@tieto.com> writes:
> This cleans up the naming a little bit. Both
> QCA6174 and QCA6164 are in practice the same as
> far as driving them is concerned.
>
> Unfortunately firmware paths will need to stay
> untouched, i.e. QCA6164 firmware will still be
> looked for in QCA6174 to avoid breaking backward
> compatibility with older /lib/firmware setups.
>
> Signed-off-by: Michal Kazior <michal.kazior@tieto.com>
This is purely cosmetics and only visible to developers, users won't
notice anything, so I'm not sure if this is worth the trouble. With
proper documentation I would hope that any developer will realise that
QCA6174 actually also means QCA6164 support :)
And more to the point there is nothing preventing coming up with a new
version with a name like QCA6964 or QCA9121 so the prefix would be wrong
again. This has happened with ath6kl in the past.
> --- a/drivers/net/wireless/ath/ath10k/core.c
> +++ b/drivers/net/wireless/ath/ath10k/core.c
> @@ -63,49 +63,49 @@ static const struct ath10k_hw_params ath10k_hw_params_list[] = {
> },
> },
> {
> - .id = QCA6174_HW_2_1_VERSION,
> - .name = "qca6174 hw2.1",
> - .patch_load_addr = QCA6174_HW_2_1_PATCH_LOAD_ADDR,
> + .id = QCA61X4_HW_2_1_VERSION,
> + .name = "qca61x4 hw2.1",
What if we instead change the name to "qca6164/qca6176 hw2.1" or
something like that. Would that help?
--
Kalle Valo
_______________________________________________
ath10k mailing list
ath10k@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/ath10k
next prev parent reply other threads:[~2015-08-14 8:28 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-08-13 12:32 [PATCH/RFT 0/2] ath10k: add qca6164 support Michal Kazior
2015-08-13 12:32 ` [PATCH/RFT 1/2] " Michal Kazior
2015-08-18 11:30 ` Kalle Valo
2015-08-26 9:09 ` Kalle Valo
2015-08-13 12:32 ` [PATCH/RFT 2/2] ath10k: rename qca6174 to qca61x4 Michal Kazior
2015-08-14 8:27 ` Kalle Valo [this message]
2015-08-26 9:10 ` Kalle Valo
[not found] ` <CAAay3RQ7N4CFpY3ffxc83Xh2rPDFxne9DZKi+Pay4-Z-+XQ5Bg@mail.gmail.com>
2015-08-20 13:22 ` [PATCH/RFT 0/2] ath10k: add qca6164 support Arnd Bergmann
2015-08-25 13:00 ` Kalle Valo
2015-08-25 12:56 ` Arnd Bergmann
2015-08-25 13:09 ` Michal Kazior
2015-08-25 13:47 ` Arnd Bergmann
2015-08-25 18:24 ` Arnd Bergmann
2015-08-26 9:44 ` Kalle Valo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87zj1ujmvo.fsf@kamboji.qca.qualcomm.com \
--to=kvalo@qca.qualcomm.com \
--cc=arnd@arndb.de \
--cc=ath10k@lists.infradead.org \
--cc=joseph.salisbury@canonical.com \
--cc=linux-wireless@vger.kernel.org \
--cc=michal.kazior@tieto.com \
--cc=oscarrydberg@gmail.com \
--cc=twilightrook@gmail.com \
--cc=vvanpo@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox