From: Kalle Valo <kvalo@codeaurora.org>
To: Kalle Valo <kvalo@codeaurora.org>
Cc: linux-wireless@vger.kernel.org, ath11k@lists.infradead.org
Subject: Re: [PATCH 1/4] ath11k: refactor debugfs code into debugfs.c
Date: Tue, 22 Sep 2020 07:42:15 +0000 (UTC) [thread overview]
Message-ID: <20200922074215.2ED65C433F1@smtp.codeaurora.org> (raw)
In-Reply-To: <1600264523-12939-1-git-send-email-kvalo@codeaurora.org>
Kalle Valo <kvalo@codeaurora.org> wrote:
> If CONFIG_ATH11K_DEBUGFS is disabled there are warnings debug.c:
>
> drivers/net/wireless/ath/ath11k/debug.c:36:20: warning: 'htt_bp_lmac_ring' defined but not used [-Wunused-variable]
> 36 | static const char *htt_bp_lmac_ring[HTT_SW_LMAC_RING_IDX_MAX] = {
> | ^~~~~~~~~~~~~~~~
> drivers/net/wireless/ath/ath11k/debug.c:15:20: warning: 'htt_bp_umac_ring' defined but not used [-Wunused-variable]
> 15 | static const char *htt_bp_umac_ring[HTT_SW_UMAC_RING_IDX_MAX] = {
> | ^~~~~~~~~~~~~~~~
>
> Fix this by refactoring debugfs code to debugfs.c. This also reduces the number
> of ifdefs in debug.c and makes it easier to maintain the code.
>
> No functional changes. Compile tested only.
>
> Reported-by: YueHaibing <yuehaibing@huawei.com>
> Signed-off-by: Kalle Valo <kvalo@codeaurora.org>
4 patches applied to ath-next branch of ath.git, thanks.
da3a9d3c1576 ath11k: refactor debugfs code into debugfs.c
cb4e57db2ff0 ath11k: debugfs: use ath11k_debugfs_ prefix
56292162b9a2 ath11k: rename debug_htt_stats.[c|h] to debugfs_htt_stats.[c|h]
568f06036ee2 ath11k: debugfs: move some function declarations to correct header files
--
https://patchwork.kernel.org/patch/11781017/
https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches
--
ath11k mailing list
ath11k@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/ath11k
prev parent reply other threads:[~2020-09-22 7:42 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-09-16 13:55 [PATCH 1/4] ath11k: refactor debugfs code into debugfs.c Kalle Valo
2020-09-16 13:55 ` [PATCH 2/4] ath11k: debugfs: use ath11k_debugfs_ prefix Kalle Valo
2020-09-16 13:55 ` [PATCH 3/4] ath11k: rename debug_htt_stats.[c|h] to debugfs_htt_stats.[c|h] Kalle Valo
2020-09-16 13:55 ` [PATCH 4/4] ath11k: debugfs: move some function declarations to correct header files Kalle Valo
2020-09-22 7:42 ` Kalle Valo [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200922074215.2ED65C433F1@smtp.codeaurora.org \
--to=kvalo@codeaurora.org \
--cc=ath11k@lists.infradead.org \
--cc=linux-wireless@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox