From mboxrd@z Thu Jan 1 00:00:00 1970 From: Felix Fietkau Date: Sat, 16 May 2015 07:45:02 +0200 Subject: [ath9k-devel] [PATCH] ath9k: add phy.c In-Reply-To: <5556D48B.3090708@rempel-privat.de> References: <1431693340-8861-1-git-send-email-linux@rempel-privat.de> <55564A50.2050004@openwrt.org> <5556D48B.3090708@rempel-privat.de> Message-ID: <5556D95E.40706@openwrt.org> List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: ath9k-devel@lists.ath9k.org On 2015-05-16 07:24, Oleksij Rempel wrote: > Am 15.05.2015 um 21:34 schrieb Felix Fietkau: >> On 2015-05-15 14:35, Oleksij Rempel wrote: >>> ... and move dup code from ar5008_phy.c and ar9002_phy.c to phy.c >>> >>> Signed-off-by: Oleksij Rempel >> We already have base functionality for AR5008-AR9002 provided in some >> ar5008_phy.c, and ar5008_hw_attach_phy_ops is called for those chipsets >> as well. Please keep the de-duplicated code there instead of adding a >> new phy.c, because AR9003+ uses a completely different codepath. >> >> - Felix >> > > ok, thanks. > Currently i celled this function phy_hw_spur_mitigate(), is it ok or > there is some better name for this code? Just use the ar5008 prefix like in the other functions. - Felix