Historical ath9k-devel archives
 help / color / mirror / Atom feed
From: Kalle Valo <kvalo@qca.qualcomm.com>
To: ath9k-devel@lists.ath9k.org
Subject: [ath9k-devel] [PATCH 2/7] ath10k: move suspend/resume exports to core.c file
Date: Thu, 18 Apr 2013 13:36:03 +0300	[thread overview]
Message-ID: <87fvyop1m4.fsf@kamboji.qca.qualcomm.com> (raw)
In-Reply-To: <1366220724-29423-2-git-send-email-bartosz.markowski@tieto.com> (Bartosz Markowski's message of "Wed, 17 Apr 2013 19:45:19 +0200")

Bartosz Markowski <bartosz.markowski@tieto.com> writes:

> --- a/drivers/net/wireless/ath/ath10k/core.c
> +++ b/drivers/net/wireless/ath/ath10k/core.c
> @@ -663,6 +663,31 @@ void ath10k_core_unregister(struct ath10k *ar)
>  }
>  EXPORT_SYMBOL(ath10k_core_unregister);
>  
> +#if defined(CONFIG_PM_SLEEP)
> +int ath10k_pdev_suspend_target(struct ath10k *ar) {
> +	int ret;
> +
> +	ath10k_dbg(ATH10K_DBG_CORE, "%s: called", __func__);
> +
> +	ret = ath10k_wmi_pdev_suspend_target(ar);
> +
> +	return ret;
> +}
> +EXPORT_SYMBOL(ath10k_pdev_suspend_target);
> +
> +int ath10k_pdev_resume_target(struct ath10k *ar) {
> +
> +	int ret;
> +
> +	ath10k_dbg(ATH10K_DBG_CORE, "%s: called", __func__);
> +
> +	ret = ath10k_wmi_pdev_resume_target(ar);
> +
> +	return ret;
> +}
> +EXPORT_SYMBOL(ath10k_pdev_resume_target);

Please rename them to ath10k_core_suspend() and _resume() or something
like that.

-- 
Kalle Valo

  reply	other threads:[~2013-04-18 10:36 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-04-17 17:45 [ath9k-devel] [PATCH 1/7] ath10k: rename struct wmi_struct -> struct ath10k_wmi Bartosz Markowski
2013-04-17 17:45 ` [ath9k-devel] [PATCH 2/7] ath10k: move suspend/resume exports to core.c file Bartosz Markowski
2013-04-18 10:36   ` Kalle Valo [this message]
2013-04-17 17:45 ` [ath9k-devel] [PATCH 3/7] ath10k: remove excessive ifdef checks Bartosz Markowski
2013-04-18  1:52   ` Sujith Manoharan
2013-04-18  6:21     ` Markowski Bartosz
2013-04-18  6:31       ` Sujith Manoharan
2013-04-17 17:45 ` [ath9k-devel] [PATCH 4/7] ath10k: reindent ath10k_pci_suspend Bartosz Markowski
2013-04-18 10:36   ` Kalle Valo
2013-04-17 17:45 ` [ath9k-devel] [PATCH 5/7] ath10k: fix pointer casts in debug code Bartosz Markowski
2013-04-18 10:37   ` Kalle Valo
2013-04-17 17:45 ` [ath9k-devel] [PATCH 6/7] ath10k: shift extern variable where it belongs Bartosz Markowski
2013-04-17 17:45 ` [ath9k-devel] [PATCH 7/7] ath10k: remove unnecessary NULL check Bartosz Markowski
2013-04-18  5:23 ` [ath9k-devel] [PATCH 1/7] ath10k: rename struct wmi_struct -> struct ath10k_wmi Michal Kazior
2013-04-18  6:22   ` Markowski Bartosz

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87fvyop1m4.fsf@kamboji.qca.qualcomm.com \
    --to=kvalo@qca.qualcomm.com \
    --cc=ath9k-devel@lists.ath9k.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox