From: Simon Wunderlich <sw@simonwunderlich.de>
To: netdev@vger.kernel.org
Cc: "David S. Miller" <davem@davemloft.net>,
Eric Dumazet <edumazet@google.com>,
Jakub Kicinski <kuba@kernel.org>, Paolo Abeni <pabeni@redhat.com>,
Simon Horman <horms@kernel.org>,
b.a.t.m.a.n@lists.open-mesh.org,
Sven Eckelmann <sven@narfation.org>,
Simon Wunderlich <sw@simonwunderlich.de>
Subject: [PATCH net-next 05/15] batman-adv: use more descriptive var names for is_similar_or_better
Date: Mon, 31 Aug 2026 15:51:07 +0200 [thread overview]
Message-ID: <20260831135117.574836-6-sw@simonwunderlich.de> (raw)
In-Reply-To: <20260831135117.574836-1-sw@simonwunderlich.de>
From: Sven Eckelmann <sven@narfation.org>
neigh1 and neigh2 is not really helpful when looking at a code which needs
to judge the metric similarity between a candidate and a reference. This
already caused an implementation error in the B.A.T.M.A.N. V bonding code.
Simply using "reference" and "candidate" for the neighbors is a lot more
descriptive and makes it easier to understand the code.
Signed-off-by: Sven Eckelmann <sven@narfation.org>
Signed-off-by: Simon Wunderlich <sw@simonwunderlich.de>
---
net/batman-adv/bat_iv_ogm.c | 25 +++++++++++-----------
net/batman-adv/bat_v.c | 42 ++++++++++++++++++-------------------
net/batman-adv/types.h | 12 +++++------
3 files changed, 40 insertions(+), 39 deletions(-)
diff --git a/net/batman-adv/bat_iv_ogm.c b/net/batman-adv/bat_iv_ogm.c
index 53fbdbbe8f4f7..3fe09b4c30463 100644
--- a/net/batman-adv/bat_iv_ogm.c
+++ b/net/batman-adv/bat_iv_ogm.c
@@ -2424,25 +2424,26 @@ static int batadv_iv_ogm_neigh_cmp(struct batadv_neigh_node *neigh1,
/**
* batadv_iv_ogm_neigh_is_sob() - check if neigh1 is similarly good or better
* than neigh2 from the metric prospective
- * @neigh1: the first neighbor object of the comparison
- * @if_outgoing1: outgoing interface for the first neighbor
- * @neigh2: the second neighbor object of the comparison
- * @if_outgoing2: outgoing interface for the second neighbor
+ * @candidate: the first neighbor object of the comparison
+ * @if_outgoing_cand: outgoing interface for the @candidate neighbor
+ * @reference: the second neighbor object of the comparison
+ * @if_outgoing_ref: outgoing interface for the @reference neighbor
*
- * Return: true if the metric via neigh1 is equally good or better than
- * the metric via neigh2, false otherwise.
+ * Return: true if the metric via @candidate is equally good or better than
+ * the metric via @reference, false otherwise.
*/
static bool
-batadv_iv_ogm_neigh_is_sob(struct batadv_neigh_node *neigh1,
- struct batadv_hard_iface *if_outgoing1,
- struct batadv_neigh_node *neigh2,
- struct batadv_hard_iface *if_outgoing2)
+batadv_iv_ogm_neigh_is_sob(struct batadv_neigh_node *candidate,
+ struct batadv_hard_iface *if_outgoing_cand,
+ struct batadv_neigh_node *reference,
+ struct batadv_hard_iface *if_outgoing_ref)
{
bool ret;
int diff;
- ret = batadv_iv_ogm_neigh_diff(neigh1, if_outgoing1, neigh2,
- if_outgoing2, &diff);
+ ret = batadv_iv_ogm_neigh_diff(candidate, if_outgoing_cand,
+ reference, if_outgoing_ref,
+ &diff);
if (!ret)
return false;
diff --git a/net/batman-adv/bat_v.c b/net/batman-adv/bat_v.c
index 0d0a226c3fd0c..596889b3522d0 100644
--- a/net/batman-adv/bat_v.c
+++ b/net/batman-adv/bat_v.c
@@ -514,40 +514,40 @@ static int batadv_v_neigh_cmp(struct batadv_neigh_node *neigh1,
/**
* batadv_v_neigh_is_sob() - check whether two B.A.T.M.A.N. V neighbours have
* a similar or better throughput
- * @neigh1: first neighbour to compare
- * @if_outgoing1: outgoing interface to use for @neigh1
- * @neigh2: second neighbour to compare
- * @if_outgoing2: outgoing interface to use for @neigh2
+ * @candidate: the first neighbor object of the comparison
+ * @if_outgoing_cand: outgoing interface for the @candidate neighbor
+ * @reference: the second neighbor object of the comparison
+ * @if_outgoing_ref: outgoing interface for the @reference neighbor
*
- * Return: true if the throughput of @neigh1 is more than 3/4 of the
- * @neigh2 throughput
+ * Return: true if the throughput of @candidate is more than 3/4 of the
+ * @reference throughput
*/
-static bool batadv_v_neigh_is_sob(struct batadv_neigh_node *neigh1,
- struct batadv_hard_iface *if_outgoing1,
- struct batadv_neigh_node *neigh2,
- struct batadv_hard_iface *if_outgoing2)
+static bool batadv_v_neigh_is_sob(struct batadv_neigh_node *candidate,
+ struct batadv_hard_iface *if_outgoing_cand,
+ struct batadv_neigh_node *reference,
+ struct batadv_hard_iface *if_outgoing_ref)
{
- struct batadv_neigh_ifinfo *ifinfo1;
- struct batadv_neigh_ifinfo *ifinfo2;
+ struct batadv_neigh_ifinfo *ifinfo_cand;
+ struct batadv_neigh_ifinfo *ifinfo_ref;
bool ret = false;
u32 threshold;
- ifinfo1 = batadv_neigh_ifinfo_get(neigh1, if_outgoing1);
- if (!ifinfo1)
+ ifinfo_cand = batadv_neigh_ifinfo_get(candidate, if_outgoing_cand);
+ if (!ifinfo_cand)
goto err_ifinfo1;
- ifinfo2 = batadv_neigh_ifinfo_get(neigh2, if_outgoing2);
- if (!ifinfo2)
+ ifinfo_ref = batadv_neigh_ifinfo_get(reference, if_outgoing_ref);
+ if (!ifinfo_ref)
goto err_ifinfo2;
- threshold = ifinfo2->bat_v.throughput / 4;
- threshold = ifinfo2->bat_v.throughput - threshold;
+ threshold = ifinfo_ref->bat_v.throughput / 4;
+ threshold = ifinfo_ref->bat_v.throughput - threshold;
- ret = ifinfo1->bat_v.throughput > threshold;
+ ret = ifinfo_cand->bat_v.throughput > threshold;
- batadv_neigh_ifinfo_put(ifinfo2);
+ batadv_neigh_ifinfo_put(ifinfo_ref);
err_ifinfo2:
- batadv_neigh_ifinfo_put(ifinfo1);
+ batadv_neigh_ifinfo_put(ifinfo_cand);
err_ifinfo1:
return ret;
}
diff --git a/net/batman-adv/types.h b/net/batman-adv/types.h
index 9bdc5a3e799e2..99667f632d4d9 100644
--- a/net/batman-adv/types.h
+++ b/net/batman-adv/types.h
@@ -2087,14 +2087,14 @@ struct batadv_algo_neigh_ops {
struct batadv_hard_iface *if_outgoing2);
/**
- * @is_similar_or_better: check if neigh1 is equally similar or better
- * than neigh2 for their respective outgoing interface from the metric
+ * @is_similar_or_better: check if @candidate is equally similar or better
+ * than @reference for their respective outgoing interface from the metric
* prospective
*/
- bool (*is_similar_or_better)(struct batadv_neigh_node *neigh1,
- struct batadv_hard_iface *if_outgoing1,
- struct batadv_neigh_node *neigh2,
- struct batadv_hard_iface *if_outgoing2);
+ bool (*is_similar_or_better)(struct batadv_neigh_node *candidate,
+ struct batadv_hard_iface *if_outgoing_cand,
+ struct batadv_neigh_node *reference,
+ struct batadv_hard_iface *if_outgoing_ref);
/** @dump: dump neighbors to a netlink socket (optional) */
void (*dump)(struct sk_buff *msg, struct netlink_callback *cb,
--
2.47.3
next prev parent reply other threads:[~2026-08-31 13:53 UTC|newest]
Thread overview: 27+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-31 13:51 [PATCH net-next 00/15] pull request for net-next: batman-adv 2026-08-31 Simon Wunderlich
2026-08-31 13:51 ` [PATCH net-next 01/15] batman-adv: dat: fix printing of unknown 4addr subtype Simon Wunderlich
2026-09-01 17:03 ` Sven Eckelmann
2026-08-31 13:51 ` [PATCH net-next 02/15] batman-adv: drop direction in _batadv_is_ap_isolated kernel-doc Simon Wunderlich
2026-08-31 13:51 ` [PATCH net-next 03/15] batman-adv: bat_v: fix bonding candidate selection Simon Wunderlich
2026-09-01 17:10 ` Sven Eckelmann
2026-08-31 13:51 ` [PATCH net-next 04/15] batman-adv: clarify cut-off in batadv_v_neigh_is_sob kernel-doc Simon Wunderlich
2026-08-31 13:51 ` Simon Wunderlich [this message]
2026-09-01 17:20 ` [PATCH net-next 05/15] batman-adv: use more descriptive var names for is_similar_or_better Sven Eckelmann
2026-08-31 13:51 ` [PATCH net-next 06/15] batman-adv: ensure u16 aligned mac address arrays on stack Simon Wunderlich
2026-08-31 13:51 ` [PATCH net-next 07/15] batman-adv: ensure u16 aligned mac address in structs Simon Wunderlich
2026-09-01 17:24 ` Sven Eckelmann
2026-08-31 13:51 ` [PATCH net-next 08/15] batman-adv: tt: remove only the entry which was looked up from the hash Simon Wunderlich
2026-09-01 18:11 ` Sven Eckelmann
2026-08-31 13:51 ` [PATCH net-next 09/15] batman-adv: tt: extract code handling a roam on add Simon Wunderlich
2026-09-01 18:14 ` Sven Eckelmann
2026-08-31 13:51 ` [PATCH net-next 10/15] batman-adv: tt: simplify NEW flag transition code Simon Wunderlich
2026-09-01 18:18 ` Sven Eckelmann
2026-08-31 13:51 ` [PATCH net-next 11/15] batman-adv: tt: drop unnecessary cleanup goto in helpers Simon Wunderlich
2026-08-31 13:51 ` [PATCH net-next 12/15] batman-adv: tt: use protected flag modifications Simon Wunderlich
2026-09-01 19:21 ` Sven Eckelmann
2026-08-31 13:51 ` [PATCH net-next 13/15] batman-adv: tt: transition NEW local entries only under lock Simon Wunderlich
2026-09-01 19:31 ` Sven Eckelmann
2026-08-31 13:51 ` [PATCH net-next 14/15] batman-adv: tt: don't uncount never committed clients on pending purge Simon Wunderlich
2026-09-01 19:33 ` Sven Eckelmann
2026-08-31 13:51 ` [PATCH net-next 15/15] batman-adv: tt: decrement count for committed client on local_remove Simon Wunderlich
2026-09-01 19:36 ` Sven Eckelmann
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260831135117.574836-6-sw@simonwunderlich.de \
--to=sw@simonwunderlich.de \
--cc=b.a.t.m.a.n@lists.open-mesh.org \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=horms@kernel.org \
--cc=kuba@kernel.org \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
--cc=sven@narfation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox