messages from 2026-07-30 19:19:36 to 2026-08-31 13:59:16 UTC [more...]
[PATCH net-next 00/15] pull request for net-next: batman-adv 2026-08-31
2026-08-31 13:51 UTC (15+ messages)
` [PATCH net-next 01/15] batman-adv: dat: fix printing of unknown 4addr subtype
` [PATCH net-next 02/15] batman-adv: drop direction in _batadv_is_ap_isolated kernel-doc
` [PATCH net-next 03/15] batman-adv: bat_v: fix bonding candidate selection
` [PATCH net-next 04/15] batman-adv: clarify cut-off in batadv_v_neigh_is_sob kernel-doc
` [PATCH net-next 05/15] batman-adv: use more descriptive var names for is_similar_or_better
` [PATCH net-next 06/15] batman-adv: ensure u16 aligned mac address arrays on stack
` [PATCH net-next 07/15] batman-adv: ensure u16 aligned mac address in structs
` [PATCH net-next 08/15] batman-adv: tt: remove only the entry which was looked up from the hash
` [PATCH net-next 10/15] batman-adv: tt: simplify NEW flag transition code
` [PATCH net-next 11/15] batman-adv: tt: drop unnecessary cleanup goto in helpers
` [PATCH net-next 12/15] batman-adv: tt: use protected flag modifications
` [PATCH net-next 13/15] batman-adv: tt: transition NEW local entries only under lock
` [PATCH net-next 14/15] batman-adv: tt: don't uncount never committed clients on pending purge
` [PATCH net-next 15/15] batman-adv: tt: decrement count for committed client on local_remove
[PATCH] batman-adv: tt: reject VLAN/TT entries before reaching size limit
2026-08-30 19:52 UTC
[PATCH batadv v6 00/20] batman-adv: tt: atomic sashiko fixes
2026-08-30 15:21 UTC (21+ messages)
` [PATCH batadv v6 01/20] batman-adv: tt: remove only the entry which was looked up from the hash
` [PATCH batadv v6 02/20] batman-adv: tt: extract code handling a roam on add
` [PATCH batadv v6 03/20] batman-adv: tt: simplify NEW flag transition code
` [PATCH batadv v6 04/20] batman-adv: tt: drop unnecessary cleanup goto in helpers
` [PATCH batadv v6 05/20] batman-adv: tt: use protected flag modifications
` [PATCH batadv v6 06/20] batman-adv: tt: transition NEW local entries only under lock
` [PATCH batadv v6 07/20] batman-adv: tt: don't uncount never committed clients on pending purge
` [PATCH batadv v6 08/20] batman-adv: tt: decrement count for committed client on local_remove
` [PATCH batadv v6 09/20] batman-adv: tt: look up wifi state of incoming interface in helper
` [PATCH batadv v6 10/20] batman-adv: tt: extract allocation of new local entries
` [PATCH batadv v6 11/20] batman-adv: tt: replace forward gotos in batadv_tt_local_add()
` [PATCH batadv v6 12/20] batman-adv: tt: extract refresh of existing local entries
` [PATCH batadv v6 13/20] batman-adv: tt: extract update of dynamic client flags
` [PATCH batadv v6 14/20] batman-adv: tt: extract allocation of new global entries
` [PATCH batadv v6 15/20] batman-adv: tt: extract merging of flags into existing "
` [PATCH batadv v6 16/20] batman-adv: tt: replace add_orig_entry goto in batadv_tt_global_add()
` [PATCH batadv v6 17/20] batman-adv: tt: extract removal of the superseded local entry
` [PATCH batadv v6 18/20] batman-adv: tt: extract marking of a removed "
` [PATCH batadv v6 19/20] batman-adv: tt: extract immediate purge of a "
` [PATCH batadv v6 20/20] batman-adv: tt: drop the cleanup label from batadv_tt_local_remove()
[PATCH batadv v5 00/20] batman-adv: tt: atomic sashiko fixes
2026-08-29 6:18 UTC (21+ messages)
` [PATCH batadv v5 01/20] batman-adv: tt: remove only the entry which was looked up from the hash
` [PATCH batadv v5 02/20] batman-adv: tt: extract code handling a roam on add
` [PATCH batadv v5 03/20] batman-adv: tt: simplify NEW flag transition code
` [PATCH batadv v5 04/20] batman-adv: tt: drop unnecessary cleanup goto in helpers
` [PATCH batadv v5 05/20] batman-adv: tt: use protected flag modifications
` [PATCH batadv v5 06/20] batman-adv: tt: transition NEW local entries only under lock
` [PATCH batadv v5 07/20] batman-adv: tt: don't uncount never committed clients on pending purge
` [PATCH batadv v5 08/20] batman-adv: tt: decrement count for committed client on local_remove
` [PATCH batadv v5 09/20] batman-adv: tt: look up wifi state of incoming interface in helper
` [PATCH batadv v5 10/20] batman-adv: tt: extract allocation of new local entries
` [PATCH batadv v5 11/20] batman-adv: tt: replace forward gotos in batadv_tt_local_add()
` [PATCH batadv v5 12/20] batman-adv: tt: extract refresh of existing local entries
` [PATCH batadv v5 13/20] batman-adv: tt: extract update of dynamic client flags
` [PATCH batadv v5 14/20] batman-adv: tt: extract allocation of new global entries
` [PATCH batadv v5 15/20] batman-adv: tt: extract merging of flags into existing "
` [PATCH batadv v5 16/20] batman-adv: tt: replace add_orig_entry goto in batadv_tt_global_add()
` [PATCH batadv v5 17/20] batman-adv: tt: extract removal of the superseded local entry
` [PATCH batadv v5 18/20] batman-adv: tt: extract marking of a removed "
` [PATCH batadv v5 19/20] batman-adv: tt: extract immediate purge of a "
` [PATCH batadv v5 20/20] batman-adv: tt: drop the cleanup label from batadv_tt_local_remove()
[PATCH net 0/9] pull request: batman-adv 2026-08-21
2026-08-22 20:00 UTC (17+ messages)
` [PATCH net 1/9] batman-adv: fix stale receive device on merged fragments
` [PATCH net 2/9] batman-adv: bla: avoid CRC corruption due to parallel claim add
` [PATCH net 3/9] batman-adv: bla: prevent CRC corruptions after claim flush
` [PATCH net 4/9] batman-adv: dat: avoid unaligned fault in IP extraction
` [PATCH net 5/9] batman-adv: dat: atomically update mac addresses
` [PATCH net 6/9] batman-adv: fix TX priority extraction for BATADV_FORW_MCAST
` [PATCH net 7/9] batman-adv: mcast: ensure unshared skb for multicast packets
` [PATCH net 8/9] batman-adv: mcast: linearize skbuff for packet generation
` [PATCH net 9/9] batman-adv: bla: fix freeing of claims on meshif deletion
[PATCH batadv 0/2] batman-adv: enforce u16 MAC address alignment
2026-08-22 13:14 UTC (3+ messages)
` [PATCH batadv 1/2] batman-adv: ensure u16 aligned mac address arrays on stack
` [PATCH batadv 2/2] batman-adv: ensure u16 aligned mac address in structs
[PATCH net v3] batman-adv: reject unrepresentable multicast TVLV offsets
2026-08-20 20:30 UTC (4+ messages)
[PATCH net-next 00/10] pull request for net-next: batman-adv 2026-08-05
2026-08-13 2:00 UTC (18+ messages)
` [PATCH net-next 01/10] batman-adv: dat: drop non-4addr backwards compatibility
` [PATCH net-next 02/10] batman-adv: tvlv: handle negative tvlv processing return codes
` [PATCH net-next 03/10] batman-adv: add missing kernel-doc comments
` [PATCH net-next 04/10] batman-adv: fix kernel-doc for functions holding skb ownership
` [PATCH net-next 05/10] batman-adv: annotate functions which may reallocate the skbuff
` [PATCH net-next 06/10] batman-adv: split multiple declarations per line
` [PATCH net-next 07/10] batman-adv: switch var declarations to reverse x-mas tree order
` [PATCH net-next 08/10] batman-adv: handle errors in batadv_init()
` [PATCH net-next 09/10] batman-adv: correct NET_RX_* NET_XMIT_* confusion
` [PATCH net-next 10/10] batman-adv: remove negative returns for batadv_send_skb_unicast
[PATCH net v2] batman-adv: reject unrepresentable multicast TVLV offsets
2026-08-11 21:56 UTC (3+ messages)
[PATCH batadv] batman-adv: compat: drop support for Linux < 5.15
2026-08-08 18:05 UTC
[PATCH batadv 0/3] batman-adv: bat_v: fix bonding candidate selection
2026-08-06 18:54 UTC (4+ messages)
` [PATCH batadv 1/3] "
` [PATCH batadv 2/3] batman-adv: clarify cut-off in batadv_v_neigh_is_sob kernel-doc
` [PATCH batadv 3/3] batman-adv: use more descriptive var names for is_similar_or_better
[PATCH batadv] batman-adv: drop direction in _batadv_is_ap_isolated kernel-doc
2026-08-06 16:33 UTC
[PATCH batadv v2] batman-adv: dat: fix printing of unknown 4addr subtype
2026-08-06 15:15 UTC
[PATCH batadv] batman-adv: dat: fix printing of unknown 4addr subtype
2026-08-06 15:06 UTC (2+ messages)
[PATCH net-next 00/15] pull request for net-next: batman-adv 2026-07-28
2026-08-06 14:49 UTC (11+ messages)
[PATCH RFC batadv 00/12] batman-adv: tt: refactor *_add/batadv_tt_local_remove functions
2026-08-06 9:44 UTC (13+ messages)
` [PATCH RFC batadv 01/12] batman-adv: tt: look up wifi state of incoming interface in helper
` [PATCH RFC batadv 02/12] batman-adv: tt: extract allocation of new local entries
` [PATCH RFC batadv 03/12] batman-adv: tt: replace forward gotos in batadv_tt_local_add()
` [PATCH RFC batadv 04/12] batman-adv: tt: extract refresh of existing local entries
` [PATCH RFC batadv 05/12] batman-adv: tt: extract update of dynamic client flags
` [PATCH RFC batadv 06/12] batman-adv: tt: extract allocation of new global entries
` [PATCH RFC batadv 07/12] batman-adv: tt: extract merging of flags into existing "
` [PATCH RFC batadv 08/12] batman-adv: tt: replace add_orig_entry goto in batadv_tt_global_add()
` [PATCH RFC batadv 09/12] batman-adv: tt: extract removal of the superseded local entry
` [PATCH RFC batadv 10/12] batman-adv: tt: extract marking of a removed "
` [PATCH RFC batadv 11/12] batman-adv: tt: extract immediate purge of a "
` [PATCH RFC batadv 12/12] batman-adv: tt: drop the cleanup label from batadv_tt_local_remove()
[PATCH RFC batadv v4 0/8] batman-adv: tt: atomic sashiko fixes
2026-08-06 7:41 UTC (9+ messages)
` [PATCH RFC batadv v4 1/8] batman-adv: tt: remove only the entry which was looked up from the hash
` [PATCH RFC batadv v4 2/8] batman-adv: tt: extract code handling a roam on add
` [PATCH RFC batadv v4 3/8] batman-adv: tt: simplify NEW flag transition code
` [PATCH RFC batadv v4 4/8] batman-adv: tt: drop unnecessary cleanup goto in helpers
` [PATCH RFC batadv v4 5/8] batman-adv: tt: use protected flag modifications
` [PATCH RFC batadv v4 6/8] batman-adv: tt: transition NEW local entries only under lock
` [PATCH RFC batadv v4 7/8] batman-adv: tt: don't uncount never committed clients on pending purge
` [PATCH RFC batadv v4 8/8] batman-adv: tt: decrement count for committed client on local_remove
[PATCH RFC batadv v3 0/6] batman-adv: tt: atomic sashiko fixes
2026-08-05 18:46 UTC (8+ messages)
` [PATCH RFC batadv v3 1/6] batman-adv: tt: remove only the entry which was looked up from the hash
` [PATCH RFC batadv v3 2/6] batman-adv: tt: extract code handling a roam on add
` [PATCH RFC batadv v3 3/6] batman-adv: tt: simplify NEW flag transition code
` [PATCH RFC batadv v3 4/6] batman-adv: tt: use atomic flag modifications
` [PATCH RFC batadv v3 5/6] batman-adv: tt: decrement count for committed client on local_remove
` [PATCH RFC batadv v3 6/6] batman-adv: tt: don't uncount never committed clients on pending purge
[PATCH batadv 0/2] batman-adv: compat add support for scoped_guard
2026-08-05 15:06 UTC (3+ messages)
` [PATCH batadv 1/2] batman-adv: compat: drop support for pre-C11 kernels
` [PATCH batadv 2/2] batman-adv: compat: add scoped_guard(spinlock_bh, ...) support
[PATCH batadv v3] batman-adv: handle errors in batadv_init()
2026-08-05 7:11 UTC (3+ messages)
[PATCH batadv v2 0/6] batman-adv: tt: atomic_t sashiko fixes
2026-08-04 10:18 UTC (7+ messages)
` [PATCH batadv v2 1/6] batman-adv: tt: remove only the entry which was looked up from the hash
` [PATCH batadv v2 2/6] batman-adv: tt: extract code handling a roam on add
` [PATCH batadv v2 3/6] batman-adv: tt: simplify NEW flag transition code
` [PATCH batadv v2 4/6] batman-adv: tt: use atomic flag modifications
` [PATCH batadv v2 5/6] batman-adv: tt: decrement count for committed client on local_remove
` [PATCH batadv v2 6/6] batman-adv: tt: don't uncount never committed clients on pending purge
[PATCH] batman-adv: reject unrepresentable multicast TVLV offsets
2026-08-01 9:55 UTC (6+ messages)
` [PATCH] batman-adv: reject unrepresentable multicast TVLV offsets (+ b4 check signed-off-problems)
[PATCH 0/6] alfred: interfaces: random fixes
2026-07-31 11:44 UTC (7+ messages)
` [PATCH 1/6] alfred: fix off-by-one in client interface name length checks
` [PATCH 2/6] alfred: update stored interface list on interface change
` [PATCH 3/6] alfred: don't drop the mesh interface name on OOM
` [PATCH 4/6] alfred: keep the running interfaces when reconfiguration fails
` [PATCH 5/6] alfred: Report failure when the client refuses to change interfaces
` [PATCH 6/6] alfred: don't check the "none" on network interface change
[PATCH 0/4] alfred: client: random fixes
2026-07-31 7:40 UTC (5+ messages)
` [PATCH 1/4] alfred: fix error code from unix_sock_req_data_reply
` [PATCH 2/4] alfred: avoid endless-loop when reading data from stdin fails
` [PATCH 3/4] alfred: close the listening socket on daemon setup errors
` [PATCH 4/4] alfred: handle short reads when waiting for daemon answer
[PATCH 0/3] alfred: leaks: random fixes
2026-07-31 6:44 UTC (4+ messages)
` [PATCH 1/3] alfred: don't leak event listener when epoll registration fails
` [PATCH 2/3] alfred: dlose the client socket on unix_sock_req_data errors
` [PATCH 3/3] alfred: Close the periodic timer fd on setup errors
[PATCH v2 0/1] batman-adv: fix stale receive device on merged fragments
2026-07-31 5:45 UTC (3+ messages)
` [PATCH v2 1/1] "
[PATCH 0/6] alfred: argument-parsing: random fixes
2026-07-30 19:32 UTC (7+ messages)
` [PATCH 1/6] alfred: keep interface names always in heap
` [PATCH 2/6] alfred: free interface parameters before assigning new
` [PATCH 3/6] alfred: check strdup() failures during option parsing
` [PATCH 4/6] alfred: reject invalid synchronization periods
` [PATCH 5/6] alfred: reject too long unix socket paths
` [PATCH 6/6] alfred: validate the IPv4 multicast group argument
[PATCH 0/2] alfred: notifications: random fixes
2026-07-30 19:18 UTC (3+ messages)
` [PATCH 1/2] alfred: Use _exit() in the update command child process
` [PATCH 2/2] alfred: Announce changed data only after it was stored
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox