BPF List
 help / color / mirror / Atom feed
From: sashiko-bot@kernel.org
To: "Amery Hung" <ameryhung@gmail.com>
Cc: bpf@vger.kernel.org
Subject: Re: [PATCH bpf-next v1 06/18] selftests/bpf: Add tests for helper and kfunc mem+size arguments
Date: Thu, 23 Jul 2026 05:42:13 +0000	[thread overview]
Message-ID: <20260723054216.001381F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260723050806.1158442-7-ameryhung@gmail.com>

Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Medium] The selftest `mapofmaps_value_as_kfunc_mem_buf` uses an out-of-bounds buffer size (8 instead of 4), and both tests lack explicit `__msg(...)` assertions. This causes the test to pass (fail verification) for the wrong reason, rendering it ineffective as a regression guard.
--

--- Patch [6]: [PATCH bpf-next v1 06/18] selftests/bpf: Add tests for helper and kfunc mem+size arguments ---
commit 967fe45d86aee49807b5742ffece3f858b20a4fd
Author: Amery Hung <ameryhung@gmail.com>

selftests/bpf: Add tests for helper and kfunc mem+size arguments

Make sure the return of map-of-maps lookup cannot be passed to nullable
memory buffer argument for helper and kfunc.

> diff --git a/tools/testing/selftests/bpf/progs/verifier_mem_size_reg.c b/tools/testing/selftests/bpf/progs/verifier_mem_size_reg.c
> new file mode 100644
> index 0000000000000..78a9ad22b10df
> --- /dev/null
> +++ b/tools/testing/selftests/bpf/progs/verifier_mem_size_reg.c
[ ... ]
> +/* An un-narrowed map-of-maps value must be rejected as a __nullable kfunc mem buffer */
> +SEC("?tc")
> +__failure
> +int mapofmaps_value_as_kfunc_mem_buf(struct __sk_buff *skb)
> +{
> +	struct bpf_dynptr dptr;
> +	__u32 key = 0;
> +	void *inner;
> +	char *p;
> +
> +	inner = bpf_map_lookup_elem(&outer_map, &key);
> +	/* intentionally NOT NULL-checked: reg stays PTR_TO_MAP_VALUE_OR_NULL */
> +
> +	bpf_dynptr_from_skb(skb, 0, &dptr);
> +	/* pass the un-narrowed map-of-maps value as the scratch buffer */
> +	p = bpf_dynptr_slice(&dptr, 0, inner, 8);

[Severity: Medium]
Does using a size of 8 here exceed the outer map's value size of 4?

If the intended type check is missing, the verifier will still reject the
program due to a bounds check failure (size 8 > 4). Since the test uses
__failure without __msg(...), this unrelated bounds-check failure satisfies
the test expectation and causes it to pass for the wrong reason.

> +	if (p)
> +		return p[0];
> +	return 0;
> +}
> +
> +/* An un-narrowed map-of-maps value must be rejected as a PTR_MAYBE_NULL helper mem buffer */
> +SEC("?tc")
> +__failure

[Severity: Medium]
Similar to the above, would it be better to include a __msg(...) assertion
here?

Without an explicit message check, this test could pass due to unrelated
verifier errors.

> +int mapofmaps_value_as_helper_mem_buf(struct __sk_buff *skb)
> +{
> +	__u32 key = 0;
> +	void *inner;

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/20260723050806.1158442-1-ameryhung@gmail.com?part=6

  reply	other threads:[~2026-07-23  5:42 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-23  5:07 [PATCH bpf-next v1 00/18] Generate bpf_func_proto for kfunc Amery Hung
2026-07-23  5:07 ` [PATCH bpf-next v1 01/18] bpf: Drop process_timer_func wrappers Amery Hung
2026-07-23  5:07 ` [PATCH bpf-next v1 02/18] bpf: Unify const map ptr argument checking for helpers and kfuncs Amery Hung
2026-07-23  5:25   ` sashiko-bot
2026-07-23 16:19     ` Amery Hung
2026-07-23  5:07 ` [PATCH bpf-next v1 03/18] bpf: Split kfunc map argument into __const_map and __map Amery Hung
2026-07-23  5:35   ` sashiko-bot
2026-07-23 16:52     ` Amery Hung
2026-07-23  5:07 ` [PATCH bpf-next v1 04/18] bpf: Pass kfunc meta to mem and mem_size check Amery Hung
2026-07-23  5:07 ` [PATCH bpf-next v1 05/18] bpf: Check helper and kfunc mem+size arguments identically Amery Hung
2026-07-23  5:52   ` sashiko-bot
2026-07-23  5:07 ` [PATCH bpf-next v1 06/18] selftests/bpf: Add tests for helper and kfunc mem+size arguments Amery Hung
2026-07-23  5:42   ` sashiko-bot [this message]
2026-07-23  5:07 ` [PATCH bpf-next v1 07/18] bpf: Check fixed-size mem args of helpers and kfuncs the same way Amery Hung
2026-07-23  5:57   ` sashiko-bot
2026-07-23  5:07 ` [PATCH bpf-next v1 08/18] bpf: Express ARG_CONST_SIZE_OR_ZERO as ARG_CONST_SIZE | SCALAR_MAYBE_ZERO Amery Hung
2026-07-23  5:07 ` [PATCH bpf-next v1 09/18] bpf: Rename ARG_CONST_SIZE{,_OR_ZERO} to ARG_MEM_SIZE{,_OR_ZERO} Amery Hung
2026-07-23  5:07 ` [PATCH bpf-next v1 10/18] bpf: Fold __szk const size handling into the scalar arg path Amery Hung
2026-07-23  5:07 ` [PATCH bpf-next v1 11/18] bpf: Classify kfunc mem_size args from BTF without register state Amery Hung
2026-07-23  5:08 ` [PATCH bpf-next v1 12/18] bpf: Handle NULL kfunc pointer args without a KF_ARG_PTR_TO_NULL type Amery Hung
2026-07-23  5:08 ` [PATCH bpf-next v1 13/18] bpf: Distinguish fixed- and variable-size kfunc mem args with MEM_FIXED_SIZE Amery Hung
2026-07-23  5:08 ` [PATCH bpf-next v1 14/18] bpf: Check helper mem+size in ARG_PTR_TO_MEM case Amery Hung
2026-07-23  5:08 ` [PATCH bpf-next v1 15/18] bpf: Classify kfunc pointer arguments from BTF, resolve type against the register Amery Hung
2026-07-23  7:27   ` sashiko-bot
2026-07-23  5:08 ` [PATCH bpf-next v1 16/18] bpf: Tag nullable kfunc pointer args with PTR_MAYBE_NULL Amery Hung
2026-07-23  5:08 ` [PATCH bpf-next v1 17/18] bpf: Classify scalar kfunc arguments from BTF Amery Hung
2026-07-23  8:01   ` sashiko-bot
2026-07-23  5:08 ` [PATCH bpf-next v1 18/18] bpf: Generate kfunc argument prototype at add-call time Amery Hung

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260723054216.001381F000E9@smtp.kernel.org \
    --to=sashiko-bot@kernel.org \
    --cc=ameryhung@gmail.com \
    --cc=bpf@vger.kernel.org \
    --cc=sashiko-reviews@lists.linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox