messages from 2025-05-09 20:17:46 to 2025-05-13 16:06:09 UTC [more...]
[PATCH bpf-next] docs: bpf: fix bullet point formatting warning
2025-05-13 16:05 UTC (2+ messages)
[PATCH iwl-next 00/16] libeth: add libeth_xdp helper lib
2025-05-13 14:58 UTC (4+ messages)
` [PATCH iwl-next 03/16] libeth: xdp: add XDP_TX buffers sending
[PATCH bpf-next v4 0/4] bpf: Add kfuncs for read-only string operations
2025-05-13 14:58 UTC (16+ messages)
` [PATCH bpf-next v4 1/4] bpf: Teach vefier to handle const ptrs as args to kfuncs
` [PATCH bpf-next v4 2/4] uaccess: Define pagefault lock guard
` [PATCH bpf-next v4 3/4] bpf: Add kfuncs for read-only string operations
[PATCH bpf-next 1/2] bpf: Warn with new bpf_unreachable() kfunc maybe due to uninitialized var
2025-05-13 14:54 UTC (5+ messages)
` [PATCH bpf-next 2/2] selftests/bpf: Add a test with bpf_unreachable() kfunc
[PATCH bpf-next v3] bpf: Add __prog tag to pass in prog->aux
2025-05-13 14:28 UTC
[PATCH] HID: bpf: abort dispatch if device destroyed
2025-05-13 14:01 UTC (3+ messages)
[PATCH v6 net-next 00/15] AccECN protocol patch series
2025-05-13 13:55 UTC (17+ messages)
` [PATCH v6 net-next 01/15] tcp: reorganize SYN ECN code
` [PATCH v6 net-next 02/15] tcp: fast path functions later
` [PATCH v6 net-next 03/15] tcp: reorganize tcp_sock_write_txrx group for variables later
` [PATCH v6 net-next 04/15] tcp: AccECN core
` [PATCH v6 net-next 05/15] tcp: accecn: AccECN negotiation
` [PATCH v6 net-next 06/15] tcp: accecn: add AccECN rx byte counters
` [PATCH v6 net-next 07/15] tcp: accecn: AccECN needs to know delivered bytes
` [PATCH v6 net-next 08/15] tcp: sack option handling improvements
` [PATCH v6 net-next 09/15] tcp: accecn: AccECN option
` [PATCH v6 net-next 10/15] tcp: accecn: AccECN option send control
` [PATCH v6 net-next 11/15] tcp: accecn: AccECN option failure handling
` [PATCH v6 net-next 12/15] tcp: accecn: AccECN option ceb/cep heuristic
` [PATCH v6 net-next 13/15] tcp: accecn: AccECN ACE field multi-wrap heuristic
` [PATCH v6 net-next 14/15] tcp: accecn: try to fit AccECN option with SACK
` [PATCH v6 net-next 15/15] tcp: try to avoid safer when ACKs are thinned
[RFC PATCH 0/7] memcg: make memcg stats irq safe
2025-05-13 13:10 UTC (15+ messages)
` [RFC PATCH 1/7] memcg: memcg_rstat_updated re-entrant safe against irqs
` [RFC PATCH 2/7] memcg: move preempt disable to callers of memcg_rstat_updated
` [RFC PATCH 3/7] memcg: make mod_memcg_state re-entrant safe against irqs
` [RFC PATCH 4/7] memcg: make count_memcg_events "
` [RFC PATCH 5/7] memcg: make __mod_memcg_lruvec_state "
` [RFC PATCH 6/7] memcg: objcg stock trylock without irq disabling
` [RFC PATCH 7/7] memcg: no stock lock for cpu hot-unplug
[PATCH 0/4] memcg: nmi-safe kmem charging
2025-05-13 11:41 UTC (13+ messages)
` [PATCH 1/4] memcg: add infra for nmi safe memcg stats
` [PATCH 2/4] memcg: add nmi-safe update for MEMCG_KMEM
` [PATCH 3/4] memcg: nmi-safe slab stats updates
` [PATCH 4/4] memcg: make objcg charging nmi safe
[PATCH bpf-next v5 0/3] Introduce kfuncs for memory reads into dynptrs
2025-05-13 11:13 UTC (8+ messages)
` [PATCH bpf-next v5 1/3] helpers: make few bpf helpers public
` [PATCH bpf-next v5 2/3] bpf: implement dynptr copy kfuncs
` [PATCH bpf-next v5 3/3] selftests/bpf: introduce tests for "
[PATCH net-next V2] net: track pfmemalloc drops via SKB_DROP_REASON_PFMEMALLOC
2025-05-13 11:04 UTC (2+ messages)
[PATCH bpf-next v2] bpf: Add __prog tag to pass in prog->aux
2025-05-13 8:49 UTC (2+ messages)
[syzbot] [bpf?] KASAN: vmalloc-out-of-bounds Write in vrealloc_noprof (2)
2025-05-13 8:13 UTC (3+ messages)
[PATCH 0/6] mm: Reentrant kmalloc
2025-05-13 6:58 UTC (12+ messages)
` [PATCH 2/6] locking/local_lock: Expose dep_map in local_trylock_t
` [PATCH 3/6] locking/local_lock: Introduce local_lock_is_locked()
` [PATCH 4/6] locking/local_lock: Introduce local_lock_irqsave_check()
[PATCH net-next,v3] net: mana: Add handler for hardware servicing events
2025-05-13 6:27 UTC (2+ messages)
[PATCH bpf-next 1/2] bpf: Do not include r10 in precision backtracking bookkeeping
2025-05-13 5:20 UTC (7+ messages)
` [PATCH bpf-next 2/2] selftests/bpf: Add a test with r10 in conditional jmp
[RFC bpf-next 0/4] bpf: Fast-Path approach for BPF program Termination
2025-05-13 5:16 UTC (8+ messages)
` [RFC bpf-next 1/4] bpf: Introduce new structs and struct fields
` [RFC bpf-next 3/4] bpf: Generating a stubbed version of BPF program for termination
[PATCH bpf-next] bpf: Fix WARN() in get_bpf_raw_tp_regs
2025-05-13 4:27 UTC
[PATCH bpf-next v1] bpftool: Add support for custom BTF path in prog load/loadall
2025-05-13 3:58 UTC
[PATCH] bpf: Fix bpf_prog nested call in trace_mmap_lock_acquire_returned
2025-05-13 2:46 UTC (3+ messages)
[PATCH bpf-next v1] bpf: Add __aux tag to pass in prog->aux
2025-05-13 1:52 UTC (6+ messages)
[RESEND PATCH] selftests/bpf: Fix bpf selftest build warning
2025-05-13 0:08 UTC (3+ messages)
[PATCH v1 bpf-next] libbpf: Use proper errno value in nlattr
2025-05-12 22:50 UTC (3+ messages)
[PATCH bpf-next v4 0/3] Allow mmap of /sys/kernel/btf/vmlinux
2025-05-12 22:33 UTC (5+ messages)
` [PATCH bpf-next v4 1/3] btf: allow mmap of vmlinux btf
` [PATCH bpf-next v4 2/3] selftests: bpf: add a test for mmapable vmlinux BTF
` [PATCH bpf-next v4 3/3] libbpf: Use mmap to parse vmlinux BTF from sysfs
[PATCH v4] tracepoint: Have tracepoints created with DECLARE_TRACE() have _tp suffix
2025-05-12 22:29 UTC (2+ messages)
[PATCH v8 00/18] unwind_user: perf: x86: Deferred unwinding infrastructure
2025-05-12 22:27 UTC (10+ messages)
` [PATCH v8 12/18] unwind deferred: Use SRCU unwind_deferred_task_work()
` [PATCH v8 15/18] perf: Have get_perf_callchain() return NULL if crosstask and user are set
[PATCH bpf-next] selftests/bpf: allow skipping docs compilation
2025-05-12 22:20 UTC (2+ messages)
[PATCH bpf-next 0/2] s390/bpf: Remove the orig_call NULL check
2025-05-12 20:57 UTC (3+ messages)
` [PATCH bpf-next 1/2] bpf: Pass the same orig_call value to trampoline functions
` [PATCH bpf-next 2/2] s390/bpf: Remove the orig_call NULL check
[PATCH bpf-next v1 00/11] BPF Standard Streams
2025-05-12 22:07 UTC (28+ messages)
` [PATCH bpf-next v1 01/11] bpf: Introduce bpf_dynptr_from_mem_slice
` [PATCH bpf-next v1 03/11] bpf: Add function to extract program source info
` [PATCH bpf-next v1 08/11] bpf: Report arena faults to BPF stderr
` [PATCH bpf-next v1 09/11] libbpf: Add bpf_stream_printk() macro
` [PATCH bpf-next v1 10/11] bpftool: Add support for dumping streams
[PATCH bpf-next v5 0/5] Replace CONFIG_DMABUF_SYSFS_STATS with BPF
2025-05-12 21:04 UTC (10+ messages)
` [PATCH bpf-next v5 1/5] dma-buf: Rename debugfs symbols
` [PATCH bpf-next v5 2/5] bpf: Add dmabuf iterator
` [PATCH bpf-next v5 3/5] bpf: Add open coded "
` [PATCH bpf-next v5 4/5] selftests/bpf: Add test for dmabuf_iter
` [PATCH bpf-next v5 5/5] selftests/bpf: Add test for open coded dmabuf_iter
[PATCH bpf-next] selftests/bpf: Fix "expression result unused" warnings
2025-05-12 19:29 UTC (7+ messages)
[PATCH bpf-next 0/2] Fix verifier test failures in verbose mode
2025-05-12 17:50 UTC (5+ messages)
` [PATCH bpf-next 1/2] selftests/bpf: test_verifier verbose causes erroneous failures
` [PATCH bpf-next 2/2] selftests/bpf: test_verifier verbose log overflows
[PATCH bpf-next 0/4] bpf: Allow get_func_[arg|arg_cnt] helpers in raw tracepoint programs
2025-05-12 16:01 UTC (11+ messages)
` [PATCH bpf-next 1/4] "
[PATCH net-next,v2] net: mana: Add handler for hardware servicing events
2025-05-12 15:00 UTC (3+ messages)
` [EXTERNAL] "
[PATCH perf/core 00/22] uprobes: Add support to optimize usdt probes on x86_64
2025-05-12 13:37 UTC (8+ messages)
` [PATCH perf/core 03/22] uprobes: Move ref_ctr_offset update out of uprobe_write_opcode
[syzbot] [bpf?] [trace?] WARNING in get_bpf_raw_tp_regs
2025-05-12 13:13 UTC (2+ messages)
[PATCH bpf-next] s390/bpf: Store backchain even for leaf progs
2025-05-12 12:26 UTC
[PATCH 0/2] Add option for generating BTF types of global variables
2025-05-12 11:15 UTC (5+ messages)
` [PATCH 2/2] btf: Add the option to include global variable types
[RFC bpf-next 0/3] bpf: handle 0-sized structs properly
2025-05-12 9:17 UTC (3+ messages)
[RESEND PATCH] selftests/bpf: Fix bpf selftest build error
2025-05-12 9:11 UTC
linux-next: build warning after merge of the bpf-next tree
2025-05-12 8:49 UTC
[PATCH dwarves v1] dwarf_loader: Fix skipped encoding of function BTF on 32-bit systems
2025-05-12 8:41 UTC (6+ messages)
` [PATCH dwarves v2] "
[PATCH] selftests/bpf: Fix bpf selftest build error
2025-05-12 6:40 UTC (6+ messages)
[PATCH 6.1.y] bpf: support deferring bpf_link dealloc to after RCU grace period
2025-05-12 3:18 UTC
[PATCH v3 0/4] Introducing Hornet LSM
2025-05-11 2:14 UTC (12+ messages)
[PATCH v1 bpf] libbpf: use proper errno value in linker
2025-05-10 18:28 UTC (3+ messages)
[PATCH] net: fix unix socket bpf implementation: ensure reliable wake-up signaling
2025-05-10 14:40 UTC (2+ messages)
[PATCH v3] tracepoint: Have tracepoints created with DECLARE_TRACE() have _tp suffix
2025-05-10 13:23 UTC
[PATCH bpf-next v3 0/3] Allow mmap of /sys/kernel/btf/vmlinux
2025-05-10 12:36 UTC (4+ messages)
[PATCH v2 bpf-next] bpf, docs: document open-coded BPF iterators
2025-05-10 6:00 UTC (2+ messages)
[PATCH net-next v5 0/3] Refactoring designware VLAN code
2025-05-10 0:40 UTC (2+ messages)
[PATCH bpf-next v5 00/17] bpf: Support new insns from cpu v4
2025-05-10 0:01 UTC (9+ messages)
` [PATCH bpf-next v5 07/17] bpf: Support new 32bit offset jmp instruction
[PATCH bpf-next v4 0/5] Replace CONFIG_DMABUF_SYSFS_STATS with BPF
2025-05-09 22:27 UTC (6+ messages)
` [PATCH bpf-next v4 5/5] selftests/bpf: Add test for open coded dmabuf_iter
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox