BPF List
 help / color / mirror / Atom feed
 messages from 2025-07-01 01:12:27 to 2025-07-02 14:58:38 UTC [more...]

[PATCH bpf-next V2 0/7] xdp: Allow BPF to set RX hints for XDP_REDIRECTed packets
 2025-07-02 14:58 UTC  (4+ messages)
` [PATCH bpf-next V2 1/7] net: xdp: Add xdp_rx_meta structure
` [PATCH bpf-next V2 2/7] selftests/bpf: Adjust test for maximum packet size in xdp_do_redirect
` [PATCH bpf-next V2 3/7] net: xdp: Add kfuncs to store hw metadata in xdp_buff

[PATCH v12 00/14] unwind_user: x86: Deferred unwinding infrastructure
 2025-07-02 14:56 UTC  (13+ messages)
` [PATCH v12 02/14] unwind_user: Add frame pointer support

[PATCH bpf-next v4 00/12] BPF Standard Streams
 2025-07-02 14:43 UTC  (14+ messages)
` [PATCH bpf-next v4 01/12] bpf: Refactor bprintf buffer support
` [PATCH bpf-next v4 02/12] bpf: Introduce BPF standard streams
` [PATCH bpf-next v4 03/12] bpf: Add function to extract program source info
` [PATCH bpf-next v4 04/12] bpf: Ensure RCU lock is held around bpf_prog_ksym_find
` [PATCH bpf-next v4 05/12] bpf: Add function to find program from stack trace
` [PATCH bpf-next v4 06/12] bpf: Add dump_stack() analogue to print to BPF stderr
` [PATCH bpf-next v4 07/12] bpf: Report may_goto timeout "
` [PATCH bpf-next v4 08/12] bpf: Report rqspinlock deadlocks/timeout "
` [PATCH bpf-next v4 09/12] libbpf: Add bpf_stream_printk() macro
` [PATCH bpf-next v4 10/12] libbpf: Introduce bpf_prog_stream_read() API
` [PATCH bpf-next v4 11/12] bpftool: Add support for dumping streams
` [PATCH bpf-next v4 12/12] selftests/bpf: Add tests for prog streams

[PATCH bpf-next] selftests/bpf: allow veristat compile standalone
 2025-07-02 14:26 UTC 

[PATCH] bpf: turn off sanitizer in do_misc_fixups for old clang
 2025-07-02 14:14 UTC  (7+ messages)

[PATCH net-next V4] net: track pfmemalloc drops via SKB_DROP_REASON_PFMEMALLOC
 2025-07-02 13:59 UTC 

[PATCH bpf-next 1/2] selftests/bpf: Negative test case for ref_obj_id in args
 2025-07-02 13:54 UTC  (2+ messages)
` [PATCH bpf-next 2/2] bpf: Avoid warning on multiple referenced args in call

[PATCH v7 00/12] unwind_deferred: Implement sframe handling
 2025-07-02 12:57 UTC  (14+ messages)
` [PATCH v7 01/12] unwind_user/sframe: Add support for reading .sframe headers
` [PATCH v7 02/12] unwind_user/sframe: Store sframe section data in per-mm maple tree
` [PATCH v7 03/12] x86/uaccess: Add unsafe_copy_from_user() implementation
` [PATCH v7 04/12] unwind_user/sframe: Add support for reading .sframe contents
` [PATCH v7 05/12] unwind_user/sframe: Detect .sframe sections in executables
` [PATCH v7 06/12] unwind_user/sframe: Wire up unwind_user to sframe
` [PATCH v7 07/12] unwind_user/sframe/x86: Enable sframe unwinding on x86
` [PATCH v7 08/12] unwind_user/sframe: Remove .sframe section on detected corruption
` [PATCH v7 09/12] unwind_user/sframe: Show file name in debug output
` [PATCH v7 10/12] unwind_user/sframe: Enable debugging in uaccess regions
` [PATCH v7 11/12] unwind_user/sframe: Add .sframe validation option
` [PATCH v7 12/12] [DO NOT APPLY] unwind_user/sframe: Add prctl() interface for registering .sframe sections

[PATCH v12 00/11] perf: Support the deferred unwinding infrastructure
 2025-07-02 12:23 UTC  (16+ messages)
` [PATCH v12 01/11] perf: Remove get_perf_callchain() init_nr argument
` [PATCH v12 02/11] perf: Have get_perf_callchain() return NULL if crosstask and user are set
` [PATCH v12 03/11] perf: Use current->flags & PF_KTHREAD|PF_USER_WORKER instead of current->mm == NULL
` [PATCH v12 04/11] perf: Simplify get_perf_callchain() user logic
` [PATCH v12 05/11] perf: Skip user unwind if the task is a kernel thread
` [PATCH v12 06/11] perf: Support deferred user callchains
` [PATCH v12 07/11] perf: Support deferred user callchains for per CPU events
` [PATCH v12 08/11] perf tools: Minimal CALLCHAIN_DEFERRED support
` [PATCH v12 09/11] perf record: Enable defer_callchain for user callchains
` [PATCH v12 10/11] perf script: Display PERF_RECORD_CALLCHAIN_DEFERRED
` [PATCH v12 11/11] perf tools: Merge deferred user callchains

[PATCH v3 bpf-next 0/4] Introduce bpf_cgroup_read_xattr
 2025-07-02 12:19 UTC  (15+ messages)
` [PATCH v3 bpf-next 1/4] kernfs: remove iattr_mutex

[Patch bpf-next v4 0/4] tcp_bpf: improve ingress redirection performance with message corking
 2025-07-02 12:17 UTC  (11+ messages)
` [Patch bpf-next v4 1/4] skmsg: rename sk_msg_alloc() to sk_msg_expand()
` [Patch bpf-next v4 2/4] skmsg: implement slab allocator cache for sk_msg
` [Patch bpf-next v4 3/4] skmsg: save some space in struct sk_psock
` [Patch bpf-next v4 4/4] tcp_bpf: improve ingress redirection performance with message corking

[PATCH v11 00/14] unwind_user: x86: Deferred unwinding infrastructure
 2025-07-02 11:44 UTC  (2+ messages)

[PATCH net-next v6] net: xsk: introduce XDP_MAX_TX_BUDGET set/getsockopt
 2025-07-02 11:33 UTC  (2+ messages)

[PATCH net-next v5 0/2] net: xsk: update tx queue consumer
 2025-07-02 11:28 UTC  (3+ messages)
` [PATCH net-next v5 1/2] net: xsk: update tx queue consumer immediately after transmission
` [PATCH net-next v5 2/2] selftests/bpf: add a new test to check the consumer update case

[PATCH net-next v4 0/3] selftest: net: Add selftest for netpoll
 2025-07-02 11:21 UTC  (4+ messages)
` [PATCH net-next v4 1/3] selftests: drv-net: add helper/wrapper for bpftrace
` [PATCH net-next v4 2/3] selftests: drv-net: Strip '@' prefix from bpftrace map keys
` [PATCH net-next v4 3/3] selftests: net: add netpoll basic functionality test

[PATCH bpf] xsk: fix immature cq descriptor production
 2025-07-02 11:04 UTC  (2+ messages)

[PATCH net-next v2] Documentation: xsk: correct the obsolete references and examples
 2025-07-02 10:09 UTC  (3+ messages)

[PATCH bpf-next 1/2] bpf: Reduce stack frame size by using env->insn_buf for bpf insns
 2025-07-02  9:28 UTC  (5+ messages)
` [PATCH bpf-next 2/2] bpf: Avoid putting struct bpf_scc_callchain variables on the stack

[PATCHv3 0/9] kexec: Use BPF lskel to enable kexec to load PE format boot image
 2025-07-02  9:17 UTC  (5+ messages)
` [PATCHv3 5/9] kexec: Introduce kexec_pe_image to parse and load PE file

[PATCH bpf-next v2 0/3] bpf: Fix and test aux usage after do_check_insn()
 2025-07-02  8:56 UTC  (4+ messages)
` [PATCH bpf-next v2 2/3] bpf: Fix "

[PATCH bpf-next] selftests/bpf: don't call fsopen() as privileged user
 2025-07-02  8:32 UTC  (3+ messages)

[PATCH bpf-next 00/13] Extend skb dynptr for metadata access from TC
 2025-07-02  8:22 UTC  (7+ messages)
` [PATCH bpf-next 01/13] bpf: Ignore dynptr offset in skb data access
` [PATCH bpf-next 03/13] bpf: Add new variant of skb dynptr for the metadata area

[PATCH bpf] selftests/bpf: Re-add kfunc declarations to qdisc tests
 2025-07-02  7:42 UTC  (9+ messages)

[PATCH bpf-next v1 1/2] bpf: avoid jump misprediction for PTR_TO_MEM | PTR_UNTRUSTED
 2025-07-02  7:36 UTC  (2+ messages)
` [PATCH bpf-next v1 2/2] selftests/bpf: null checks for rdonly_untrusted_mem should be preserved

[PATCH net-next v8 0/5] Split netmem from struct page
 2025-07-02  5:32 UTC  (6+ messages)
` [PATCH net-next v8 1/5] page_pool: rename page_pool_return_page() to page_pool_return_netmem()
` [PATCH net-next v8 2/5] page_pool: rename __page_pool_release_page_dma() to __page_pool_release_netmem_dma()
` [PATCH net-next v8 3/5] page_pool: rename __page_pool_alloc_pages_slow() to __page_pool_alloc_netmems_slow()
` [PATCH net-next v8 4/5] netmem: use _Generic to cover const casting for page_to_netmem()
` [PATCH net-next v8 5/5] page_pool: make page_pool_get_dma_addr() just wrap page_pool_get_dma_addr_netmem()

[PATCH v10 net-next 00/15] AccECN protocol patch series
 2025-07-02  4:37 UTC  (16+ messages)
` [PATCH v10 net-next 01/15] tcp: reorganize SYN ECN code
` [PATCH v10 net-next 02/15] tcp: fast path functions later
` [PATCH v10 net-next 03/15] tcp: reorganize tcp_sock_write_txrx group for variables later
` [PATCH v10 net-next 04/15] tcp: ecn functions in separated include file
` [PATCH v10 net-next 05/15] tcp: AccECN core
` [PATCH v10 net-next 06/15] tcp: accecn: AccECN negotiation
` [PATCH v10 net-next 07/15] tcp: Add wait_third_ack flag for ECN negotiation in simultaneous connect
` [PATCH v10 net-next 08/15] tcp: accecn: add AccECN rx byte counters
` [PATCH v10 net-next 09/15] tcp: accecn: AccECN needs to know delivered bytes
` [PATCH v10 net-next 10/15] tcp: sack option handling improvements
` [PATCH v10 net-next 11/15] tcp: accecn: AccECN option
` [PATCH v10 net-next 12/15] tcp: accecn: AccECN option send control
` [PATCH v10 net-next 13/15] tcp: accecn: AccECN option failure handling
` [PATCH v10 net-next 14/15] tcp: accecn: AccECN option ceb/cep and ACE field multi-wrap heuristics
` [PATCH v10 net-next 15/15] tcp: accecn: try to fit AccECN option with SACK

[PATCH bpf-next 0/2] Clarify and Enhance XDP Rx Metadata Handling
 2025-07-02  3:55 UTC  (6+ messages)
` [PATCH bpf-next 1/2] doc: clarify XDP Rx metadata layout and bpf_xdp_adjust_meta usage
` [PATCH bpf-next 2/2] selftests/bpf: Enhance XDP Rx Metadata Handling

[PATCH bpf-next,v2 0/2] Clarify and Enhance XDP Rx Metadata Handling
 2025-07-02  3:03 UTC  (3+ messages)
` [PATCH bpf-next,v2 1/2] doc: clarify XDP Rx metadata layout and bpf_xdp_adjust_meta usage
` [PATCH bpf-next,v2 2/2] selftests/bpf: Enhance XDP Rx Metadata Handling

[PATCH bpf-next v6 1/3] bpf: Show precise link_type for {uprobe,kprobe}_multi fdinfo
 2025-07-02  2:48 UTC  (6+ messages)
` [PATCH bpf-next v6 3/3] bpf: Add show_fdinfo for kprobe_multi

[PATCH net-next] net: mana: Handle Reset Request from MANA NIC
 2025-07-02  2:40 UTC  (2+ messages)

[syzbot] [bpf?] WARNING in record_func_key
 2025-07-02  1:56 UTC 

[syzbot] [bpf?] WARNING in check_helper_call
 2025-07-02  1:56 UTC 

[syzbot] [bpf?] WARNING in reg_bounds_sanity_check
 2025-07-02  1:55 UTC 

[PATCH v2 0/2] bpf/arena: Add kfunc for reserving arena memory
 2025-07-02  0:33 UTC  (3+ messages)
` [PATCH v2 1/2] bpf/arena: add bpf_arena_reserve_pages kfunc
` [PATCH v2 2/2] selftests/bpf: add selftests for bpf_arena_reserve_pages

[PATCH net-next v7 0/7] Split netmem from struct page
 2025-07-01 23:45 UTC  (7+ messages)
` [PATCH net-next v7 1/7] netmem: introduce struct netmem_desc mirroring "

[PATCH bpf-next v5 0/3] Task local data
 2025-07-01 22:47 UTC  (4+ messages)
` [PATCH bpf-next v5 1/3] selftests/bpf: Introduce task "

[PATCH bpf v2 1/2] bpf: Reject %p% format string in bprintf-like helpers
 2025-07-01 22:40 UTC  (3+ messages)
` [PATCH bpf v2 2/2] selftests/bpf: Add negative test cases for snprintf

[PATCH bpf-next v3 0/2] bpf: add bpf_dynptr_memset() kfunc
 2025-07-01 21:16 UTC  (3+ messages)
` [PATCH bpf-next v3 1/2] "

[PATCH][next] selftests/bpf: Fix spelling mistake "subtration" -> "subtraction"
 2025-07-01 20:40 UTC  (2+ messages)

[RFC PATCH bpf-next 0/3] bpf: Introduce BPF_F_CPU flag for percpu_array map
 2025-07-01 20:22 UTC  (7+ messages)
` [RFC PATCH bpf-next 1/3] "
` [RFC PATCH bpf-next 2/3] bpf, libbpf: Support BPF_F_CPU "
` [RFC PATCH bpf-next 3/3] selftests/bpf: Add case to test BPF_F_CPU

[PATCH bpf-next v3] bpf: Warn on internal verifier errors
 2025-07-01 19:50 UTC  (2+ messages)

[PATCH bpf-next] selftests/bpf: enable dynptr/test_probe_read_user_str_dynptr
 2025-07-01 19:50 UTC  (2+ messages)

[PATCH bpf-next 0/2] s390/bpf: Describe the frame using a struct instead of constants
 2025-07-01 19:40 UTC  (2+ messages)

[PATCH] bpf: Call cond_resched() to avoid soft lockup in trie_free()
 2025-07-01 16:41 UTC  (13+ messages)

[PATCH bpf-next v2] bpf: Warn on internal verifier errors
 2025-07-01 16:16 UTC  (2+ messages)

[PATCH v2 dwarves 2/2] github CI: Add comparison of generated BTF functions between baseline, change
 2025-07-01 16:14 UTC  (2+ messages)

[PATCH bpf 1/2] bpf: Reject %p% format string in bprintf-like helpers
 2025-07-01 16:03 UTC  (4+ messages)
` [PATCH bpf 2/2] selftests/bpf: Add negative test cases for snprintf

[PATCH bpf-next 02/13] bpf: Helpers for skb dynptr read/write/slice
 2025-07-01 11:13 UTC  (4+ messages)

[PATCH iwl-net v1 1/1] igc: Fix data_meta pointer adjustment for XDP zero-copy
 2025-07-01  8:09 UTC 

[PATCH 0/2] Fix two tailcall-related issues
 2025-07-01  7:41 UTC  (3+ messages)
` [PATCH 1/2] LoongArch: BPF: Optimize the calculation method of jmp_offset in the emit_bpf_tail_call function
` [PATCH 2/2] LoongArch: BPF: Fix tailcall hierarchy

[PATCH v1] tools/rtla: Consolidate common parameters into shared structure
 2025-07-01  6:03 UTC 

[PATCH v3 0/5] barrier: Add smp_cond_load_*_timewait()
 2025-07-01  5:55 UTC  (5+ messages)
` [PATCH v3 5/5] arm64: barrier: Handle waiting in smp_cond_load_relaxed_timewait()

[PATCH] bpftool: Add CET-aware symbol matching for x86_64 architectures
 2025-07-01  2:31 UTC  (3+ messages)
` [PATCH v3] "

[PATCH net v3 0/2] virtio-net: xsk: rx: fix the frame's length check
 2025-07-01  2:23 UTC  (3+ messages)
` [PATCH net v3 2/2] virtio-net: xsk: rx: move the xdp->data adjustment to buf_to_xdp()

[PATCH net v2 0/3] virtio-net: fixes for mergeable XDP receive path
 2025-07-01  2:20 UTC  (5+ messages)
` [PATCH net v2 1/3] virtio-net: ensure the received length does not exceed allocated size
` [PATCH net v2 3/3] virtio-net: use the check_mergeable_len helper


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox