messages from 2025-07-02 04:37:31 to 2025-07-03 11:23:42 UTC [more...]
[PATCH net] vsock: fix `vsock_proto` declaration
2025-07-03 11:23 UTC
[PATCH bpf-next V2 0/7] xdp: Allow BPF to set RX hints for XDP_REDIRECTed packets
2025-07-03 11:17 UTC (10+ messages)
` [PATCH bpf-next V2 1/7] net: xdp: Add xdp_rx_meta structure
` [PATCH bpf-next V2 2/7] selftests/bpf: Adjust test for maximum packet size in xdp_do_redirect
` [PATCH bpf-next V2 3/7] net: xdp: Add kfuncs to store hw metadata in xdp_buff
` [PATCH bpf-next V2 4/7] net: xdp: Set skb hw metadata from xdp_frame
` [PATCH bpf-next V2 5/7] net: veth: Read xdp metadata from rx_meta struct if available
` [PATCH bpf-next V2 6/7] bpf: selftests: Add rx_meta store kfuncs selftest
` [PATCH bpf-next V2 7/7] net: xdp: update documentation for xdp-rx-metadata.rst
[PATCH] bpf: Call cond_resched() to avoid soft lockup in trie_free()
2025-07-03 11:00 UTC (13+ messages)
[PATCH 5.10/5.15] bpf: Do mark_chain_precision for ARG_CONST_ALLOC_SIZE_OR_ZERO
2025-07-03 9:50 UTC
[PATCH net v3 0/2] virtio-net: xsk: rx: fix the frame's length check
2025-07-03 9:40 UTC (5+ messages)
` [PATCH net v3 2/2] virtio-net: xsk: rx: move the xdp->data adjustment to buf_to_xdp()
[PATCH net v2 0/3] virtio-net: fixes for mergeable XDP receive path
2025-07-03 9:10 UTC (2+ messages)
[PATCH v2 0/3] btf_encoder: do not encode functions consuming packed structs on stack
2025-07-03 9:02 UTC (4+ messages)
` [PATCH v2 1/3] btf_encoder: skip functions consuming packed structs passed by value "
` [PATCH v2 2/3] tests: add some tests validating skipped functions due to uncertain arg location
` [PATCH v2 3/3] gitignore: ignore all the test kmod build-related files
[PATCH net-next v6] net: xsk: introduce XDP_MAX_TX_BUDGET set/getsockopt
2025-07-03 8:22 UTC (4+ messages)
[PATCH v3 bpf-next 0/4] Introduce bpf_cgroup_read_xattr
2025-07-03 6:28 UTC (16+ messages)
` [PATCH v3 bpf-next 1/4] kernfs: remove iattr_mutex
[PATCH v11 net-next 00/15] AccECN protocol patch series
2025-07-03 5:17 UTC (16+ messages)
` [PATCH v11 net-next 01/15] tcp: reorganize SYN ECN code
` [PATCH v11 net-next 02/15] tcp: fast path functions later
` [PATCH v11 net-next 03/15] tcp: reorganize tcp_sock_write_txrx group for variables later
` [PATCH v11 net-next 04/15] tcp: ecn functions in separated include file
` [PATCH v11 net-next 05/15] tcp: AccECN core
` [PATCH v11 net-next 06/15] tcp: accecn: AccECN negotiation
` [PATCH v11 net-next 07/15] tcp: Add wait_third_ack flag for ECN negotiation in simultaneous connect
` [PATCH v11 net-next 08/15] tcp: accecn: add AccECN rx byte counters
` [PATCH v11 net-next 09/15] tcp: accecn: AccECN needs to know delivered bytes
` [PATCH v11 net-next 10/15] tcp: sack option handling improvements
` [PATCH v11 net-next 11/15] tcp: accecn: AccECN option
` [PATCH v11 net-next 12/15] tcp: accecn: AccECN option send control
` [PATCH v11 net-next 13/15] tcp: accecn: AccECN option failure handling
` [PATCH v11 net-next 14/15] tcp: accecn: AccECN option ceb/cep and ACE field multi-wrap heuristics
` [PATCH v11 net-next 15/15] tcp: accecn: try to fit AccECN option with SACK
[PATCH v5 bpf-next 0/5] bpf path iterator
2025-07-03 5:04 UTC (4+ messages)
[PATCH v11 00/14] unwind_user: x86: Deferred unwinding infrastructure
2025-07-03 4:01 UTC (6+ messages)
[PATCH bpf-next v1 0/8] bpf: additional use-cases for untrusted PTR_TO_MEM
2025-07-03 3:20 UTC (11+ messages)
` [PATCH bpf-next v1 1/8] bpf: make makr_btf_ld_reg return error for unexpected reg types
` [PATCH bpf-next v1 2/8] bpf: rdonly_untrusted_mem for btf id walk pointer leafs
` [PATCH bpf-next v1 3/8] selftests/bpf: ptr_to_btf_id struct walk ending with primitive pointer
` [PATCH bpf-next v1 4/8] bpf: attribute __arg_untrusted for global function parameters
` [PATCH bpf-next v1 5/8] libbpf: __arg_untrusted in bpf_helpers.h
` [PATCH bpf-next v1 6/8] selftests/bpf: test cases for __arg_untrusted
` [PATCH bpf-next v1 7/8] bpf: support for void/primitive __arg_untrusted global func params
` [PATCH bpf-next v1 8/8] selftests/bpf: tests for __arg_untrusted void * "
linux-next: duplicate patches in the bpf-next tree
2025-07-03 2:51 UTC
[Patch bpf-next v4 0/4] tcp_bpf: improve ingress redirection performance with message corking
2025-07-03 2:17 UTC (13+ messages)
` [Patch bpf-next v4 1/4] skmsg: rename sk_msg_alloc() to sk_msg_expand()
` [Patch bpf-next v4 2/4] skmsg: implement slab allocator cache for sk_msg
` [Patch bpf-next v4 3/4] skmsg: save some space in struct sk_psock
` [Patch bpf-next v4 4/4] tcp_bpf: improve ingress redirection performance with message corking
[PATCH bpf-next v2 0/3] bpf: Reduce verifier stack frame size
2025-07-03 2:02 UTC (9+ messages)
` [PATCH bpf-next v2 1/3] bpf: Simplify assignment to struct bpf_insn pointer in do_misc_fixups()
` [PATCH bpf-next v2 2/3] bpf: Reduce stack frame size by using env->insn_buf for bpf insns
` [PATCH bpf-next v2 3/3] bpf: Avoid putting struct bpf_scc_callchain variables on the stack
[PATCHv3 0/9] kexec: Use BPF lskel to enable kexec to load PE format boot image
2025-07-03 1:17 UTC (6+ messages)
` [PATCHv3 5/9] kexec: Introduce kexec_pe_image to parse and load PE file
[PATCH v12 00/14] unwind_user: x86: Deferred unwinding infrastructure
2025-07-02 23:50 UTC (33+ messages)
` [PATCH v12 02/14] unwind_user: Add frame pointer support
` [PATCH v12 06/14] unwind_user/deferred: Add deferred unwinding interface
` [PATCH v12 07/14] unwind_user/deferred: Make unwind deferral requests NMI-safe
[PATCH v6 00/14] Add a deadline server for sched_ext tasks
2025-07-02 23:29 UTC (3+ messages)
` [PATCH v6 12/14] selftests/sched_ext: Add test for sched_ext dl_server
` [PATCH v6 14/14] selftests/sched_ext: Add test for DL server total_bw consistency
[PATCH net-next v5 0/2] net: xsk: update tx queue consumer
2025-07-02 23:09 UTC (5+ messages)
` [PATCH net-next v5 1/2] net: xsk: update tx queue consumer immediately after transmission
` [PATCH net-next v5 2/2] selftests/bpf: add a new test to check the consumer update case
[syzbot] [bpf?] WARNING in check_helper_call
2025-07-02 22:04 UTC (2+ messages)
[PATCH bpf-next v4 0/2] bpf: add bpf_dynptr_memset() kfunc
2025-07-02 21:03 UTC (3+ messages)
` [PATCH bpf-next v4 1/2] "
` [PATCH bpf-next v4 2/2] selftests/bpf: add test cases for bpf_dynptr_memset()
[PATCH bpf-next v2] selftests/bpf: allow veristat compile standalone
2025-07-02 18:50 UTC (2+ messages)
[PATCH bpf] selftests/bpf: Re-add kfunc declarations to qdisc tests
2025-07-02 17:55 UTC (11+ messages)
[PATCH bpf-next] selftests/bpf: allow veristat compile standalone
2025-07-02 17:36 UTC (2+ messages)
[RFC PATCH bpf-next 0/3] bpf: Introduce BPF_F_CPU flag for percpu_array map
2025-07-02 17:32 UTC (13+ messages)
` [RFC PATCH bpf-next 1/3] "
` [RFC PATCH bpf-next 2/3] bpf, libbpf: Support BPF_F_CPU "
` [RFC PATCH bpf-next 3/3] selftests/bpf: Add case to test BPF_F_CPU
[PATCH bpf-next v4 00/12] BPF Standard Streams
2025-07-02 17:07 UTC (7+ messages)
` [PATCH bpf-next v4 01/12] bpf: Refactor bprintf buffer support
` [PATCH bpf-next v4 02/12] bpf: Introduce BPF standard streams
[PATCH iwl-net v1 1/1] igc: Fix data_meta pointer adjustment for XDP zero-copy
2025-07-02 17:07 UTC (2+ messages)
[PATCH bpf-next,v3 0/2] Clarify and Enhance XDP Rx Metadata Handling
2025-07-02 16:57 UTC (3+ messages)
` [PATCH bpf-next,v3 1/2] doc: enhance explanation of XDP Rx metadata layout and METADATA_SIZE
` [PATCH bpf-next,v3 2/2] selftests/bpf: Enhance XDP Rx metadata handling
[PATCH v7 00/12] unwind_deferred: Implement sframe handling
2025-07-02 16:47 UTC (3+ messages)
[PATCH v12 00/11] perf: Support the deferred unwinding infrastructure
2025-07-02 16:28 UTC (6+ messages)
` [PATCH v12 07/11] perf: Support deferred user callchains for per CPU events
` [PATCH v12 08/11] perf tools: Minimal CALLCHAIN_DEFERRED support
[PATCH bpf-next 0/2] Clarify and Enhance XDP Rx Metadata Handling
2025-07-02 16:17 UTC (9+ messages)
` [PATCH bpf-next 2/2] selftests/bpf: "
[PATCH bpf-next 1/2] selftests/bpf: Negative test case for ref_obj_id in args
2025-07-02 15:50 UTC (3+ messages)
` [PATCH bpf-next 2/2] bpf: Avoid warning on multiple referenced args in call
[PATCH bpf] xsk: fix immature cq descriptor production
2025-07-02 15:49 UTC (3+ messages)
[PATCH bpf-next v7 1/3] bpf: Show precise link_type for {uprobe,kprobe}_multi fdinfo
2025-07-02 15:39 UTC (3+ messages)
` [PATCH bpf-next v7 2/3] bpf: Add show_fdinfo for uprobe_multi
` [PATCH bpf-next v7 3/3] bpf: Add show_fdinfo for kprobe_multi
[PATCH net-next v2] Documentation: xsk: correct the obsolete references and examples
2025-07-02 15:35 UTC (4+ messages)
[PATCH bpf-next 1/2] bpf: Reduce stack frame size by using env->insn_buf for bpf insns
2025-07-02 15:29 UTC (7+ messages)
` [PATCH bpf-next 2/2] bpf: Avoid putting struct bpf_scc_callchain variables on the stack
[PATCH bpf-next v1 1/2] bpf: avoid jump misprediction for PTR_TO_MEM | PTR_UNTRUSTED
2025-07-02 15:00 UTC (3+ messages)
` [PATCH bpf-next v1 2/2] selftests/bpf: null checks for rdonly_untrusted_mem should be preserved
[PATCH] bpf: turn off sanitizer in do_misc_fixups for old clang
2025-07-02 14:14 UTC (7+ messages)
[PATCH net-next V4] net: track pfmemalloc drops via SKB_DROP_REASON_PFMEMALLOC
2025-07-02 13:59 UTC
[PATCH net-next v4 0/3] selftest: net: Add selftest for netpoll
2025-07-02 11:21 UTC (4+ messages)
` [PATCH net-next v4 1/3] selftests: drv-net: add helper/wrapper for bpftrace
` [PATCH net-next v4 2/3] selftests: drv-net: Strip '@' prefix from bpftrace map keys
` [PATCH net-next v4 3/3] selftests: net: add netpoll basic functionality test
[PATCH bpf-next v2 0/3] bpf: Fix and test aux usage after do_check_insn()
2025-07-02 8:56 UTC (4+ messages)
` [PATCH bpf-next v2 2/3] bpf: Fix "
[PATCH bpf-next] selftests/bpf: don't call fsopen() as privileged user
2025-07-02 8:32 UTC (2+ messages)
[PATCH bpf-next 00/13] Extend skb dynptr for metadata access from TC
2025-07-02 8:22 UTC (7+ messages)
` [PATCH bpf-next 01/13] bpf: Ignore dynptr offset in skb data access
` [PATCH bpf-next 03/13] bpf: Add new variant of skb dynptr for the metadata area
[PATCH net-next v8 0/5] Split netmem from struct page
2025-07-02 5:32 UTC (6+ messages)
` [PATCH net-next v8 1/5] page_pool: rename page_pool_return_page() to page_pool_return_netmem()
` [PATCH net-next v8 2/5] page_pool: rename __page_pool_release_page_dma() to __page_pool_release_netmem_dma()
` [PATCH net-next v8 3/5] page_pool: rename __page_pool_alloc_pages_slow() to __page_pool_alloc_netmems_slow()
` [PATCH net-next v8 4/5] netmem: use _Generic to cover const casting for page_to_netmem()
` [PATCH net-next v8 5/5] page_pool: make page_pool_get_dma_addr() just wrap page_pool_get_dma_addr_netmem()
[PATCH v10 net-next 00/15] AccECN protocol patch series
2025-07-02 4:37 UTC (15+ messages)
` [PATCH v10 net-next 01/15] tcp: reorganize SYN ECN code
` [PATCH v10 net-next 03/15] tcp: reorganize tcp_sock_write_txrx group for variables later
` [PATCH v10 net-next 04/15] tcp: ecn functions in separated include file
` [PATCH v10 net-next 05/15] tcp: AccECN core
` [PATCH v10 net-next 06/15] tcp: accecn: AccECN negotiation
` [PATCH v10 net-next 07/15] tcp: Add wait_third_ack flag for ECN negotiation in simultaneous connect
` [PATCH v10 net-next 08/15] tcp: accecn: add AccECN rx byte counters
` [PATCH v10 net-next 09/15] tcp: accecn: AccECN needs to know delivered bytes
` [PATCH v10 net-next 10/15] tcp: sack option handling improvements
` [PATCH v10 net-next 11/15] tcp: accecn: AccECN option
` [PATCH v10 net-next 12/15] tcp: accecn: AccECN option send control
` [PATCH v10 net-next 13/15] tcp: accecn: AccECN option failure handling
` [PATCH v10 net-next 14/15] tcp: accecn: AccECN option ceb/cep and ACE field multi-wrap heuristics
` [PATCH v10 net-next 15/15] tcp: accecn: try to fit AccECN option with SACK
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox