messages from 2026-08-03 18:46:37 to 2026-08-04 21:46:55 UTC [more...]
[PATCH dwarves] btf_encoder: Infer arena kfunc arguments from suffixes
2026-08-04 21:46 UTC (8+ messages)
[PATCH v5 net-next 0/2] ECN offload handling series
2026-08-04 21:35 UTC (3+ messages)
` [PATCH v5 net-next 1/2] net: update comments for SKB_GSO_TCP_ECN and SKB_GSO_TCP_ACCECN
` [PATCH v5 net-next 2/2] net: hns3: fix GSO_ECN flag setting in the RX path
[PATCH v2 00/13] bpf: Support aggregate return values up to 16 bytes
2026-08-04 21:14 UTC (18+ messages)
` [PATCH bpf-next v2 01/13] bpf: Factor check_global_ret_scalar_reg() out of the global return check
` [PATCH bpf-next v2 02/13] bpf: Add helpers to describe the R0:R2 return register pair
` [PATCH bpf-next v2 03/13] bpf: Wire up JIT support for 16-byte kfunc returns
` [PATCH bpf-next v2 04/13] bpf: Track R2 of register-pair returns in precision backtracking
` [PATCH bpf-next v2 05/13] bpf: Account R2 of register-pair returns in live register analysis
` [PATCH bpf-next v2 06/13] bpf: Reject callbacks returning more than 8 bytes
` [PATCH bpf-next v2 07/13] bpf: Add verifier support for 16-byte returns in R0:R2
` [PATCH bpf-next v2 08/13] bpf: Reject register-pair returns when the subprog BTF is unreliable
` [PATCH bpf-next v2 09/13] bpf: Enable aggregate return types up to 16 bytes
` [PATCH bpf-next v2 10/13] selftests/bpf: Add C tests for 16-byte returns in R0:R2
` [PATCH bpf-next v2 11/13] selftests/bpf: Add inline-asm and subprog tests for R0:R2 returns
` [PATCH bpf-next v2 12/13] selftests/bpf: Add tests for callbacks returning more than 8 bytes
` [PATCH bpf-next v2 13/13] Documentation/bpf: Document up to 16-byte kfunc return values in R0:R2
[RFC PATCH bpf-next v4 0/3] selftests/bpf: restructure the Makefile as a layered build
2026-08-04 20:43 UTC (4+ messages)
` [RFC PATCH bpf-next v4 3/3] selftests/bpf: build each test runner instance in its own sub-make
[RFC PATCH bpf-next v4 2/3] selftests/bpf: move shared build definitions into Makefile.buildvars
2026-08-04 20:42 UTC (3+ messages)
[PATCH bpf-next v3 0/9] Add arena argument support to kfuncs and struct_ops
2026-08-04 20:36 UTC (11+ messages)
` [PATCH bpf-next v3 1/9] bpf: Support __arena and __arena_nullable kfunc argument suffixes
` [PATCH bpf-next v3 5/9] selftests/bpf: Add kfunc __arena and __arena_nullable argument tests
[PATCH bpf-next 1/2] bpf: Check load-acquire src ptr type before the load
2026-08-04 20:19 UTC (2+ messages)
` [PATCH bpf-next 2/2] selftests/bpf: Add load-acquire test for dst_reg == src_reg from ctx
[PATCHv3 bpf-next 00/12] bpf: Disable preemption in stack map code
2026-08-04 20:05 UTC (21+ messages)
` [PATCHv3 bpf-next 01/12] bpf: Factor stackid_init function from __bpf_get_stackid
` [PATCHv3 bpf-next 02/12] bpf: Factor stackid_fastpath "
` [PATCHv3 bpf-next 03/12] bpf: Factor stackid_new_bucket "
` [PATCHv3 bpf-next 04/12] bpf: Use stack id functions instead of __bpf_get_stackid
` [PATCHv3 bpf-next 05/12] bpf: Disable preemption in bpf_get_stackid
` [PATCHv3 bpf-next 06/12] bpf: Factor callchain_store function from __bpf_get_stack
` [PATCHv3 bpf-next 07/12] bpf: Factor callchain_finalize "
` [PATCHv3 bpf-next 08/12] bpf: Remove trace_in argument "
` [PATCHv3 bpf-next 09/12] bpf: Clear buf on error in __bpf_get_task_stack
` [PATCHv3 bpf-next 10/12] bpf: Disable preemption in __bpf_get_stack
` [PATCHv3 bpf-next 11/12] bpf: Avoid changing callchain in bpf_get_stack_pe
` [PATCHv3 bpf-next 12/12] bpf: Avoid changing callchain in bpf_get_stackid_pe
[PATCH bpf-next v6 0/9] bpf: add support for KASAN checks in JITed programs
2026-08-04 19:04 UTC (15+ messages)
` [PATCH bpf-next v6 1/9] bpf: mark instructions accessing program stack
` [PATCH bpf-next v6 2/9] bpf: add BPF_JIT_KASAN for KASAN instrumentation of JITed programs
` [PATCH bpf-next v6 3/9] bpf, x86: refactor BPF_ST management in do_jit
` [PATCH bpf-next v6 4/9] bpf, x86: emit KASAN checks in x86 JITed programs
` [PATCH bpf-next v6 5/9] bpf, x86: enable KASAN for JITed programs on x86
` [PATCH bpf-next v6 6/9] selftests/bpf: make cmdline_contains stricter
` [PATCH bpf-next v6 7/9] selftests/bpf: add helpers for KASAN in JIT testing
` [PATCH bpf-next v6 8/9] selftests/bpf: move bpf_jit_harden helper into testing_helpers
` [PATCH bpf-next v6 9/9] selftests/bpf: add tests to validate KASAN on JIT programs
[PATCH net-next v3 00/15] gve: AdminQ mode related refactors
2026-08-04 18:47 UTC (22+ messages)
` [PATCH net-next v3 01/15] gve: don't pass in unused parameter to gve_adminq_free
` [PATCH net-next v3 04/15] gve: add struct gve_device_info to hold device properties
` [PATCH net-next v3 05/15] gve: introduce control plane operations structure
` [PATCH net-next v3 06/15] gve: introduce ctrl ops to set vectors and Qs
` [PATCH net-next v3 07/15] gve: introduce gve_adminq_get_device_properties()
` [PATCH net-next v3 08/15] gve: refactor gve_init_priv for reset path
` [PATCH net-next v3 09/15] gve: simplify reset logic
` [PATCH net-next v3 10/15] gve: add gve_ctrl_ops for gve initialization/teardown sequences
` [PATCH net-next v3 11/15] gve: split up notify block allocation and setup paths
` [PATCH net-next v3 12/15] gve: introduce new methods to handle IRQ doorbells
` [PATCH net-next v3 13/15] gve: setup and teardown management interrupts
` [PATCH net-next v3 14/15] gve: add ctrl ops to for queue operations
` [PATCH net-next v3 15/15] gve: add link status/speed ctrl ops
[RFC PATCH bpf-next v5 0/8] selftests/bpf: restructure the Makefile as a layered build
2026-08-04 17:59 UTC (11+ messages)
` [RFC PATCH bpf-next v5 1/8] selftests/bpf: keep headers off the generic link command line
` [RFC PATCH bpf-next v5 2/8] selftests/bpf: drop stale and no-op lines
` [RFC PATCH bpf-next v5 3/8] selftests/bpf: factor the permissive-mode skip suffix into a helper
` [RFC PATCH bpf-next v5 4/8] selftests/bpf: generate the signing key and certificate once
` [RFC PATCH bpf-next v5 5/8] selftests/bpf: generate verifier/tests.h in a regular recipe
` [RFC PATCH bpf-next v5 6/8] selftests/bpf: extract BPF skeleton generation into a helper script
` [RFC PATCH bpf-next v5 7/8] selftests/bpf: move shared build definitions into Makefile.buildvars
` [RFC PATCH bpf-next v5 8/8] selftests/bpf: build each test runner instance in its own sub-make
[PATCH bpf v2 0/1] bpf: Check sk_state before sk_protocol in bpf_tcp_*_syncookie
2026-08-04 17:50 UTC (5+ messages)
` [PATCH bpf v2 1/1] "
[PATCH bpf-next v3 0/5] Introduce bpf_ksock
2026-08-04 17:50 UTC (7+ messages)
` [PATCH bpf-next v3 1/5] net: Add __sys_connect_socket() helper
` [PATCH bpf-next v3 2/5] bpf: Add ksock kfuncs
` [PATCH bpf-next v3 3/5] selftests/bpf: Add ksock kfunc test
` [PATCH bpf-next v3 4/5] selftests/bpf: Add ksock LSM recursion test
` [PATCH bpf-next v3 5/5] selftests/bpf: Add ksock test for async callback guard
[PATCH bpf-next v2 0/2] bpf: Invalidate RCU pointers after final spin unlock
2026-08-04 16:28 UTC (6+ messages)
` [PATCH bpf-next v2 1/2] "
[PATCH bpf-next v3 0/2] bpf: Fix sleepable check for tracing prog
2026-08-04 15:49 UTC (4+ messages)
` [PATCH bpf-next v3 1/2] "
` [PATCH bpf-next v3 2/2] selftests/bpf: Verify rejection of sleepable "
[PATCH bpf-next] selftests/bpf: Move tracing_multi_bench_attach to bench
2026-08-04 15:48 UTC
[PATCH v3 0/2] LoongArch: BPF: per-CPU address resolution and timed may_goto
2026-08-04 15:39 UTC (3+ messages)
` [PATCH v3 1/2] LoongArch: BPF: Support internal-only MOV to resolve per-CPU addrs
` [PATCH v3 2/2] LoongArch: BPF: Add timed may_goto support
[PATCH bpf-next v5 0/6] bpf: Inline the numeric open-coded iterator kfuncs
2026-08-04 15:04 UTC (9+ messages)
` [PATCH bpf-next v5 1/6] bpf: Correct the overflow check comment in bpf_iter_num_next()
` [PATCH bpf-next v5 2/6] bpf: Inline bpf_iter_num_new() kfunc
` [PATCH bpf-next v5 3/6] bpf: Inline bpf_iter_num_next() kfunc
` [PATCH bpf-next v5 4/6] bpf: Inline bpf_iter_num_destroy() as a no-op
` [PATCH bpf-next v5 5/6] selftests/bpf: Verify inlined numeric iterator shape with __xlated
` [PATCH bpf-next v5 6/6] selftests/bpf: Add bpf_for() benchmark
[BUG?] bpf/tcx: bpf_clone_redirect() can sustain self-cloning transmit loops
2026-08-04 14:57 UTC
[PATCH] bpf: disable lockdep while running BPF on lock_release
2026-08-04 14:45 UTC (4+ messages)
[PATCH v8 13/25] cachefiles,netfs: sunset ondemand mode
2026-08-04 14:32 UTC (2+ messages)
[PATCH v6 net-next 1/1] tcp: Replace min_tso_segs() with tso_segs() CC callback
2026-08-04 14:08 UTC (2+ messages)
[PATCH] binfmt_elf_fdpic: only honour the first PT_INTERP
2026-08-04 13:56 UTC (3+ messages)
[PATCH] bpf: add KF_SPIN_LOCK flag for kfuncs under bpf_spin_lock
2026-08-04 13:05 UTC (9+ messages)
[PATCH net 0/1] xdp: reject clones that overrun skb_shared_info tailroom
2026-08-04 12:54 UTC (4+ messages)
` [PATCH net 1/1] "
[PATCH v5 00/14] module: Introduce hash-based integrity checking
2026-08-04 12:44 UTC (5+ messages)
` [PATCH v5 13/14] kbuild: move handling of module stripping to Makefile.lib
` [PATCH v5 14/14] kbuild: make CONFIG_MODULE_HASHES compatible with module stripping
[PATCH v4 net-next 1/1] net: update comments for SKB_GSO_TCP_ECN and SKB_GSO_TCP_ACCECN
2026-08-04 12:38 UTC (3+ messages)
[PATCH net v2 1/1] net: cap advertised device headroom
2026-08-04 11:52 UTC (2+ messages)
[PATCH bpf v2 0/2] bpf: Fix socket leaks around connect(AF_UNSPEC)+listen()
2026-08-04 10:14 UTC (6+ messages)
` [PATCH bpf v2 1/2] bpf: Extract shared reqsk-to-listener upgrade
` [PATCH bpf v2 2/2] bpf: Unconditionally take socket references in lookup helpers
[PATCH bpf-next v5 0/3] Improve stack depth verification stats output
2026-08-04 9:48 UTC (8+ messages)
` [PATCH bpf-next v5 1/3] bpf: Show more useful info in stack depth stats
` [PATCH bpf-next v5 2/3] selftests/bpf: Adjust veristat stack depth parsing
` [PATCH bpf-next v5 3/3] selftests/bpf: Test stack depth stats without BTF subprog names
[PATCH bpf v2 0/2] Fixes for bpf_get_fsverity_digest()
2026-08-04 7:30 UTC (4+ messages)
` [PATCH bpf v2 2/2] fsverity: Fix silent truncation in bpf_get_fsverity_digest()
[PATCH] fsverity: Fix bpf_get_fsverity_digest() dynptr assumptions
2026-08-04 7:30 UTC (2+ messages)
[PATCH bpf-next v4 0/3] Improve stack depth verification stats output
2026-08-04 7:21 UTC (4+ messages)
` [PATCH bpf-next v4 1/3] bpf: Show more useful info in stack depth stats
[PATCH net v3 0/2] fix skb length accounting after XDP frag adjustment
2026-08-04 5:40 UTC (3+ messages)
` [PATCH net v3 1/2] net: fix skb length accounting after generic "
` [PATCH net v3 2/2] veth: fix skb length accounting after "
[bpf-next 3/4] selftests/bpf: report failed subtest count in test_progs summary
2026-08-03 18:36 UTC (3+ messages)
[PATCH 1/1] bpf: Check sk_fullsock() in bpf_tcp_*_syncookie
2026-08-04 3:00 UTC (2+ messages)
[PATCH net-next v13 0/2] net: mana: add ethtool private flag for full-page RX buffers
2026-08-04 2:40 UTC (2+ messages)
[PATCH net v2] selftests: net: reuseport_bpf_numa: consider cpuless numa node
2026-08-04 1:42 UTC (2+ messages)
[PATCH bpf-next v2] bpf: Fix mmap_lock leak in irq_work path
2026-08-04 1:08 UTC (2+ messages)
[PATCH net 0/6] xsk: harden TX metadata validation against races
2026-08-03 23:50 UTC (2+ messages)
[PATCH bpf v3 0/4] bpf: Fix refcount_acquire handling for borrowed kptrs
2026-08-03 22:48 UTC (4+ messages)
` [PATCH bpf v3 2/4] selftests/bpf: Test refcount_acquire return nullability
[PATCH net-next] selftests: drv-net: enable devmem TCP in the test config
2026-08-03 20:30 UTC (2+ messages)
[PATCH v2] tracing: Make per-template BTF id lists file-local
2026-08-03 20:10 UTC (2+ messages)
[bpf-next 4/4] selftests/bpf: vmtest.sh: preserve command quoting when running in the VM
2026-08-03 19:52 UTC (3+ messages)
[PATCH 0/2] arm64: ftrace: enable single ftrace_ops for direct calls
2026-08-03 19:48 UTC (9+ messages)
` [PATCH 1/2] "
[bpf-next 2/4] selftests/bpf: add --no-error-summary to skip end-of-run error log dump
2026-08-03 19:48 UTC (3+ messages)
[PATCH bpf v4] bpf: Fix UAF when reading prog type in bpf_mprog_link
2026-08-03 19:14 UTC (3+ messages)
[PATCH 7.1.y] selftests/bpf: Add tests for sleepable tracepoint programs
2026-08-03 18:57 UTC
[PATCH v5 0/4] arm64: Add BRBE support for bpf_get_branch_snapshot()
2026-08-03 18:54 UTC (4+ messages)
` [PATCH v5 3/4] perf/arm64: "
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox