From mboxrd@z Thu Jan 1 00:00:00 1970 From: Li Zefan Subject: Re: [PATCH 3/3] cgroup: implement cgroup.subtree_populated for the default hierarchy Date: Wed, 16 Apr 2014 09:30:32 +0800 Message-ID: <534DDD38.9090800@huawei.com> References: <1397511846-2904-1-git-send-email-tj@kernel.org> <1397511846-2904-4-git-send-email-tj@kernel.org> <534C83F1.9020106@huawei.com> <20140415145450.GL1863@htj.dyndns.org> <20140415165221.GD30990@htj.dyndns.org> Mime-Version: 1.0 Content-Transfer-Encoding: 7bit Return-path: In-Reply-To: <20140415165221.GD30990-Gd/HAXX7CRxy/B6EtB590w@public.gmane.org> Sender: cgroups-owner-u79uwXL29TY76Z2rM5mHXA@public.gmane.org List-ID: Content-Type: text/plain; charset="us-ascii" To: Tejun Heo Cc: containers-cunTk1MwBs9QetFLy7KEm3xJsTq8ys+cHZ5vskTnxNA@public.gmane.org, cgroups-u79uwXL29TY76Z2rM5mHXA@public.gmane.org, linux-kernel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org, john-jueV0HHMeujJJrXXpGQQMAC/G2K4zDHf@public.gmane.org, rlove-L7G0xEPcOZbYtjvyW6yDsg@public.gmane.org, eparis-FjpueFixGhCM4zKIHC2jIg@public.gmane.org, gregkh-hQyY1W1yCW8ekmWlsbkhG0B+6BGkLq7r@public.gmane.org, serge.hallyn-GeWIH/nMZzLQT0dZR+AlfA@public.gmane.org, lennart-mdGvqq1h2p+GdvJs77BJ7Q@public.gmane.org, kay-tD+1rO4QERM@public.gmane.org On 2014/4/16 0:52, Tejun Heo wrote: > On Tue, Apr 15, 2014 at 10:54:50AM -0400, Tejun Heo wrote: >> Hello, >> >> On Tue, Apr 15, 2014 at 08:57:21AM +0800, Li Zefan wrote: >>> Is cgroup.tree_populated a better name? >>> >>> cgroup.subtree_control controls child cgroups only, but .subtree_populated >>> shows 1 if there're tasks in the cgroup or its children, so the two >>> are a bit inconsistent to me. >> >> Yes, good catch. subtree_control affects subtree proper. >> subtree_populated covers self too. The difference is subtle and the >> trade off between shared pattern in names and clarifying the subtlety >> didn't seem clear-cut to me. Hmmm.... > > How about cgroup.populated? > Yeah, fine for me.