Hi Jan,
On Mon, Aug 10, 2026 at 07:46 AM, Jan Kiszka wrote:
On 03.08.26 11:47, Kunijadar Shivanand wrote:
Hi Jan,
On Tue, Jul 28, 2026 at 09:26 PM, Kunijadar Shivanand wrote:
On Tue, Jul 28, 2026 at 08:29 AM, Jan Kiszka wrote:
On 28.07.26 10:55, Shivanand.Kunijadar@toshiba-tsip.com wrote:
From: Shivanand Kunijadar <Shivanand.Kunijadar@toshiba-tsip.com>
Keep these jobs as scheduled and can be scheduled to run
every week
just to monitor and fix if there are any issues.
Also set allow_failure:true for these jobs as forky is not
officially
released and there will always be some build & test issues.
It includes SWUpdate, secure boot & RB tests.
Signed-off-by: Shivanand Kunijadar
<Shivanand.Kunijadar@toshiba-tsip.com>
---
.gitlab-ci.yml | 148 +++++++++++++++++++++++++++++++++++++
.reproducible-check-ci.yml | 72 ++++++++++++++++++
2 files changed, 220 insertions(+)
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index b53def4..b15c5da 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -8,6 +8,7 @@
# Jan Kiszka <jan.kiszka@siemens.com>
# Quirin Gylstorff <quirin.gylstorff@siemens.com>
# Nobuhiro Iwamatsu <nobuhiro1.iwamatsu@toshiba.co.jp>
+# Shivanand Kunijadar <shivanand.kunijadar@toshiba-tsip.com>
#
# SPDX-License-Identifier: MIT
#
@@ -63,6 +64,7 @@ default:
- if [ "${release}" = "bullseye" ]; then
base_yaml="${base_yaml}:kas/opt/bullseye.yml"; fi
- if [ "${release}" = "bookworm" ]; then
base_yaml="${base_yaml}:kas/opt/bookworm.yml"; fi
- if [ "${release}" = "trixie" ]; then
base_yaml="${base_yaml}:kas/opt/trixie.yml"; fi
+ - if [ "${release}" = "forky" ]; then
base_yaml="${base_yaml}:kas/opt/forky.yml"; fi
- if [ "${release}" = "sid" ]; then
base_yaml="${base_yaml}:kas/opt/sid.yml"; fi
- if [ "${encrypt}" = "enable" ]; then
base_yaml="${base_yaml}:kas/opt/encrypt-data.yml"; fi
- if [ "${factory_reset}" = "enable" ]; then
base_yaml="${base_yaml}:kas/opt/factory-reset.yml"; fi
@@ -399,6 +401,57 @@ build:qemu-arm-base-sid:
separate_home_partition: enable
deploy: enable
+# forky image builds
+.build_base_forky:
+ extends:
+ - .build_base
+ rules:
+ - if: $CI_COMMIT_TAG
+ when: never
+ - if: '$CI_PIPELINE_SOURCE == "schedule" && $CI_RUN_UNSTABLE'
I meant we should migrate both forky and sid under this one
CI_RUN_UNSTABLE variable. Now we would still have two of them
and would
need to set them both in the pipeline schedule.
My idea was as below,
- The CI variable CI_RUN_UNSTABLE_FORKY is changed to CI_RUN_UNSTABLE,
however CI_RUN_UNSTABLE_SID is not changed in this patch series, will
update in a separate patch as it is not related to this series.
And it was mentioned in the v2 patch series cover letter, I think
you would have missed that.
let me know if required I will change CI_RUN_UNSTABLE_SID to
CI_RUN_UNSTABLE in this series only.
Any comments on this? Shall i include the above change in this patch
series?
please let me know, will send v3 patch series accordingly.
Please rename CI_RUN_UNSTABLE_SID to CI_RUN_UNSTABLE before introducing
forky as another user. Will easy to pipeline maintenance.
Thanks, fixed in v3 patch series.
please check it.
Thanks & Regards
Shivanand K