DAMON development mailing list
 help / color / mirror / Atom feed
 messages from 2025-11-03 12:33:33 to 2025-12-05 10:15:40 UTC [more...]

[PATCH v2] mm/damon/stat: deduplicate intervals_goal setup in damon_stat_build_ctx()
 2025-12-05 10:15 UTC  (2+ messages)

[PATCH] mm/damon/tests/core-kunit: avoid damos_test_commit stack warning
 2025-12-04 15:01 UTC  (2+ messages)

[PATCH] mm/damon: Remove duplicate attrs.intervals_goal at the damon_stat_build_ctx()
 2025-12-03  7:54 UTC  (2+ messages)

[PATCH] mm/damon/core: fix memory leak of repeat mode damon_call_control objects
 2025-12-02 15:18 UTC  (2+ messages)

[PATCH] mm/damon/core: support multiple damon_call_control requests
 2025-12-02  7:55 UTC  (4+ messages)

A rough plan for CPUs/write-only monitoring RFC v3 and future
 2025-12-02  1:45 UTC  (4+ messages)

[sj:damon/next 145/145] mm/memory.c:6213:9: error: implicit declaration of function 'damon_report_page_fault'
 2025-12-02  1:06 UTC 

[sj:damon/next 101/102] checkpatch: WARNING:REPEATED_WORD: Possible repeated word: 'is'
 2025-11-29 17:10 UTC 

[PATCH v2 00/16] mm: remove is_swap_[pte, pmd]() + non-swap entries, introduce leaf entries
 2025-11-27 19:33 UTC  (66+ messages)
` [PATCH v3 01/16] mm: correctly handle UFFD PTE markers
` [PATCH v3 02/16] mm: introduce leaf entry type and use to simplify leaf entry logic
` [PATCH v3 03/16] mm: avoid unnecessary uses of is_swap_pte()
` [PATCH v3 04/16] mm: eliminate is_swap_pte() when softleaf_from_pte() suffices
` [PATCH v3 05/16] mm: use leaf entries in debug pgtable + remove is_swap_pte()
` [PATCH v3 06/16] fs/proc/task_mmu: refactor pagemap_pmd_range()
` [PATCH v3 07/16] mm: avoid unnecessary use of is_swap_pmd()
` [PATCH v3 08/16] mm/huge_memory: refactor copy_huge_pmd() non-present logic
` [PATCH v3 09/16] mm/huge_memory: refactor change_huge_pmd() "
` [PATCH v3 10/16] mm: replace pmd_to_swp_entry() with softleaf_from_pmd()
` [PATCH v3 11/16] mm: introduce pmd_is_huge() and use where appropriate
` [PATCH v3 12/16] mm: remove remaining is_swap_pmd() users and is_swap_pmd()
` [PATCH v3 13/16] mm: remove non_swap_entry() and use softleaf helpers instead
` [PATCH v3 14/16] mm: remove is_hugetlb_entry_[migration, hwpoisoned]()
` [PATCH v3 15/16] mm: eliminate further swapops predicates
` [PATCH v3 16/16] mm: replace remaining pte_to_swp_entry() with softleaf_from_pte()

DAMON Beer/Coffee/Tea chat reminder for the week of 2025-11-24
 2025-11-25  1:58 UTC 

[RFC PATCH 00/12] mm/damos/stat: introduce nr_snapshots, max_nr_snapshots and tracepoint
 2025-11-24 15:37 UTC  (16+ messages)
` [RFC PATCH 01/12] mm/damon/core: introduce nr_snapshots damos stat
` [RFC PATCH 02/12] mm/damon/sysfs-schemes: introduce nr_snapshots damos stat file
` [RFC PATCH 03/12] Docs/mm/damon/design: update for nr_snapshots damos stat
` [RFC PATCH 04/12] Docs/admin-guide/mm/damon/usage: "
` [RFC PATCH 05/12] Docs/ABI/damon: "
` [RFC PATCH 06/12] mm/damon: update damos kerneldoc for stat field
` [RFC PATCH 07/12] mm/damon/core: implement max_nr_snapshots
` [RFC PATCH 08/12] mm/damon/sysfs-schemes: implement max_nr_snapshots file
` [RFC PATCH 09/12] Docs/mm/damon/design: update for max_nr_snapshots
` [RFC PATCH 10/12] Docs/admin-guide/mm/damon/usage: "
` [RFC PATCH 11/12] Docs/ABI/damon: "
` [RFC PATCH 12/12] mm/damon/core: add trace point for damos stat per apply interval

[PATCH next] mm/damon/tests/sysfs-kunit: fix use after free on error path
 2025-11-21 16:35 UTC  (2+ messages)

[Linux Memory Hotness and Promotion] Notes from October 23, 2025
 2025-11-21  2:27 UTC  (3+ messages)

[PATCH 0/9] mm/damon: misc cleanups
 2025-11-17 15:44 UTC  (11+ messages)
` [PATCH 1/9] mm/damon: rename damos core filter helpers to have word core
` [PATCH 2/9] mm/damon: rename damos->filters to damos->core_filters
` [PATCH 3/9] mm/damon/vaddr: cleanup using pmd_trans_huge_lock()
` [PATCH 4/9] mm/damon/vaddr: use vm_normal_folio{,_pmd}() instead of damon_get_folio()
` [PATCH 5/9] mm/damon/vaddr: consistently use only pmd_entry for damos_migrate
` [PATCH 6/9] mm/damon/tests/core-kunit: remove DAMON_MIN_REGION redefinition
` [PATCH 7/9] selftests/damon/sysfs.py: merge DAMON status dumping into commitment assertion
` [PATCH 8/9] Docs/mm/damon/maintainer-profile: fix a typo on mm-untable link
` [PATCH 9/9] Docs/mm/damon/maintainer-profile: fix grammartical errors

[PATCH 00/11] mm/damon/tests: add more tests for online parameters commit
 2025-11-11 18:44 UTC  (12+ messages)
` [PATCH 01/11] mm/damon/tests/core-kunit: remove dynamic allocs on damos_test_commit_filter()
` [PATCH 02/11] mm/damon/tests/core-kunit: split out damos_test_commit_filter() core logic
` [PATCH 03/11] mm/damon/tests/core-kunit: extend damos_test_commit_filter_for() for union fields
` [PATCH 04/11] mm/damon/tests/core-kunit: add test cases to damos_test_commit_filter()
` [PATCH 05/11] mm/damon/tests/core-kunit: add damos_commit_quota_goal() test
` [PATCH 06/11] mm/damon/tests/core-kunit: add damos_commit_quota_goals() test
` [PATCH 07/11] mm/damon/tests/core-kunit: add damos_commit_quota() test
` [PATCH 08/11] mm/damon/core: pass migrate_dests to damos_commit_dests()
` [PATCH 09/11] mm/damon/tests/core-kunit: add damos_commit_dests() test
` [PATCH 10/11] mm/damon/tests/core-kunit: add damos_commit() test
` [PATCH 11/11] mm/damon/tests/core-kunit: add damon_commit_target_regions() test

[PATCH v2 00/16] mm: remove is_swap_[pte, pmd]() + non-swap entries, introduce leaf entries
 2025-11-11 10:03 UTC  (44+ messages)
` [PATCH v2 01/16] mm: correctly handle UFFD PTE markers
` [PATCH v2 02/16] mm: introduce leaf entry type and use to simplify leaf entry logic
` [PATCH v2 03/16] mm: avoid unnecessary uses of is_swap_pte()
` [PATCH v2 04/16] mm: eliminate is_swap_pte() when softleaf_from_pte() suffices
` [PATCH v2 05/16] mm: use leaf entries in debug pgtable + remove is_swap_pte()
` [PATCH v2 06/16] fs/proc/task_mmu: refactor pagemap_pmd_range()
` [PATCH v2 07/16] mm: avoid unnecessary use of is_swap_pmd()
` [PATCH v2 08/16] mm/huge_memory: refactor copy_huge_pmd() non-present logic
` [PATCH v2 09/16] mm/huge_memory: refactor change_huge_pmd() "
` [PATCH v2 10/16] mm: replace pmd_to_swp_entry() with softleaf_from_pmd()
` [PATCH v2 11/16] mm: introduce pmd_is_huge() and use where appropriate
` [PATCH v2 12/16] mm: remove remaining is_swap_pmd() users and is_swap_pmd()
` [PATCH v2 13/16] mm: remove non_swap_entry() and use softleaf helpers instead
` [PATCH v2 14/16] mm: remove is_hugetlb_entry_[migration, hwpoisoned]()
` [PATCH v2 15/16] mm: eliminate further swapops predicates
` [PATCH v2 16/16] mm: replace remaining pte_to_swp_entry() with softleaf_from_pte()

DAMON Beer/Coffee/Tea chat reminder for the week of 2025-11-10
 2025-11-08  4:07 UTC 

[PATCH 00/16] mm: remove is_swap_[pte, pmd]() + non-swap entries, introduce leaf entries
 2025-11-05 21:47 UTC  (31+ messages)
` [PATCH 01/16] mm: correctly handle UFFD PTE markers
` [PATCH 02/16] mm: introduce leaf entry type and use to simplify leaf entry logic
` [PATCH 10/16] mm: replace pmd_to_swp_entry() with leafent_from_pmd()
` [PATCH 13/16] mm: remove non_swap_entry() and use leaf entry helpers instead
` [PATCH 16/16] mm: replace remaining pte_to_swp_entry() with leafent_from_pte()


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox