From: Gerrit Renker <gerrit@erg.abdn.ac.uk>
To: dccp@vger.kernel.org
Subject: Re: [PATCH 3/6]: Migrate to new naming scheme, using macro to declare cache
Date: Sun, 17 Jun 2007 10:43:01 +0000 [thread overview]
Message-ID: <200706171143.01292@strip-the-willow> (raw)
In-Reply-To: <200706111341.49697@strip-the-willow>
Quoting Ian McDonald:
| On 6/17/07, Gerrit Renker <gerrit@erg.abdn.ac.uk> wrote:
| > Ian McDonald wrote:
| > | > [TFRC]: Migrate to new naming scheme, using macro to declare cache
| > | >
| > | I agree totally with the intent. I reworked li_hist as well but
| > | Arnaldo decided to do in a better way and I think he'll want the same
| > | for this also.
| > Is this an Ack?
|
| Not yet - it's saying look at his patch and see if you want to match
| his style...
Difficult to see what is meant. I think that my set mirrors in a way what Arnaldo
does in the spirit, but not in detail. Since in the end the approach is different.
But the principles are similar:
* also use explicit allocation/deallocation routines
* also put the slab allocation into the module, as Arnaldos patch
* effectively the same functions are removed in my changeset
* as discussed earlier, modularity of calc_first_li is achieved by using a function pointer.
=> wonder whether I should add `__read_mostly' to the slab declaration, but that is
a smaller issue. I will think about this.
The main difference is that in my changeset further functionality is implemented which
intersects with the work Arnaldo has been doing.
| >
| > | See his patch (which is in Dave M's tree now) at:
| > | http://www.mail-archive.com/dccp@vger.kernel.org/msg01879.html
| > |
next prev parent reply other threads:[~2007-06-17 10:43 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-06-11 12:41 [PATCH 3/6]: Migrate to new naming scheme, using macro to declare cache Gerrit Renker
2007-06-16 22:54 ` Ian McDonald
2007-06-17 10:12 ` Gerrit Renker
2007-06-17 10:28 ` Ian McDonald
2007-06-17 10:43 ` Gerrit Renker [this message]
2007-06-17 22:59 ` Ian McDonald
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=200706171143.01292@strip-the-willow \
--to=gerrit@erg.abdn.ac.uk \
--cc=dccp@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox