From: "Łeandro Sales" <leandroal@gmail.com>
To: dccp@vger.kernel.org
Subject: Re: [PATCH 13/25] Share TFRC feedback types struct via ccid34_lib
Date: Wed, 31 Oct 2007 22:21:10 +0000 [thread overview]
Message-ID: <5bc4c4570710311521o682bd3btc540263f2bcda9bf@mail.gmail.com> (raw)
In-Reply-To: <200710310959.15075@strip-the-willow>
2007/10/31, Gerrit Renker <gerrit@erg.abdn.ac.uk>:
> Leandro,
>
> following Arnaldo's reply, can you please you the suggested naming scheme (it is also
> already used in packet_history.c and loss_interval.c): I will be looking into merging
> the patches with the CCID3 set of patches, to reduce work and duplication.
>
> The whole lot of CCID3 patches will then be re-submitted. Arnaldo, I would like to make
> your job easier by sending fewer patches (the CCID3 batch is 40 patches, plus Leandro's):
> would you be ok with a smaller number, e.g. 5..7?
>
> There will also be a short RFC before this (regarding locking), and I will make sure that
> the entire batch becomes fully bisectable.
>
> Gerrit
>
> Quoting Arnaldo Carvalho de Melo:
> | > enum tfrc_fback_type {
> | > // ...
> | > };
> | >
> | > instead of:
> | >
> | > | enum ccid34_fback_type {
> | > | + FBACK_NONE = 0,
> | > | + FBACK_INITIAL,
> | > | + FBACK_PERIODIC,
> | > | + FBACK_PARAM_CHANGE
> | > | +};
> | >
> | > There are no mechanisms other than TFRC (current work builds around TFRC, rather than entirely new schemes)
> | > so I think that this naming scheme is safe; and it would be consistent throughout the library.
> | >
> | > I'd hope that Arnaldo and Ian add their take if they disagree or have other suggestions.
> |
> | I agree that for things which concept comes from TFRC and are used in
> | one of the TFRC based DCCP CCIDs the best possible namespace is tfrc_.
> | If not we'll have to rename everything again when CCID5 comes if it is
> | also based on TFRC 8-)
> |
> | And after all, even before ccid4 appeared on the radar I created
> | dccp_tfrc_lib, include/linux/tfrc.h, etc exactly for sharing code with
> | potentially new CCIDs that were based on TFRC.
> |
>
Hello Gerrit,
Yes, for sure! I also agree with you and Arnaldo on this and I'm
currently change to the namespace suggested by you and accepted by
Arnaldo.
Leandro
next prev parent reply other threads:[~2007-10-31 22:21 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-10-31 9:59 [PATCH 13/25] Share TFRC feedback types struct via ccid34_lib Gerrit Renker
2007-10-31 11:55 ` Arnaldo Carvalho de Melo
2007-10-31 13:15 ` Gerrit Renker
2007-10-31 22:21 ` Łeandro Sales [this message]
2007-11-01 0:31 ` [PATCH 13/25] Share TFRC feedback types struct via tfrc_ccids Leandro
2007-11-01 12:29 ` Tommi Saviranta
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=5bc4c4570710311521o682bd3btc540263f2bcda9bf@mail.gmail.com \
--to=leandroal@gmail.com \
--cc=dccp@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox