From: Martin Wilck <mwilck@suse.com>
To: Benjamin Marzinski <bmarzins@redhat.com>,
device-mapper development <dm-devel@redhat.com>
Subject: Re: [PATCH 2/2] multipath: fix rcu thread cancellation hang
Date: Fri, 23 Mar 2018 22:09:23 +0100 [thread overview]
Message-ID: <1521839363.13100.119.camel@suse.com> (raw)
In-Reply-To: <1521835246-29080-3-git-send-email-bmarzins@redhat.com>
On Fr, 2018-03-23 at 15:00 -0500, Benjamin Marzinski wrote:
> While the rcu code is waiting for a grace period to elapse, no
> threads
> can register or unregister as rcu reader threads. If for some reason,
> a
> thread never calls put_multipath_config() to exit a read side
> critical
> section, then any threads trying to start or stop will hang. This can
> happen if a thread is cancelled between calls to
> get_multipath_config()
> and put_multipath_config(), and multipathd is reconfigured (which
> causes
> the rcu code to wait for a grace period).
>
> This patch fixes this issue in two ways. Where possible, it reorders
> the
> code or saves config values into local variables to remove
> cancellation
> points between calls to get_multipath_config() and
> put_multipath_config(). In cases where this isn't possible (or where
> it
> would cause a significant amount of extra work to be done) multipath
> now
> pushes a cleanup handler to call put_multipath_config().
>
> The only functions that were not modified were ones that were only
> called by multipath or mpathpersist, since these are single threaded
> and already disable rcu thread registration.
>
> Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
Kudos for doing this meticulous work!
Reviewed-by: Martin Wilck <mwilck@suse.com>
(I admit my review wasn't in depth. I fully ack the idea of the patch,
and I scanned through it without spotting obvious errors. I did not
check whether you should have changed more code as you already did).
Here's a suggestion, as I think this is getting pretty ugly (not your
fault). Maybe we should rename get_multipath_config() to
__get_multipath_config() and do something like
#define begin_with_config(conf) \
__get_multipath_config(conf); \
pthread_cleanup_push(__put_multipath_config, conf); \
do
#define end_with_config(conf) \
while(0); \
pthread_cleanup_pop(1)
... and require that all code blocks accessing the configuration should
be coded like this:
begin_with_config(conf) {
... CODE ...
} end_with_config(conf);
IMO that'd improve readability and reduce likelihood of errors.
As you're touching so many lines of code anyway, that wouldn't be that
much harder :-/
Regards,
Martin
--
Dr. Martin Wilck <mwilck@suse.com>, Tel. +49 (0)911 74053 2107
SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton
HRB 21284 (AG Nürnberg)
--
dm-devel mailing list
dm-devel@redhat.com
https://www.redhat.com/mailman/listinfo/dm-devel
prev parent reply other threads:[~2018-03-23 21:09 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-03-23 20:00 [PATCH 0/2] Fix RCU hang Benjamin Marzinski
2018-03-23 20:00 ` [PATCH 1/2] multipathd: register threads that use rcu calls Benjamin Marzinski
2018-03-23 20:56 ` Martin Wilck
2018-03-23 20:00 ` [PATCH 2/2] multipath: fix rcu thread cancellation hang Benjamin Marzinski
2018-03-23 21:09 ` Martin Wilck [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1521839363.13100.119.camel@suse.com \
--to=mwilck@suse.com \
--cc=bmarzins@redhat.com \
--cc=dm-devel@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox