From: Benjamin Marzinski <bmarzins@redhat.com>
To: mwilck@suse.com
Cc: dm-devel@redhat.com
Subject: Re: [dm-devel] [PATCH v2 24/37] libmultipath: simplify get_free_id() assuming total ordering
Date: Tue, 12 Sep 2023 17:59:11 -0500 [thread overview]
Message-ID: <20230912225911.GM7412@octiron.msp.redhat.com> (raw)
In-Reply-To: <20230911163846.27197-25-mwilck@suse.com>
On Mon, Sep 11, 2023 at 06:38:33PM +0200, mwilck@suse.com wrote:
> From: Martin Wilck <mwilck@suse.com>
>
> If we can assume that the bindings array is totally ordered for every
> prefix, which the previous patch guarantees, the search for a free ID can be
> simplified.
>
Reviewed-by: Benjamin Marzinski <bmarzins@redhat.com>
> Signed-off-by: Martin Wilck <mwilck@suse.com>
> ---
> libmultipath/alias.c | 87 ++++++++++----------------------------------
> 1 file changed, 19 insertions(+), 68 deletions(-)
>
> diff --git a/libmultipath/alias.c b/libmultipath/alias.c
> index af6565b..66e34e3 100644
> --- a/libmultipath/alias.c
> +++ b/libmultipath/alias.c
> @@ -356,83 +356,34 @@ int get_free_id(const Bindings *bindings, const char *prefix, const char *map_ww
> {
> const struct binding *bdg;
> int i, id = 1;
> - int biggest_id = 1;
> - int smallest_bigger_id = INT_MAX;
>
> vector_foreach_slot(bindings, bdg, i) {
> int curr_id = scan_devname(bdg->alias, prefix);
>
> - /*
> - * Find an unused index - explanation of the algorithm
> - *
> - * ID: 1 = mpatha, 2 = mpathb, ...
> - *
> - * We assume the bindings are unsorted. The only constraint
> - * is that no ID occurs more than once. IDs that occur in the
> - * bindings are called "used".
> - *
> - * We call the list 1,2,3,..., exactly in this order, the list
> - * of "expected" IDs. The variable "id" always holds the next
> - * "expected" ID, IOW the last "expected" ID encountered plus 1.
> - * Thus all IDs below "id" are known to be used. However, at the
> - * end of the loop, the value of "id" isn't necessarily unused.
> - *
> - * "smallest_bigger_id" is the smallest used ID that was
> - * encountered while it was larger than the next "expected" ID
> - * at that iteration. Let X be some used ID. If all IDs below X
> - * are used and encountered in the right sequence before X, "id"
> - * will be > X when the loop ends. Otherwise, X was encountered
> - * "out of order", the condition (X > id) holds when X is
> - * encountered, and "smallest_bigger_id" will be set to X; i.e.
> - * it will be less or equal than X when the loop ends.
> - *
> - * At the end of the loop, (id < smallest_bigger_id) means that
> - * the value of "id" had been encountered neither in order nor
> - * out of order, and is thus unused. (id >= smallest_bigger_id)
> - * means that "id"'s value is in use. In this case, we play safe
> - * and use "biggest_id + 1" as the next value to try.
> - *
> - * biggest_id is always > smallest_bigger_id, except in the
> - * "perfectly ordered" case.
> - */
> - if (curr_id == id) {
> - if (id < INT_MAX)
> - id++;
> - else {
> - id = -1;
> - break;
> - }
> + if (curr_id == -1)
> + continue;
> + if (id > curr_id) {
> + condlog(0, "%s: ERROR: bindings are not sorted", __func__);
> + return -1;
> }
> - if (curr_id > biggest_id)
> - biggest_id = curr_id;
> -
> - if (curr_id > id && curr_id < smallest_bigger_id)
> - smallest_bigger_id = curr_id;
> - }
> -
> - if (id >= smallest_bigger_id)
> - id = biggest_id < INT_MAX ? biggest_id + 1 : -1;
> -
> - if (id > 0) {
> - while(id_already_taken(id, prefix, map_wwid)) {
> - if (id == INT_MAX) {
> - id = -1;
> - break;
> - }
> + while (id < curr_id && id_already_taken(id, prefix, map_wwid))
> id++;
> - if (id == smallest_bigger_id) {
> - if (biggest_id == INT_MAX) {
> - id = -1;
> - break;
> - }
> - if (biggest_id >= smallest_bigger_id)
> - id = biggest_id + 1;
> - }
> - }
> + if (id < curr_id)
> + return id;
> + id++;
> + if (id <= 0)
> + break;
> }
>
> - if (id < 0)
> + for (; id > 0; id++) {
> + if (!id_already_taken(id, prefix, map_wwid))
> + break;
> + }
> +
> + if (id <= 0) {
> + id = -1;
> condlog(0, "no more available user_friendly_names");
> + }
> return id;
> }
>
> --
> 2.42.0
--
dm-devel mailing list
dm-devel@redhat.com
https://listman.redhat.com/mailman/listinfo/dm-devel
next prev parent reply other threads:[~2023-09-12 22:59 UTC|newest]
Thread overview: 68+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-09-11 16:38 [dm-devel] [PATCH v2 00/37] multipath-tools: user-friendly names rework mwilck
2023-09-11 16:38 ` [dm-devel] [PATCH v2 01/37] libmultipath: sysfs_set_scsi_tmo: do nothing for ACT_DRY_RUN mwilck
2023-09-11 16:38 ` [dm-devel] [PATCH v2 02/37] libmultipath: add alias_already_taken() mwilck
2023-09-12 22:59 ` Benjamin Marzinski
2023-09-11 16:38 ` [dm-devel] [PATCH v2 03/37] libmultipath: unify use_existing_alias() and get_user_friendly_alias() mwilck
2023-09-11 16:38 ` [dm-devel] [PATCH v2 04/37] libmultipath: never allocate an alias that's already taken mwilck
2023-09-12 23:00 ` Benjamin Marzinski
2023-09-11 16:38 ` [dm-devel] [PATCH v2 05/37] libmultipath: lookup_binding: add comment about the algorithm mwilck
2023-09-11 16:38 ` [dm-devel] [PATCH v2 06/37] multipath-tools test: simplify debugging for condlog mismatch mwilck
2023-09-11 16:38 ` [dm-devel] [PATCH v2 07/37] multipath-tools tests: add tests for get_user_friendly_alias() mwilck
2023-09-12 23:00 ` Benjamin Marzinski
2023-09-11 16:38 ` [dm-devel] [PATCH v2 08/37] multipath-tools test: consistent use of macros in alias test mwilck
2023-09-11 16:38 ` [dm-devel] [PATCH v2 09/37] multipath-tools tests: convert mock_{failed, used}_alias to macros mwilck
2023-09-11 16:38 ` [dm-devel] [PATCH v2 10/37] multipath-tools test: use mock_bindings_file() consistently mwilck
2023-09-11 16:38 ` [dm-devel] [PATCH v2 11/37] libmultipath: add global variable for current bindings mwilck
2023-09-11 16:38 ` [dm-devel] [PATCH v2 12/37] libmultipath: rename fix_bindings_file() to update_bindings_file() mwilck
2023-09-11 16:38 ` [dm-devel] [PATCH v2 13/37] libmultipath: alias.c: move bindings related code up mwilck
2023-09-11 16:38 ` [dm-devel] [PATCH v2 14/37] libmultipath: update_bindings_file: take filename argument mwilck
2023-09-11 16:38 ` [dm-devel] [PATCH v2 15/37] libmultipath: update_bindings_file: use a single write() mwilck
2023-09-11 16:38 ` [dm-devel] [PATCH v2 16/37] libmultipath: update_bindings_file: don't log temp file name mwilck
2023-09-11 16:38 ` [dm-devel] [PATCH v2 17/37] libmultipath: alias.c: factor out read_binding() mwilck
2023-09-11 16:38 ` [dm-devel] [PATCH v2 18/37] libmultipath: keep bindings in memory mwilck
2023-09-12 23:00 ` Benjamin Marzinski
2023-09-11 16:38 ` [dm-devel] [PATCH v2 19/37] multipath-tools tests: fix alias tests mwilck
2023-09-12 22:02 ` Benjamin Marzinski
2023-09-11 16:38 ` [dm-devel] [PATCH v2 20/37] libmultipath: dm_get_uuid(): return emtpy UUID for non-existing maps mwilck
2023-09-11 16:38 ` [dm-devel] [PATCH v2 21/37] libmultipath: adapt to new semantics of dm_get_uuid() mwilck
2023-09-11 16:38 ` [dm-devel] [PATCH v2 22/37] libmultipath: sort aliases by length and strcmp mwilck
2023-09-12 23:00 ` Benjamin Marzinski
2023-09-13 13:53 ` Martin Wilck
2023-09-13 14:38 ` Benjamin Marzinski
2023-09-13 19:07 ` Martin Wilck
2023-09-13 23:15 ` Benjamin Marzinski
2023-09-11 16:38 ` [dm-devel] [PATCH v2 23/37] multipath-tools tests: fix alias test after sort order change mwilck
2023-09-12 23:01 ` Benjamin Marzinski
2023-09-11 16:38 ` [dm-devel] [PATCH v2 24/37] libmultipath: simplify get_free_id() assuming total ordering mwilck
2023-09-12 22:59 ` Benjamin Marzinski [this message]
2023-09-11 16:38 ` [dm-devel] [PATCH v2 25/37] multipath-tools tests: adapt alias tests for " mwilck
2023-09-12 23:01 ` Benjamin Marzinski
2023-09-11 16:38 ` [dm-devel] [PATCH v2 26/37] multipath-tools tests: add test for ordering of bindings mwilck
2023-09-12 23:05 ` Benjamin Marzinski
2023-09-12 23:20 ` Benjamin Marzinski
2023-09-13 14:05 ` Martin Wilck
2023-09-11 16:38 ` [dm-devel] [PATCH v2 27/37] multipathd: watch bindings file with inotify + timestamp mwilck
2023-09-13 22:07 ` Benjamin Marzinski
2023-09-14 13:25 ` Martin Wilck
2023-09-14 14:28 ` Martin Wilck
2023-09-14 15:00 ` Benjamin Marzinski
2023-09-11 16:38 ` [dm-devel] [PATCH v2 28/37] multipath-tools tests: mock pthread_mutex_{lock, unlock} mwilck
2023-09-13 22:18 ` Benjamin Marzinski
2023-09-11 16:38 ` [dm-devel] [PATCH v2 29/37] multipath-tools Makefile: sanitize paths for configuration files mwilck
2023-09-13 22:30 ` Benjamin Marzinski
2023-09-11 16:38 ` [dm-devel] [PATCH v2 30/37] multipath-tools: add compile time configuration for "/etc/multipath" mwilck
2023-09-13 22:32 ` Benjamin Marzinski
2023-09-11 16:38 ` [dm-devel] [PATCH v2 31/37] multipath-tools man pages: generate with correct paths mwilck
2023-09-13 22:44 ` Benjamin Marzinski
2023-09-11 16:38 ` [dm-devel] [PATCH v2 32/37] libdmmp/Makefile: fix bug in install section mwilck
2023-09-13 22:46 ` Benjamin Marzinski
2023-09-11 16:38 ` [dm-devel] [PATCH v2 33/37] multipath-tools: README.md: improve documentation for compile-time options mwilck
2023-09-13 22:58 ` Benjamin Marzinski
2023-09-11 16:38 ` [dm-devel] [PATCH v2 34/37] libmultipath: print built-in values for deprecated options mwilck
2023-09-13 23:05 ` Benjamin Marzinski
2023-09-11 16:38 ` [dm-devel] [PATCH v2 35/37] multipath: add a missing newline mwilck
2023-09-13 23:05 ` Benjamin Marzinski
2023-09-11 16:38 ` [dm-devel] [PATCH v2 36/37] multipath-tools: allow prefixes with and w/o trailing slash mwilck
2023-09-13 23:09 ` Benjamin Marzinski
2023-09-11 16:38 ` [dm-devel] [PATCH v2 37/37] libmultipath: deprecate bindings_file, wwids_file, prkeys_file mwilck
2023-09-13 23:13 ` Benjamin Marzinski
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20230912225911.GM7412@octiron.msp.redhat.com \
--to=bmarzins@redhat.com \
--cc=dm-devel@redhat.com \
--cc=mwilck@suse.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox