From mboxrd@z Thu Jan 1 00:00:00 1970 From: Thomas Monjalon Subject: Re: [PATCH] doc: announce xstats api change for 16.07 Date: Tue, 05 Apr 2016 20:45:54 +0200 Message-ID: <1955261.zYXyGahjVu@xps13> References: <1459879089-3430-1-git-send-email-harry.van.haaren@intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7Bit Cc: dev@dpdk.org, maryam.tahhan@intel.com To: Harry van Haaren Return-path: Received: from mail-wm0-f54.google.com (mail-wm0-f54.google.com [74.125.82.54]) by dpdk.org (Postfix) with ESMTP id 03F552C39 for ; Tue, 5 Apr 2016 20:47:33 +0200 (CEST) Received: by mail-wm0-f54.google.com with SMTP id 191so34023432wmq.0 for ; Tue, 05 Apr 2016 11:47:33 -0700 (PDT) In-Reply-To: <1459879089-3430-1-git-send-email-harry.van.haaren@intel.com> List-Id: patches and discussions about DPDK List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" 2016-04-05 18:58, Harry van Haaren: > +* ABI change is planned for the xstats API and rte_eth_xstats struct, to > + facilitate updating to an API that allows retrieval of values without any > + string copies or parsing. No backwards compatibility is planned, as it would > + require code duplication in every PMD that supports xstats. Have you already submitted a RFC patch to let us have an opinion on the change? We need, at least, to see the structure changes. Thanks