From mboxrd@z Thu Jan 1 00:00:00 1970 From: Yuanhan Liu Subject: Re: [PATCH 5/6] vhost: add a flag to enable Tx zero copy Date: Tue, 6 Sep 2016 17:55:48 +0800 Message-ID: <20160906095548.GB23158@yliu-dev.sh.intel.com> References: <1471939839-29778-1-git-send-email-yuanhan.liu@linux.intel.com> <1471939839-29778-6-git-send-email-yuanhan.liu@linux.intel.com> <82F45D86ADE5454A95A89742C8D1410E3912C500@shsmsx102.ccr.corp.intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Cc: "dev@dpdk.org" , Maxime Coquelin To: "Xu, Qian Q" Return-path: Received: from mga06.intel.com (mga06.intel.com [134.134.136.31]) by dpdk.org (Postfix) with ESMTP id 35A325A38 for ; Tue, 6 Sep 2016 11:43:42 +0200 (CEST) Content-Disposition: inline In-Reply-To: <82F45D86ADE5454A95A89742C8D1410E3912C500@shsmsx102.ccr.corp.intel.com> List-Id: patches and discussions about DPDK List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" On Tue, Sep 06, 2016 at 09:00:14AM +0000, Xu, Qian Q wrote: > Just curious about the naming: vhost USER TX Zero copy. In fact, it's Vhost RX zero-copy > For virtio, it's Virtio TX zero-copy. So, I wonder why we call it as Vhost TX ZERO-COPY, > Any comments? It's just that "Tx zero copy" looks more nature to me (yes, I took the name from the virtio point of view). Besides that, naming it to "vhost Rx zero copy" would be a little weird, based on we have functions like "virtio_dev_rx" in the enqueue path while here we just touch dequeue path. OTOH, I seldome say "vhost-user Tx zero copy"; I normally mention it as "Tx zero copy", without mentioning "vhost-user". For the flag RTE_VHOST_USER_TX_ZERO_COPY, all vhost-user flags start with "RTE_VHOST_USER_" prefix. --yliu