From mboxrd@z Thu Jan 1 00:00:00 1970 From: Thomas Monjalon Subject: [PATCH 1/2] doc: remove outdated deprecation notices Date: Thu, 11 May 2017 02:25:53 +0200 Message-ID: <20170511002554.7891-1-thomas@monjalon.net> To: dev@dpdk.org Return-path: Received: from out4-smtp.messagingengine.com (out4-smtp.messagingengine.com [66.111.4.28]) by dpdk.org (Postfix) with ESMTP id 49AF1106A for ; Thu, 11 May 2017 02:26:07 +0200 (CEST) Received: from xps.monjalon.net (184.203.134.77.rev.sfr.net [77.134.203.184]) by mail.messagingengine.com (Postfix) with ESMTPA id 545BB24996 for ; Wed, 10 May 2017 20:26:06 -0400 (EDT) List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" Some VFIO functions have been exported without any rename, thus no breakage. The struct eth_driver has been removed, but rte_pci_driver is still used in rte_cryptodev_driver. Fixes: a016873eb3c2 ("vfio: export utility functions in map file") Fixes: 9dca21fb80b6 ("ethdev: remove ethdev driver") Signed-off-by: Thomas Monjalon --- doc/guides/rel_notes/deprecation.rst | 11 +---------- 1 file changed, 1 insertion(+), 10 deletions(-) diff --git a/doc/guides/rel_notes/deprecation.rst b/doc/guides/rel_notes/deprecation.rst index f6d28fe97..f38c13f31 100644 --- a/doc/guides/rel_notes/deprecation.rst +++ b/doc/guides/rel_notes/deprecation.rst @@ -28,19 +28,10 @@ Deprecation Notices has exposed, like the way we have done with uio-pci-generic. This change targets release 17.05. -* vfio: Some functions are planned to be exported outside librte_eal in 17.05. - VFIO APIs like ``vfio_setup_device``, ``vfio_get_group_fd`` can be used by - subsystem other than EAL/PCI. For that, these need to be exported symbols. - Such APIs are planned to be renamed according to ``rte_*`` naming convention - and exported from librte_eal. - * The VDEV subsystem will be converted as driver of the new bus model. It will imply some EAL API changes in 17.05. -* ``eth_driver`` is planned to be removed in 17.05. This currently serves as - a placeholder for PMDs to register themselves. Changes for ``rte_bus`` will - provide a way to handle device initialization currently being done in - ``eth_driver``. Similarly, ``rte_pci_driver`` is planned to be removed from +* The struct ``rte_pci_driver`` is planned to be removed from ``rte_cryptodev_driver`` in 17.05. * ethdev: An API change is planned for 17.08 for the function -- 2.12.2