From mboxrd@z Thu Jan 1 00:00:00 1970 From: Bruce Richardson Subject: Re: [PATCH v6 1/2] mem: balanced allocation of hugepages Date: Wed, 21 Jun 2017 10:34:05 +0100 Message-ID: <20170621093405.GA19848@bricha3-MOBL3.ger.corp.intel.com> References: <1496756020-4579-1-git-send-email-i.maximets@samsung.com> <1498032250-24924-2-git-send-email-i.maximets@samsung.com> <3630286.1QuNDLyk9u@xps> <20170621085844.GA93740@bricha3-MOBL3.ger.corp.intel.com> <36e228bb-1f27-4464-7597-4000fcb1d9f7@samsung.com> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Cc: Thomas Monjalon , dev@dpdk.org, David Marchand , Sergio Gonzalez Monroy , Heetae Ahn , Yuanhan Liu , Jianfeng Tan , Neil Horman , Yulong Pei , Jerin Jacob To: Ilya Maximets Return-path: Received: from mga02.intel.com (mga02.intel.com [134.134.136.20]) by dpdk.org (Postfix) with ESMTP id CD6B14CC5 for ; Wed, 21 Jun 2017 11:34:10 +0200 (CEST) Content-Disposition: inline In-Reply-To: <36e228bb-1f27-4464-7597-4000fcb1d9f7@samsung.com> List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" On Wed, Jun 21, 2017 at 12:25:51PM +0300, Ilya Maximets wrote: > On 21.06.2017 11:58, Bruce Richardson wrote: > > On Wed, Jun 21, 2017 at 10:51:58AM +0200, Thomas Monjalon wrote: > >> 21/06/2017 10:04, Ilya Maximets: > >>> +CONFIG_RTE_LIBRTE_EAL_NUMA_AWARE_HUGEPAGES=n > >> > >> We can stop inserting LIBRTE in our config options. > >> CONFIG_RTE_EAL_ is long enough :) > >> > > Consistency. While I agree it's unneeded should have it in all or none, > > and unless we change a bunch of existing ones, I think it means we have > > it in all. > > Hmm. There are few options named CONFIG_RTE_EAL_* and CONFIG_RTE_LIBRTE_EAL_*. > Also there is one strange CONFIG_RTE_LIBEAL_(USE_HPET). > > Maybe we can prepare the patch to unify all that options later? > Or should I rename CONFIG_RTE_LIBRTE_EAL_NUMA_AWARE_HUGEPAGES to > CONFIG_RTE_EAL_NUMA_AWARE_HUGEPAGES in this series? Sure, if it's already insonsistent for EAL, then use the shorter name. We can fix up the others later. These options may move or disappear if we look to move to a different build system e.g. [1], so that may be a good opportunity to adjust some names. /Bruce [1] http://dpdk.org/dev/patchwork/patch/25104/