From mboxrd@z Thu Jan 1 00:00:00 1970 From: =?iso-8859-1?Q?Ga=EBtan?= Rivet Subject: Re: [PATCH] lib/librte_ether: remove the repeat code Date: Mon, 31 Jul 2017 16:42:58 +0200 Message-ID: <20170731144258.GM11154@bidouze.vm.6wind.com> References: <20170728081014.48104-1-zhiyong.yang@intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset=iso-8859-1 Content-Transfer-Encoding: 8bit Cc: dev@dpdk.org, thomas@monjalon.net To: Zhiyong Yang Return-path: Received: from mail-wr0-f180.google.com (mail-wr0-f180.google.com [209.85.128.180]) by dpdk.org (Postfix) with ESMTP id C425A58CB for ; Mon, 31 Jul 2017 16:43:08 +0200 (CEST) Received: by mail-wr0-f180.google.com with SMTP id v105so149959426wrb.0 for ; Mon, 31 Jul 2017 07:43:08 -0700 (PDT) Content-Disposition: inline In-Reply-To: <20170728081014.48104-1-zhiyong.yang@intel.com> List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" Hi Zhiyong, On Fri, Jul 28, 2017 at 04:10:14PM +0800, Zhiyong Yang wrote: > The code eth_dev->intr_handle = &dev->intr_handle; has duplicate code > in the function rte_eth_copy_pci_info(), remove it here. > > Signed-off-by: Zhiyong Yang Acked-by: Gaetan Rivet > --- > lib/librte_ether/rte_ethdev_pci.h | 1 - > 1 file changed, 1 deletion(-) > > diff --git a/lib/librte_ether/rte_ethdev_pci.h b/lib/librte_ether/rte_ethdev_pci.h > index c3f7f721c..fe2e0f64c 100644 > --- a/lib/librte_ether/rte_ethdev_pci.h > +++ b/lib/librte_ether/rte_ethdev_pci.h > @@ -117,7 +117,6 @@ rte_eth_dev_pci_allocate(struct rte_pci_device *dev, size_t private_data_size) > } > > eth_dev->device = &dev->device; > - eth_dev->intr_handle = &dev->intr_handle; > rte_eth_copy_pci_info(eth_dev, dev); > return eth_dev; > } > -- > 2.13.3 > -- Gaëtan Rivet 6WIND